cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

onitkun
Journeyman III

Random issues with my RX 470 (video signal loss, artifacts & crashing)

Hi guys, so here's the deal. As you can see from the title it's a quite complex problem. I installed this RX470 when battlefield 1 beta came out. In the past two months I've suffered an escalation of various problems, starting from the monitor losign signal and the pc crashing after a couple seconds, then sometimes random square-ish multicolor artifacts came in and just right after the pc crashed, both of these happened randomly from time to time, 90% of the times while watching stuff on streaming sites like youtube. I've had a different and much more annoying issue these past few days, I had the latest non-whql drivers installed and I wanted to test the card so I installed 3D mark, it wouldn't start the tests unless I reinstalled the drivers cause it sensed some random errors. I installed the whql drivers and tried again. As the test started, the pc crashed, and when it got back up, it gave me the same error as before on 3D mark. In addition to that, trying to play Mount & Blade warband or Rising Storm Vietnam it gave me errors related to the absence of a video card or proper drivers. Reinstalling the drivers seemed to help at the time but I just tried to clean uninstall & reinstall the drivers and the games and 3D mark won't start at all, even on a drivers' fresh install. Sys info as follows:

i5-2500K on a P8H67 mobo set on performance

16 gbs crappy Kingston DDR3 ram (6 months life, tested with memtest and fine)

XFX Radeon 470

Windows 10 OS

all stuff installed on a Samsung SSD840 EVO, 250gb

0 Kudos
2 Replies
angryuser1
Elite

Re: Random issues with my RX 470 (video signal loss, artifacts & crashing)

What is your PSU? Have you tried a different PSU or a different PC for your GPU?

0 Kudos
onitkun
Journeyman III

Re: Random issues with my RX 470 (video signal loss, artifacts & crashing)

Corsair CX850. I don't have the possibility to try different PSUs or PCs since I changed the old PSU to this one six months ago cause it was broken.

0 Kudos