Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Random frame drops in SteamVR on Vega 64 with recent drivers

I'm getting seemingly random dropped frames with my Valve Index + Vega 64 setup, which happens with the AMD drivers in 20.10.1 but doesn’t happen with 20.4.2

They can happen even in the empty Steam loading screen, with nothing happening (standing there, not loading a game, just moving my head around). In that case I'll be at 90hz with a frame time of ~11ms. The typical time my system will delivering a frame in will be 1ms, so loads of headroom in theory.

Everything will be buttery smooth, except every 10 seconds or so (but the actual period is random) it will drop a frame or two and stutter. I'll be able to see the dropped frame(s) on the Steam frame timing graph and also in fpsVR.

If I sit in the empty Steam loading screen, I can pretty much guarantee a frame drop if I just move the HMD so it shows or hides the chaperon barrier. At this point the GPU/CPU are very lightly loaded.

I had been on 20.4.2 from back in April 2020, I updated to 20.10.1 in October and found this frame drop problem.

I've spoken to Steam support about it and tried various suggested fixes which didn't work. They have said it is an issue for AMD to address.

For the moment I’ve rolled back to 20.4.2, but it would be nice to get onto a recent driver again at some point.

Has anyone else seen this problem ?

2 Replies
Journeyman III

Same issue here i was just on a vega 64 and now a 6800XT. large purple frametime spike on the graph at random intervals. Nvidia has acknowledged this on their drivers and have apparently fixed it a few days ago. hopefully AMD can figure out the same thing with their drivers. just installed the 21.2.1 and i think it got worse...


Same issue here, and its been this way for a very long time. I cant upgrade further from last summers drivers because i'll get a huge amount of framedrops in VR games, which make most of them unplayble. Im currently on 20.4.2 which has problems of its own but atleast not valve index frametime related. I just tried 21.2.3 but that also still has the same issue, DDU or clean installs dont make any difference either. Incredible how AMD just doesnt fix this, they dont seem to care about the customers of their older toptier products.


R5 3600

X370 taichi

ddr4 3600cl17 @ 3200mhz

vega64 liquid cooled edition

w10 20h2