Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

RAIDXpert2 Array 1 Raid Array Critical Error (Offline) after waking from sleep

Hello all,

First time posting and would really appreciate any help anyone is able to provide.  I have just upgraded to Windows 1909 and in the process, had to upgrade to RAIDXpert2 9.3.0-00038 UWP.  I have an ASRock Killer SLI X370 Motherboard with AMD Ryzen 1700X CPU.  I have also upgraded to AMD Chipset Driver Ver (latest version I could get as of 2 days ago).

My problem now is that whenever my computer goes to sleep, when it wakes up, RAIDXpert2 will see that both my SATA RAID Disks (2 Seagate IronWolf 6TB Drives) in Raid 1 (mirrored) are offline, hence the Raid Array is Offline.  I will not be able to recover the RAID until I restart the system.

Prior to my latest round of upgrades (to Windows 1909 and the Chipset and RAIDXpert2), my system and RAID had no issues with sleeping and waking up.  Any help will be very much appreciated!


56 Replies
Journeyman III

Same here.... on x570 chipset same win10 build

clearly this is a pwm bug... I don't want to have to rescan each time I wake up my computer to add the array back online... I also don't want the HDDS to spin forever and waste energy... 



Same here again on x470 chipset, same win10 build, on my 4 disks RAID0 array.

My disks are 4 Seagate ST6000VN0033-2EE110, firmware SC60.

I have tried to remove ErP, PCIE power save, etc. No way.

Raid Driver and Chipset Driver, up to date today.

Fresh Windows install with all patches.

The bug is immediate : sleep, wake up, the array disappears.

Motherboard Asus Crosshair VII hero (C7H) X470 with last bios 3004 & 3950x.

I'm lucky, because it's not my boot disk; but after a wake up, I have to do

a RAIDXpert2 scan disks manually to (re)find my array. Of course, all applications

which use this array crash before this scan.


Journeyman III

Same here, brand new build X570 Asrock.


Hello Comp615,

What is your disks reference, please ? For my Seagate, the actual firmware (SC60) is old but official. I have found the SC61, unofficial, but I'll take the risk to flash only if your firmware is also seagate SC60.

You have a x570 and an Asrock motherboard. I have a x470 and an Asus. So, our problem only comes from :

- Windows,

- AMD Drivers (RAID and/or Chipset),

- Disk Firmware.

Not from the motherboard BIOS.




I used these disks on a previous mobo with RAID 1 and Windows and it had no trouble resuming from sleep, so for me it's only the AMD setup that changed.

WDC WD3000FYYZ-01UL1B0 -> 01.01KY1

AMD Drivers latest (I've never had anything else since I just swapped the mobo)



Release Notes of RAIDXpert2,  VERSION: RC‑9.2.0–0127, 7/17/2019

[...] Changes from 9.2.0–0120 to 9.2.0–0127 [...]

3. The Identify command failed on one of the drives during hiber resume causing the RAID0 to go offline. Timing issue with the drive initialization/spinup. Fix: Send a second identify command and complete the drive initialization after the drive is online [...]
Seems this fix is not sufficient, AMD! The initialisation/spinup of my Seagate STx0000NVxxxx (here, ST6000NV0033) is from 8 to 15 seconds to my mind. The POST time from resume must be egal to the POST on the BIOS, which (legacy) could be from 5 to 20 seconds, until 30 in some cases.
I have created a task on Windows with the Task Scheduler (taskschd.msc), an administrateur account and the trigger
Event - System Log - Power-Troubleshooter - ID 1 (it's the event Wake Up/Resume of the Windows System Logs). So, when my machine resumes, this .bat is running :
@echo off
timeout /t 10 /nobreak > NUL
"C:\Program Files (x86)\RAIDXpert2\rcadm.exe" -M --rescan > NUL
timeout /t 10 /nobreak > NUL
"C:\Program Files (x86)\RAIDXpert2\rcadm.exe" -M --rescan > NUL
timeout /t 10 /nobreak > NUL
"C:\Program Files (x86)\RAIDXpert2\rcadm.exe" -M --rescan > NUL
It's not perfect, but the disks are visible after ~10 to 15 seconds. Of course, all the applications which use these disks crash. Events in windows are clear: disks dissapear after the resume, and ~10 seconds later, become online.
I have tried to suppress or reduce the timeout commands: not a good idea, only 3 of 5 disks are visible; a reboot is need in this case. The first timeout is really need: if the first rescan is done too early, no disk are visible.
So, AMD, please, do a fix!

Thanks for this, i will pass it directly to the Raid team for consideration. 

Please could you provide your full system specs, Raid/HD setup, and current Raid driver version used?


Not sure if my data change anything, but what I have is:

Specs: ASUS TUF Gaming Plus X570-Plus with Ryzen 5 2600, except HDDs in RAID I have two NVMe drives - ADATA XPG SX6200 Pro and Toshiba XG6 512 GB.


RAIDXpert2: 9.2.0-00105

RAID driver: 9.2.0-00105 (as stated in RAIDXpert2) or (Windows Devices Manager)

RAID Setup: 10 consisting of 8 Seagate ST3000DM001 drives

Windows: 10 Pro x64, v2004, 19592.1001,


Is there an update scheduled to fix this? I have to prevent my PC from sleeping which is not very green, not to mention costly. I was forced to update the AMD drivers last year in order to move to Windows 1903. Prior to that, everything was fine with my system.It went to sleep, woke up for backups and I never had disk issues. Now, I cannot let my PC go to sleep because when it wakes up, one or more disks will show as missing. I can shutdown & reboot without issue, it's just power management that's the problem. There has not been a RAID driver update since November 2019. I'm really hoping that AMD fix this soon. 


Full system spec: cf ALM.LOG.

Config RAID/HD Setup: cf RAIDXpertConfig.PNG

Versions of Chipset & RAIDXpert2: and, full install.

Windows: Version 1909; 18363.270; pro 64 bits; up-to-date today for classical patches.

I will contact Seagate for a possible firmware upgrade (SC60 -> SC61) and some

hacks in these disks with SeaChestUtilities.





Seagate support is not interested by the problem. The SC61 firmware has been created only for special noise on these disks. The documentation of SeaChestUtilities doesn't exist, and the Seagate Support reply is the official NAS list supported by these "specific NAS models", LOL. Thanks, Seagate, for nothing!

Adept I

Same here. I too have this problem.

However I have one more question. I just reinstalled the OS and before I had normal windowed RAIDXpert2. Now I have only webUI. How to restore window version, as web one cannot even readd the lost drive to the array (it sees it as online, but that's all)? It is connected, I can see all disks in BIOS, biut WebUI shows that one is all the time removed. No way to rescan or anything helps...

tl'dr. How to change shitty WebUI back to windowUI?


OK. I managed to add the drive and it is now rebuilding. WebUI is very unintuitive compared to the app, which probably was available in older versions.

And why it is rebuilding? Drive wasn't disconnected, so it should have exactly same data as its mirror, right? It's not system data, nor program data drive or one for game data and I wasn't downloading anything, so there were no changes in it's structure. Still it does it and it takes sooooo loooooong... (had to do it already once and it took +/- 11 hours...)

Adept I

I have the same issue. It started with the upgrade to 1909 and the associated required AMD driver updates late last year. I have 4 arrays with a mixture of WDC, Toshiba, Kingston SSD and Maxtor drives (although each array only has a single manufactures drives).
I have RAID 0, RAID 1, Legacy and a single drive SSD array (marked as RAIDABLE). My system was working with no issues at all for several years until the 1909 + AMD update.
It is usually my RAID 1 array that fails due to 1 drive going offline. But it's 2TB & takes the best part of a week to rebuild (usually fails again before the rebuild finishes). The other arrays do drop as well, but nowhere near as often.

I have  an ASUS ROG STRIX X370-F GAMING Motherboard.
I tried going to the AMD site for drivers rather than ASUS. That was a mistake & it broke my system. I had to rebuild
However, (Ch3mn3y) that is where you get the version of RAIDXpert2 that runs as a local app & not as a web app. I use RAIDXpert2 from AMD but just be careful NOT to install their drivers.
I'm looking forward to an update from AMD via ASUS to fix this as it is becoming very tedious.

Will try ASUS drivers, however had them before and had similar problem (but rsrer I think). Still this time it could be just Winfows messing eith my data, as whole OS broke down after few reboots (now it won't even boot into safe mode...

Journeyman III

Hi All,

I just joined the AMD forum as I am having a very similar issue with RAIDXpert2 arrays to what you all seem to:

I have a new system with an X570 chipset, Windows 10 64-bit v2004 and RAIDXpert2 9.3.0-00038 using only chipset drivers from the AMD website (rather than the ASUS web site). The problem I have is that one of my two RAID10 arrays on (the same) 4 HDDs disappears from the system after a reboot/shutdown and the only way to get it back is to use device manager and "scan for hardware changes". The only difference to what you experienced is that RAIDXpert2 does not report a RAID failure. I wonder if this is a new "bug" or somehow related to the problem you all experienced? Incidentally, the PC cannot enter sleep mode at all - the monitor, keyboard and mouse go on standby but the system stays awake, just completely unresponsive - and rather strangely my UPS shows a 40-50W increase in power consumption!

ASUS tech support suggested I reset my CMOS (full battery pull etc.) to cure it. I have yet to hear back from my AMD tech support ticket.

What's the current situation with your problem - are your systems all working again even with the latest Windows update?

Many thanks,



Hi Jonathan
I think maybe you have a different issue. I never have a problem if I shutdown the system, it's purely when it wakes from sleep. Then one or more disks are not discovered, causing the RAIDs to go bad. A rescan, immediately finds the missing disk(s) and rebuilding starts. 
Last week I updated to Windows 10 version 2004. I decided to let my machine sleep to see if there was still a problem. There was! On waking my 2TB array was marked as bad. It's been rebuilding for the last 3 days & is only 40% complete!

What I have now done is downloaded the latest chipset drivers from AMD (,  released June 3 2020). In the past taking drivers direct from AMD has caused issues booting my system & I have had to restore from backup. So I usually only use the drivers from ASUS. But the notes for this latest release contain the following:
"AMD Ryzen™ Power Plans (required for UEFI CPPC2 in Windows® 10 May 2019 Update)"
So I ran the installer but only selected the installation of the Power Plans. 
I have put my PC to sleep a few times, and so far no issues. I'll test it more fully once my RAID completes rebuilding. Right now I have disabled sleep so that the rebuild runs 24 hours.




Thank you for replying. I have discovered that although at first it looked my PC would not go to sleep, I was just impatient - it does take a few minutes but it does eventually do it! Here's the interesting bit though - RAIDXpert2 reports one physical drive "missing" and marks the arrays as "critical". Doing a re-scan in the GUI does not bring it back, nor does a system restart. The only way was to mark the drive as a "global" spare (in the "uses" column it had "0" so there was no way it was coming back, it's status was "ready" not "online"). The arrays had a "missing" entry instead of the name of the serial number of the physical disk. I wonder if these are two related problems or just coincidence?

The company I purchased the system from think the best course of action is for me to wipe everything and start from scratch and document each step and see if the problem recurs.

I will let you know what happens.




Jonathan, that sounds a bit extreme! Certainly not an option I would like to take. 
I have had the same issue as you on occasions. I have had to add rescanned disks as global spares.
I've also had RAID0 failures due to this issue. I got around that by deleting the array and recreating it with exactly the same parameters, but selecting do not initialise. I can't remember if I did that in RAID Xpert or in the BIOS RAID firmware. I remember that skipping initialisation is not an option in one or other of those. Anyway the array had all of my data in tact after that.
I'm going to stick with the AMD Ryzen Power Plan. I really hope it cures my issue.
Good luck with your rebuild.


Sad to say the AMD Ryzen power plan did not fix the problem for me. Overnight my PC woke from sleep to find the C:\ drive missing (A raidable SSD drive). So the system understandably hung. Using the reset button didn't resolve the problem. I had to power cycle the PC. It's all back up again. So sleep is still not an option for my PC atm.   



I just encountered a different yet somewhat similar issue.
I also encountered same issue a few months ago when installing my OS, but just recreated my arrays and disabled sleep+hibernation as I do not use them.

I have a TRX40 motherboard and a threadripper CPU.

I have 4 1TB M.2 nvme drive on which I created two arrays:
- 400GB RAID5, this is my boot drive
- 3.5TB RAID0, temp work drive

This morning when I booted the RAID0 array was missing. After a reboot RAID0 showed up, but RAID5 got critical with one drive reported as missing.

This is quite strange as the drives are all recognized and RAID0 works fine.

I tried updating my BIOS, get latest AMD chipset drivers, trying to add global spare (impossible in my case, I guess because part of drive is used for RAID0). I found no way to rebuild.

Anyways after a few hours I found a workaround that worked for me. Maybe it can help people like me that couldn't trigger rebuild even if the drive is detected...

In RAIDXpert2 windows app:
- I right clicked on the faulty array and clicked on "transform"
- From there I chose RAID5 and selected my 4 disks (source drives were showing disks "0 1", "1 1", "2 1" and "0 0", destination drives were "0 1", "1 1", "2 1" and "3 1").
- Clicked on commit.
- Transformation was very fast. And success!! My array is back to normal!

Good luck in fixing your issues!




Just a follow up on what eventually happened with my AMD RAID issue in case it helps anyone else: After trying various combinations of RAID arrays with my HDDs and SSDs, the problems of disappearing drives (within RAIDXpert and also in device manager) plus sleep and hibernation issues are always present. If I disable RAID in the BIOS and wipe all the drives and install Windows again from scratch all drives work fine to prove that my drives were not at fault (even tried Windows Storage Spaces and the built in drive mirroring in Disk Management which both worked as well).

The company who supplied the motherboard agreed that this is either an AMD driver issue or a hardware fault so collected it and ran their own tests with similar hardware. They had the exact same problems - so they got an identical motherboard and it worked fine so the original board has gone back to ASUS and I have a new (but different) one.




Thanks Jonathanc, your reply, prompted me to check the AMD site & there are some new RAID drivers (  :-)
This is where I found the ones for my MB
I installed them, rebooted & then put my PC to sleep a few times. No issues so far. 
I'm now going to take my PC out of High Performance mode & let it sleep at will. I'm really hoping that, the RAID issue will be resolved.

Unfortunately, I couldn't see any release notes to see what had be changed


Sadly, today my PC woke up & started rebuilding a broken array. So the problem does not seem to have been resolved in this latest release.


I have now performed a full install of the drivers software (All drivers plus RaidXpert2). I did this several days ago & it appears to have fixed the issue with disks being lost after sleep. I think maybe when I tried to install just the drivers something didn't install properly. So I am no longer losing drives, no longer needing to rebuild arrays & I can let my PC sleep.
My PC has hung a couple of times with a blank screen since updating the drivers, but I can live with that.


I completely confirm the previous email, with the same history. The bug is indeed fixed, provided that you make a full install of the drivers 00167 and RaidXpert2, all in the only binary containing both of them: the RaidXpert2 full install binary.
Then, and for security, you can install *after* the AMD 00167 drivers by its binary installer, but in this order and not in the other one.
However, I never managed to make a correct installation (error usually 1603) before using the "AMD cleanup utility" before. It can be found on the AMD support pages. Eventually the excellent Display Driver Uninstaller (DDU, from Guru3D) could do the job too.
If you do that, however, make sure you have all the necessary drivers on hand and also write down all the information for a possible reconstruction of your raid (how the disks were assembled, size of the interleave buffer, etc). In the end, I didn't need it though.
Good luck, and I repeat : the bug did not appear to me anymore after dozens of sleep mode operations.


Hmmm The Hangs I am getting are in fact crashes. There is a MEMORY.DMP file in my Windows folder. My PC is left on full power but unresponsive. Hitting  the power button causes it to reboot & usually it comes up OK.
This is happening a few times a day. I'm not sure if it happens when the PC tries to sleep, wakeup or simply happens at random times. It never happens when I'm actively using the PC (at least not yet)
Running dumpchk against the dump says it's a memory corruption.
Running windbg & using "!analyse -v" seems to implicate rcbottom.sys. However, I know nothing about analysing Windows dumps. 


I have now resolved the crashes. First I installed the latest chipset drivers from the ASUS website. This did not resolve the issue. I decided to risk installing the latest chipset drivers directly from the AMD website. The last 2 times I have done this, I had to rebuild my PC. I assumed that ASUS tweak the drivers?
Anyway, this time the PC was fine after the install and the crashes have stopped. 


I have an Asus tuf gaming x570-plus wifi motherboard and encountered the same problem with the RAID arrays disappeared after waking up from sleep. After updating the driver & software (AMD Chipset Drivers, AMD RAID Installer (SATA,MVMe RAID) and AMD RAID Driver (SATA, NVMe RAID) ) from AMD for my MB, the problem was fixed.

Note: AMD RAID Driver (SATA, NVMe RAID) is NOT an executable install.  You have to extract it and browse to the sub folders WIN10\x64\RAID_SATA\rcraid, WIN10\x64\RAID_SATA\rccfg, and WIN10\x64\RAID_SATA\rcbottom then right click the *.inf and select install.  The driver version I have is dated 7/20/2020.


Hope this helps everyone and good luck to all.




I tried the latest Raid installer ( as well as the latest Raid drivers (, even with a new Win10x64 installation. Still having the issue that after Hibernate/Sleep my HDD Raid Array is Offline.

Is anyone else still facing the same problem even with new drivers?

Got in touch with ASUS - now answer yet.

Send my Bug Report to AMD - No reaction.

Pretty frustrating!


Hi everyone,

I had the same problem as others reported - one of the disks didn't resume after my PC woke from sleep mode. I was running the latest drivers. Reinstallation didn't work. I always had to rescan disks manually in RAIDXpert2 tool.

The problem (or the root cause) was in the incompatibility with my hard drive. Except my fast NVMe primary disk, I was also running WD Green 1.5TB (WD15EADS) from 2009 (SATA/II only). When I replaced the disk with newer Seagate Barracuda 2TB (ST2000DM008, SATA/III, 2018), everything was OK!

So, guys, check if your disks are not too old and consider replacing them with newer ones. Not sure, if older SATA/II was the problem. Or the disk was simply slower on resuming from sleep and AMD RAID controller was not patient enough to wait.

Just some details:
Chipset drivers:
RAID installer:
RAID drivers:
CPU/MB: Ryzen 5 1600X @ ASUS PRIME B450M-K II



I have exactly the same problem, raid array is not detected when resuming from sleep on windows 11, and have to rescan drives each time I resume. I've installed the latest  windows 11 available drivers with same result. The drives I have are new (less than a year old), so I don't think this is the problem. This was not happening to me on windows 10, so don't know what is causing this.

If there is something I can test to make it work as expected, any help will be apreciated.



Same problem here. I am using driver Only the legacy drive is affected when resuming from standby.

It would be much appreciated if the dev team will be looking into this. My guess would be that the error was fixed in the latest driver but only for Windows 10 (If OS is Windows 10 then ...)


New version ( still hasn't fixed the Offline error after waking from sleep.


I've the same problem. (Asus ROG CROSSHAIR VIII HERO (WI-FI))

Newest driver is installed ( and the problem still exists.

RaidXpert shows that the disks are offline after sleep mode, disk rescan in diskmanager does change nothing, array is still missing. Only a reboot can fix the issue.



I always used Intel based systems but I never had a problem like that, this was the first system with AMD Chipset and now this issue - very disappointing!!! 


2 years later and still no fix? Big thumbs up to the dev team! lolz

I've been building Intel systems for years, but took a chance on an AMD Ryzen for video encoding. Not making that mistake again.



I don't use hibernation, so I don't think fast start will make any difference.


Please read the takes 15 seconds to enable it or disable it. It's worth a shot. I wouldn't be posting this if it had not help users with similar issues. Hibernate and fast start are two different things. Note that you must reboot the computer after making the change.