Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

RAID Drivers / RAIDXpert2 Won't Install in Windows 10

I'm having trouble getting the RAID driver installed and recognized in Windows 10.

I'm trying to set up RAID 1 on 2 8 TB HDDs on a ASRock Fatal1ty B450 Gaming ITX/ac - . I'm on the latest BIOS version.

I'm on Windows 10 x64 (version 1809) with all updates. The system drive is a single NVMe SSD.

I've setup the RAID array in the BIOS.

I've installed RAIDXpert2, and installed the chipset drivers and RAID drivers. Everything says it installed successfully.

Device manager shows the RAID Controller (2 of them) under Other devices. I've tried updating the drivers through device manager, but it can't find a valid driver from Windows Update or from any of the extracted setup folders within C:\AMD\ .

If I open RAIDXpert2, I get to a web UI with a login form, but the Submit button is greyed out. The RAID array doesn't show up in the RAIDXpert2 quick status. It also doesn't show up in Disk Management.

What's the deal?


1 Reply
Adept I

Re: RAID Drivers / RAIDXpert2 Won't Install in Windows 10

Should the BIOS be setup for RAID or AHCI?  I have it set to RAID, of course.  But the driver installer mentions ACHI Compatible.

I was able to get the array detected in Windows and I created a disk.  I did this by loading the floppy/F6 driver manually (within Windows, not during installation).  But I obviously want RAIDXpert2 up and running so I can see the array's status.


I uninstalled all the AMD drivers/software, then tried installing again, but noticed that amd_raid_drivers_9.2.0.105.exe wasn't really doing much when I told it to install both the driver and RAIDXpert2.  It finished very quickly and RAIDXpert2 didn't get installed.  I ended up running it once with just RAIDXpert2 selected (since I though I already had a working driver), and RAIDXpert2 reinstalled.  I then ran it again with only the driver selected (since RAIDXpert2 still wasn't working, I figured the Floppy/F6 driver wasn't enough), and this time it actually installed a driver. After a restart, RAIDXpert2 worked finally.  I can now see that my array is initializing (or "CREATE"ing).