Showing results for 
Search instead for 
Did you mean: 

Drivers & Software


raid 10 RAID 10 and windows 10 (NVMe troubles)

so i have a new build with

AMD Ryzen 7 1800x

MSI GTX 1050 Ti

ASRock AB350 Pro 4 MB

120 GB M.2 NVMe with the OS

4 2TB HDDs that i want to set up in RAID 10


I successfully RAID 10'd them in the bios ( and switched back to SATA mode before you ask) they don't show up in windows besides in the disk manager where they show as normal partitions and not as striped or mirrored drives.
these do NOT show up in windows file explorer.

I tried downloading the AMD RAID Driver and RAIDXpert utility ver:17.40_RAIDXpert from the ASRock website and AMD but both gives me this error: OS is booted on NVMe volume and upgrading the driver will make the drive unbootable; so aborting the installation. 
I've tried everything i can think of guys! please help?

2 Replies
Journeyman III

Hi, I'm running a similar configuration (Asus C6H with one NVMe Bootdisk and 2x SSD raid 1 (4 SSD HD's)). You have to switch to raid mode in the Bios for the sata disks. Sata raid configurations are only reconiced by the OS when switched to raid mode for the SATA disks.

And yes the new AMD Raid driver is not working with this configuration. I'm getting the same error when trying to upgrade the driver.


I have tried both in RAID mode and SATA mode to no avail...