Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Raedon Chill issue

I just updated my AMD Raedon driver to version 19.7.5 and I'm having a bit of an issue with Raedon Chill. Whenever I launch World of Warcraft, I hear 3 beeps coming out from my speakers(my keyboard starts to blink during the beeps as well). Before my last update I was not hearing those beeps. I googled the problem I'm having and I found an article which shows how to disable Raedon Chill, however when I navigate to Gaming>Global Options, the only thing I see is "Chill Hotkey". I do not have the option to enable/disable Raedon Chill.

I hate the beeping sound and I don't even want to use Raedon Chill, is there a way to disable to feature?

4 Replies

There is no global option for it anymore like there used to be. Although I think it should have been off by default, you can add a profile for Warcraft to turn it off.

Navigate to Gaming.
Click Add.
Click Browse.
Navigate to C:\Program Files (x86)\World of Warcraft\_retail_ 
Select Wow.exe.
Navigate back to Gaming. 
Select the new Warcraft profile you just added.
Turn off Chill.


Hello, thank you for the reply.

I have both World of Warcraft Launcher and Wow.exe added to my gaming tab. Chill FPS is disabled on both profiles, however I still hearing the 3 beeping sounds whenever I launch the game. I play other games and WoW is the only one where I hear the beep.

As I said above, this happened after the latest update. Should I wait for a new update or downgrade my driver?




You can also Alt+R in game and disable it,

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro..

I just tested this on my system. I'm running a RX590 and driver version 19.7.5. It turns on and off just fine for me with Warcraft. I'd advise running a scan and repair on Wow and/or a clean install of 19.7.5.