cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

wicpar
Newcomer

Radeon VII eGPU error 43 after Xconnect stopped working

Hello,

Yesterday i set up the Radeon VII on my akitio node pro, connected to my lenovo p1(xeon+p2000). I installed the drivers (got a blue screen, messed things up, and it couldn't install the radeon settings) and it seemed to work fine i played a few games to celebrate, and the Xconnect service was active.

Today I decided to fix the mess, so i reinstalled the drivers. During the first reinstall i tried activating Thunderbolt 3 support in bios mode, but it caused a system hangup and i had to hard restart, maybe this messed things up. I spent  the rest of the day trying everything i can to fix but nothing helped. Oddly my windows troubleshooter doesn't have the option to troubleshoot hardware, so i didn't try that.

I even tried changing the card vbios, but it didn't help so i reverted.

So the card is there, in the device manager, with error code 43, GPU-Z detects it, i fixed the radeon settings installation, but it won't start.

The two differences remaining are error 43 and Xconnect not launching...

Is there a way to force Xconnect to launch? Is there an installer to force install it? or is my issue something else?

Tags (2)
0 Likes
1 Reply
radeonvii
Journeyman III

Re: Radeon VII eGPU error 43 after Xconnect stopped working

I got a similar issue last night. mid game my screen began artifacting and performance grinded to a halt. my system crashed shortly. I uninstalled amd drivers and it ran fine on generic intel drivers. now when i try reinstalling amd drivers I get a code 43. even after DDU'ing all drivers, clean windows install and clean driver install. Any help would be appreciated before i open an RMA request

0 Likes