Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Radeon software broken after a driver timeout - GUI will no longer launch.

I've run into some strange driver issues in my time, but this issue is so persistent that I'm at a loss. I'm running a Sapphire Pulse Vega 56 on Windows 10, 21H1. Here's what happened and what I've done to fix it so far:

  • I was playing Bioshock Remastered and got a driver timeout notice; game crashed but Windows etc. were fine. I rebooted just to be safe.
  • I went to open AMD Radeon Settings and saw all my game records were gone; everything appeared blank. After launching Bioshock again through Steam, Radeon Settings didn't detect that I'm running a game.
  • I started up Back 4 Blood (I'm using Adrenalin 21.10.2) and got another driver timeout notice. This time, I had to hard reset my PC.
  • After restarting, AMD Radeon Settings refused to launch on my system at all.
  • I rebooted into Safe Mode and ran DDU, selecting GPU, then AMD, and Clean and Restart. I disconnected my Ethernet connection before rebooting to prevent Windows from trying to install a driver through Windows Update.
  • Reinstalled Adrenalin 21.10.2 with the full installation and clean install options chosen. Rebooted.
  • Radeon Settings still refused to start. I uninstalled Radeon Software through Control Panel and downloaded AMD Cleanup Utility, then rebooted into Safe Mode.
  • I ran DDU and chose Clean without Restarting and let it finish. Then, I ran AMD Cleanup Utility, which reported one App Package failed to be removed: AppProfiles.
  • I ran DDU again, choosing Clean without Restarting again, then re-ran AMD Cleanup Utility, which reported the same error as before.
  • I manually combed through my AppData folder, Program Files, and ProgramData and manually deleted anything I could find related to AMD or Radeon Software (I have an Intel chipset so I'm not concerned about accidentally breaking those). I also did the same in the registry.
  • I rebooted into a regular session and attempted to reinstall Adrenalin 21.20.2 with a freshly downloaded package from I again chose a Full installation with the Clean install option.
  • I restarted, just to be safe. I'm still unable to launch Radeon Software.
  • I confirmed in Device Manager that my Vega 56 is properly detected and using the driver, but game performance is subpar and I have no way to tweak any options through Radeon Software.
  • At some point in this process, my GPU refused to show anything at all (no POST or UEFI messages, no desktop) even though I could tell my PC was booting and letting me log in normally. I fixed this by reseating the power connections and switching to the other onboard vBIOS. After a successful boot, I was able to switch back to the original vBIOS without further issue.

I've done some research and tried a few common solutions, like changing a driver version registry entry or force closing all AMD processes and trying to launch them again with no luck. I'm completely stumped on this issue; I've never had a driver problem persist after such a thorough removal and reinstallation.

I know one option is to try System Restore, but unfortunately I recently switched my system from using AHCI to RAID and going back to the restore point from when I first installed Adrenalin 21.20.2 would remove that driver and all the necessary configuration, so that option is off the table.

I tried to look up where the AppProfiles that AMD Cleanup Utility could not remove are located, but came up empty handed. I could find a file or registry entry in my system and couldn't find any details online, either. I've attached a screenshot of my AMD Cleanup Utility report in case I've left anything ambiguous by mistake.

AMD Cleanup Utility report.png

Thanks so much in advance for any and all guidance you can provide. I'm trying to finish an important video I've been working on for a month and play some games and I'm not confident in my system's performance or stability with this half-working driver installation.

1 Solution
Adept I

Was able to fix this issue after a bit more research; for future reference I followed the steps posted here on the forum.

View solution in original post

1 Reply
Adept I

Was able to fix this issue after a bit more research; for future reference I followed the steps posted here on the forum.