cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

jon2281
Journeyman III

Radeon Software Adrenalin Edition 18.2.1 R9 290X CrossFire Issue's

Hello ive been having a problem with my  2 R9 290x's the 2nd GPU is just not being used at all and even in the radeon control settings their isn't even an option to enable or disable crossfire support so what i did was i downloaded the software display driver uninstaller to completely uninstall the drivers and roll them back to previous versions to test out and see if corssfire would work on older versions and i even went all the way back to crimson relive edition 17.4.3 and that version works with crossfire but those drivers are over a year old now. Is their a way to keep crossfire support for my r9 290x's but on the latest radeon software adrenalin edition 18.2.1?

0 Likes
7 Replies
elstaci
MVP

Re: Radeon Software Adrenalin Edition 18.2.1 R9 290X CrossFire Issue's

Please post your computer specs according to AMD Forum rule : INFORMATION REQUIRED WHEN POSTING A QUESTION .

There is a new AMD Driver for the R9 290x. You can download from here: Desktop . (Windows 10 x64)

Since you didn't post your Motherboard's Make & Model, I couldn't check to see if there is a newer update for your Motherboard's BIOS and CHIPSET.

Updating those two will make the latest AMD Drivers be more compatible.

Also your Windows OS must be fully updated via Windows Update for the latest AMD Drivers to install and work correctly.

0 Likes
jon2281
Journeyman III

Re: Radeon Software Adrenalin Edition 18.2.1 R9 290X CrossFire Issue's

thank you for the reply and sorry i forgot to post my specs i was just so frustrated that something was wrong with my gpus or system but i figure its definitely the new drivers that dont support the older 290x cards and i also tried the newest drivers that u linked me and now crossfire is gone again someone please help me, ive also included screen shots of my system running the radeon crimson relive 17.4.3 with CF enabled then i updated the the drivers that you linked me and now it stays disabled?

CF working: Imgur: The magic of the Internet

CF not working: Imgur: The magic of the Internet

CPU: Intel core i7 8700K

RAM: 16GB DDR4

MOBO: gigabyte z370 aorus gaming 7

PSU: evga supernova 1300watt

GPU: R9 290X Crossfire

0 Likes
kingfish
MVP

Re: Radeon Software Adrenalin Edition 18.2.1 R9 290X CrossFire Issue's

What OS? WinXP? Win7?

0 Likes
jon2281
Journeyman III

Re: Radeon Software Adrenalin Edition 18.2.1 R9 290X CrossFire Issue's

im running Windows10 Ver.1709 Build 16299.371

0 Likes
elstaci
MVP

Re: Radeon Software Adrenalin Edition 18.2.1 R9 290X CrossFire Issue's

According to Gigabyte Support your Motherboard has a very new BIOS and fairly new Intel VGA Driver.Z370 AORUS Gaming 7 (rev. 1.0) | Motherboard - GIGABYTE Global

BIOS - F6 - 04/10/2018 (F5 (03/09/2018)is an important one since it update AMD Microcodes and improve Graphics card compatibility)

Intel VGA Driver - 03/27/2018.

This is from your Motherboard's Manual about setting up Crossfire. Do you have Crossfire activate in Global Settings under Radeon Settings as per manual:

jon2281
Journeyman III

Re: Radeon Software Adrenalin Edition 18.2.1 R9 290X CrossFire Issue's

yes i have crossfire active in the global setting section but like i said its only showing up active in the crimson relive edition 17.4.3 version not 18.21 or 18.34 and also my motherboards bios version is F5 so i guess ill try updating it to F6 and see if that would help CF but it probably wont

0 Likes
jon2281
Journeyman III

Re: Radeon Software Adrenalin Edition 18.2.1 R9 290X CrossFire Issue's

crossfire is still not working with my mobo updated to R6 and amdccc 18.34

0 Likes