Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Radeon Software Adrenalin 2020 Edition 20.12.1

Installed the software and it does not open

2 Replies

You might the following:

I would suggest trying to install the drivers from scratch again as sometimes things just corrupt.

Have the driver downloaded from AMD

Download and run DDU from wagnardsoft dot com from safe mode with Internet unplugged or wifi off. 

Restart with Internet still disconnected.

Install the AMD driver but don't pick express install. Choose the"Factory Reset" option.

See if that helps.

I that doesn't help repeat the same process above but install a previous driver that worked for you and report the issue to AMD:

In Radeon Settings there is a Bug Report tool too you can submit the issue or

You can contact AMD support here:

Good Luck!

Adept II

Same here.  After uninstalling 19.9.2, rebooting, and installing 20.12.1, there was no access to Radeon Settings or Radeon Software controls or configuration dialogs of any kind.  No desktop icon, no start menu icon, no system tray icon from which to start Radeon software.  The old link to RadeonSettings.exe remained on the start menu, but the .exe file was gone and so it was a dead link.  Uninstalled and reinstalled three times, and got the same result.

Started Radeon Software .exe from installed folder location, but app failed to start and produced an error event in Windows event viewer.

Installed 20.11.2 and started Radeon software from an icon on the start menu, and got the same result.  Radeonsoftware.exe fails to start and Windows event viewer logs an application error event "Faulting application name:  Radeonsoftware.exe, version:"

These Radeon driver updates are always such huge time wasters because usually something does not work, so when I discover a version that does work, I rarely update until I absolutely have to.  I would not have even tried updating except that Windows Update was forcing an update with no way to exclude it.