Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

radeon settings won't open in 18.2.3/18.3.1 - Win7

After upgrading to both the 18.2.3 and the 18.3.1 drivers I haven't been able to open Radeon Settings.  After boot, I don't get the Radeon icon in the task tray, and if I have task manager open while I try to open Radeon Settings I see RadeonSettings.exe start and quickly die.  I have tried the clean install option, the AMD driver cleaner, and DDU, all with the same results.  I've needed to revert back to 17.2.2 to gain access to Radeon Settings.  I have reported this on the "issue reporting forum" as well.


Gigabyte Aorus RX580 8GB

Windows 7 64 Bit

ASUS VH238H 1920x1080@60 DVI

ASUS VH238H 1920x1080@60 HDMI

ASUS VH238H 1920x1080@60 Active DP DVI adapter

GA-Z77x-UD3H F20e

i5 3570k

Antec EA650


9 Replies
Adept I

I missed a digit, I've been reverting back to ​17.12.2

Did you run DDU from safe mode? It makes a difference. Run DDU and restart to normal. Run registry cleaner, I use CCleaner as it is very safe, to remove orphans left behind after DDU. Reinstall latest driver with Custom not Express install and choose Clean Install. It makes a difference. Hopefully this gets you going. I also have a RX 580 and didn't get the Radeon Settings in notification area with the first Adrenaline Drivers, this fixed it for me.

Good Luck!


Just attempted, same result. Back to 17.12.2 I go.

  1. Rebooted to safe mode
  2. ran DDU
  3. restart to normal
  4. ran Eusing Free Registry Cleaner 4.1
  5. reboot
  6. custom install of 18.3.1 from FULL download
  7. selected clean install
  8. selected display driver, HDMI Audio Driver, Problem Report Wizard, and AMD settings.  Deselect Bethesda Launcher
  9. accepted the non-whql warning on the display driver
  10. sip some tea (this install gets longer all the time...)
  11. SKIP the radeon relive installation
  12. "restart now"
  13. Wait for windows to come back up, get greeted by the successful installation website
  14. Check the system tray, notice no Radeon icon
  15. Opened Task Manager, see atieclxx.exe is running, no other AMD processes
  16. Opened Radeon Settings, see RadeonSettings.exe show up for ~3 seconds and disappear
  17. Say some swears to feel better
  18. Maybe it's a fluke, try opening again!  No RadeonSettings.exe this time, instead see cncmd.exe for ~3 seconds and disappear
  19. Screeeeee

Silly question have you tried disabling any antivirus and antimalware software you have going while installing? Just thinking it's gotta be something.


** Windows 7 and Windows 8.1 must be fully updated before attempting to install any AMD driver. All 'critical', 'recommended', and 'optional' (no language packs,etc) updates as well as any Service Packs (SP) must be installed before any attempt to install graphics drivers. If you do not get this message .... keep installing until you do:

The only update I haven't installed is the preview of monthly quality rollup KB4075211.  I'm up-to-date as of KB4074598. Thank you, but this wouldn't seem to be the cause.

Adept II

Install latest driver and after this uninstall only radeon settings. Install radeon settings from 18.2.2 driver and all is working

Adept III

You are not alone:

Journeyman III


1) Run 'regedit' ; HKLM/SOFTWARE/AMD/CN - Driver Version. Delete the number that you find, close registry & reboot.

This will allow you to open the stuck on tray driver settings, re-occurring Chinese Bug.

2) Run 'regedit' ; Find "ULPS", set all entries of 'EnableULPS' to 0. When done close registry & reboot.

This will remove the sleep mode for a 2nd or 3rd GPU if you have them, temps & run clocks will display normally.

(Until I find otherwise, this is my M.O. from now on.)