Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Radeon Settings Driver 18.1.1 Shader problems on GTA 5

I have been hoping for a solution to this serious problem. But I'm seeing that the issue is not solved.

A lot of people with an amd setup have this problem for months. On GTA 5 there are some shaders problems that create odd artifacts when they are set on "very high". The only solution is to set them on "normal". But, in this way, we lose many graphic details and we are compeled to have a not-full experience of this amazing game....

Pls AMD!! do something or try to suggest us an effective solution =(

19 Replies

What setting do you have in Wattman?


I have always used the default setting. Do you suggest to deactivate the shader cache option as you have done?


Well look at it like this....what have you got to lose? try 'AMD optimized' and if that doesn't do the trick, try "On".


I Will surely try and I will let you know the results thanks for the advice


As I always (by habit) never use something that is going to "optimize" something for me, I am very curious as to which of the three choices have a positive effect with the game shaders.

Nothing change. I've tried your suggestions but the problem persists. I've tried not only to change the shader cache option, but I've also tried to adopt your same setting that you use on call of duty.

The only playable solution to have a decent game experience is to switch the shader option to "normal" inside the game option. Moreover, I had to substitute the d3dx9_43.dll inside the system 32  windows folder in order to avoid a lot of random crashes of the game. As I supposed, it's a driver problem because with some old amd drivers there is not this huge complication. For example, using the crimson driver 16.7.3 whql the issue doesn't exist. All works fine... (but obiviously I can't play with new games such as ac origins, using that old driver).

It's really disgraceful that a lot of new amd drivers can't handle a 2014 videogame -.-°°°

my specs are:

OS: Windows 10 64 bit creative edition

Graphic Card: Sapphire Nitro Radeon r9 380 4gb

Processor: Amd fx 8350 8 core

PC Sink: Artic Freezer A30

Ram 16gb

Power supply: 650W

Motherboard: Gigabyte GA-970A-UD3P (rev. 2.х) socket am3+ chipset amd 970

HD1: ssd ocz-arc100

HD2: wdc wd10eads-65l5b1 1 TB (here I install all my games)

The temperatures are around 70/75° for the gpu

and 55/60° for the cpu


The shader cache should have no effect at all on the 'graphic details' of any game. That's not it's purpose. That setting could be a little high for your card/computer as well...nothing wrong with using "normal".

How AMD's shader cache works exactly ? - [Solved] - Graphics Cards


My setting can't be high for my pc because, as I said, with old amd driver such as the 16.7.3 there wasn't any problem at all.... =(


I wish I had this game to offer to test and offer you good advice. I can offer this though and hope it helps. If you are using a custom profile for GTA5, that profile or whatever the drivers custom override or enhancement feature is doing to your game, may be an issue that I have no help for. Some engines just don't play nice with the drivers taking over. However have you chosen the option of resetting that profile to default and then deactivating it, this will ensure the driver and only the game engine is running things. This has fixed issues I have had in the past with Battlefield 4. I know different games and engines but just a thought.


Shame you can 't get it working. Make sure you report it to AMD maybe they will fix it. They fixed the recent DX9 issue pretty quick. Have you checked any game forums for that game like on Steam or other gaming sites. Sometimes those guys figure out some pretty creative work arounds to issues. Good luck to you!


Hey after a quick google search many are saying this isn't an AMD issue but actually a corruption in the user account on windows. Try creating another user account and launch the game from there. Maybe you get lucky and it works for you too! Definitely an easy thing to try!


mate, I gave a glimpse to all the possible forum.... the only answers I had found was: "I have your same problem"


Excerpt from TPU article,

I leave it on.

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..

With this information you provided leads me to think that the user profile corruption is a likely culprit. Seeing as the cache location would be within the folders unique to the profile! So very possible their is an issue with read/write or security settings that gets fixed by using a new profile. Again very easy to create another user profile and try the game from there. Hope he actually gives this a try.


Seeing as there is this thread Radeon Adrenaline Edition GTA V Artifacts

I'm unsub from this.

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..

I have done a complete format C of my primary hd and I have re-installed the game with a fresh installation. The user profile is not the problem. I have substituted the .dll file in order to avoid the error err_gfx_3d3_init that always occured after 5-10 minutes of gaming.


That's too bad. I haven't a clue then what to try next other than a new driver or an update from the games maker. I know I just uninstalled a few old games I liked that were broken when MS abandoned windows live. Unfortunately your game isn't really that old and probably an easy fix if the appropriate party would just fix it. Good luck!

Adept II

New drivers 18.2.1 same issue using DDU.