Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Radeon Settings doesn't open

Hello, i  do have a Ryzen 3 2200g with the last update from the radeon settings, but when i click to open the Radeon settings, the mouse start to open, but after a second or two, the driver icon disappear from the notification on windows, and i had tried the cco, a clean install, uninstall, every damn thing to get this settings working up again, it appears to work when i reinstall the driver, but after a restart or two on my computer, its doesn't work anymore.

Asus a320m-k br

Ballistix crucial 8gb 2400mhz cl 16

vs450 from corsair.

ryzen 3 2200g

ssd from WD

10 Replies
Adept I

I'm on the same boat. Except it doesn't EVER open. No matter what I do (clean install, uninstall, DDU, etc.), it just refuses to open.


Disable Fast Startup / Hibernation.  Windows caches old restart information and that information in notorious for having old bits of driver information that conflicts with current drives causing them to misbehave or quit all together.

So disable that.

Run DDU from Waganardsoft_com from safemode

Disconnect for the Internet

reinstall your driver

then reboot normal and see what happens.


Still did not work.


Return to a previous driver that did work, and report the current issue to AMD is about all I can recommend :  Online Service Request | AMD


Yup I've already reported it. Sadly, the previous version from AMD's website has the same issue

So I had to go to some tech website and download the driver that AMD does not offer anymore.

Thanks for trying ma man. I appreciate it.

Adept I

Ok guys, i had the same problem (nothing happens when i try to open Radeon Settings) and reinstalling the driver suite (using DDU first) did not help me. Then, after a lot of google searches, i solved my problem. I don't exactly remember at which site i found, thus, i can't give credit (sorry for that). I'll share my solution here hoping to help others. I'll explain as simple as i can.

(This solution may work if you are using an intel CPU with CPU graphics enabled alongside your main AMD GPU)


Step 1: Open Windows Task Manager (right click on the clock and click on Task Manager). Switch to "performance" tab. Here, you can see real time performance graphics for your hardware like HDD, Network, GPU etc. Do you see your intel on-board GPU here? Is it seen/identified as GPU 0 or GPU 1 by Windows? If your intel CPU graphics is seen as GPU 0, this solution may not be for you (but you can still try it cause it doesn't involve anything potentially harmful for your system)


As i understand it, If your intel CPU graphics is listed as GPU 1, this is the problem. Supposedly Radeon Settings tries to communicate with GPU 1 and it doesn't work because it's an intel on-board GPU. This may be a Windows fault too, i don't know. 

Step 2: Now the solution is pretty simple. You need to first uninstall (in my case it's a HD 4600), download and install the latest drivers for your on-board GPU.

To download most recent drivers (if you know this you can skip this paragraph): Go to intel web site, navigate to "drivers&software" page (direct link: Drivers & Software ) and from there you click on "Graphics Drivers" link and at the next page you only need to select your CPU family (ie 4th Gen), download type (you need drivers), your OS version.

You should install (as admin) the suitable and most recent driver package. 

Step 3: After installation is completed, restart your PC. In my case i didn't need to do anything else after restarting and my Radeon Settings worked flawlessly. I didn't need to re-install Radeon Settings either. And now Windows sees my on-board graphics as GPU 0 (as it should be).

I'll share this solution in similar forum posts.

Sorry for my poor English. I hope this solution works for you. 

A simple solution worked out for me.

After contacting AMD, we realized that the issue points to igdrclneo64.dll as the cause. This file appears to be an Intel OpenCL file and it appeared to be preventing Radeon Settings from launching according to my DxDiag reports.

If the integrated Intel graphics card is enabled, then its drivers has to be uninstalled and disabled from BIOS and/or the Device Manager.

But what really worked for me is going to the path
>> C:\Windows\System32\DriverStore\FileRepository\igdlh64.inf_amd64_250db833a1cd577e <<
and deleting the "igdrclneo64.dll" file (but of course I saved it elsewhere just in case).

Removing that file did the trick for me! I have been working on this for WAY too long. 


This work for me, thanks a lot!. The GPU0 its 4600 and the GPU1 the Radeon R9 265, I unistall the Intel 4600 and install the last drive from the Intel web site, "drivers & software" page. I do not unistall the radeon software and the drivers. I have the last ones!!!! Thanks!!! 


Thank you man this worked for me!