cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

carlos_mateus77
Journeyman III

Radeon RX VEGA 56: No AMD graphics driver is installed, or the AMD driver is not functionning proper

Hi,

I have an AMD Radeon RX Vega 56 (a Powercolor card that I bought a few years ago but never used it before as my previous motherboard only had PCIE 2) that I cannot seem to have working properly with the drivers in my machine.
This is a brand new, self assembled system with:

Motherboard ASUS TUF GAMING X570-plus
Cooling Corsair H100x
CPU AMD Ryzen 7 3800x
Memory Corsair Vengeance 16GB 3200Mhz
Power supply Corsair TX650M (650W)

I first uninstalled the drivers (AMD Radeon Drivers for an HD7550).
I installed the Vega and installed the newest drivers from the AMD website (Adrenalin).
The result is that I have no access to the Radeon software and I get the following message:

No AMD graphics driver is installed, or the AMD driver is not functionning properly.
Please install the AMD driver appropriate for your AMD hardware.

I have tried multiple troubleshooting:

Uninstall drivers and reboot
Install drivers - same issue

Uninstall drivers
Use the autodetect tool - same issue

Uninstall drivers using DDU in safe mode and reboot
Install drivers - same issue

Uninstall drivers using DDU in safe mode
Set BIOS PCI express to GEN3
Re-install drivers -same issue

Used the AMD cleanup utility
Install drivers - same issue

I have taken out the graphics card and placed it again to make sure that it is sitting correctly.
I also tried the second PCIE16 but it still has the same issue.
In addition, Windows 10 Pro is at its latest version (20H2 build version 19042.662)

Also ran DISM /Online /Cleanup-Image /RestoreHealth but no change.

All installations have been done with Administrator permissions.
When I look at Device Manager there is a warning and Code 43 error stating:
"Windows has stopped this device because it has reported problems".
Also, when I install the drivers and I get the error accessing the Radeon software, the mouse gets trails all over the screen but it will not show in a screen capture.
Do bear in mind that after every attempt I uninstalled the driver in safe mode using DDU and I also followed the link on:
https://community.amd.com/t5/knowledge-base/troubleshooting-common-amd-graphics-driver-installation-...
The BIOS is also updated to the last version.

However, with the standard Windows driver, there are no mouse trails but I cannot use the full capabilities of the VEGA.
Would you be able to put me in the right direction?

Thanks for your help

0 Likes
2 Replies
pokester
MVP

If you have another machine to test that card in I would to see if it behaves the same there.

If you have a spare hard drive you could install Windows to it and see if it then behaves better or not. 

This should help figure out if it is the card or Windows gone bad. 

Good Luck!

0 Likes

I just tested on my old machine but it's an old PCIE2.0 and it does the same thing.

I don't know whether it is due to that and unfortunately I do not have a spare hard disk.

0 Likes