cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

carclis
Adept I

Radeon RX 5700 XT Intermittent audio stutter

I'm typing this on behalf of someone I built a system for. He has a 5700 XT hooked up to a large OLED display via HDMI which is then connected to a soundbar. In games in particular (Destiny 2 was the easiest to replicate the issue) but also during normal use the audio sometimes cuts out for a split second or even multiple seconds at a time. I have been able to verify this issue on numerous different driver versions including 19.12.1. 19.11.3 and 19.10.2 before just jumping onto one of the earliest driver versions; 19.7.5 which seems to resolve the issue. He had been using a Radeon VII prior as a temporary card which had no such issues and I also tested an Nvidia GTX 1080ti as well which also had no problems.
His system is:

Ryzen 5 3600
Gigabyte X570 Gaming X
MSI 5700 XT Gaming X
Intel 660p 500GB
Seasonic Focus Plus 750w
Windows 10 64 bit

Obviously this is a pretty serious issue as games become simply unplayable with this audio situation. Currently considering returning for an Nvidia card if this does not get resolved.

Update: 19.7.5 was better but did not fully resolve the issue. Card has been returned.

27 Replies
rockmong
Adept I

I solved the audio cut out stuttering problem by using an older HDMI driver.
That's version 10.0.1.07.

Included in Radeon ™ Software Adrenalin Edition 18.10.1

It is located in the package \ drivers \ audio \ hdmi \ WT64A folder.

 

https://www.amd.com/en/support/kb/release-notes/rn-rad-win-18-10-1

 

Please overwrite the driver via manual update.

Thanks. I also noticed this seems to be an issue that is addressed with AGESA 1.0.0.5 on my motherboard as well. So I'm unsure if your fix or the AGESA will work. Either way we don't have the card anymore.

0 Likes

Thanks,, I will now try the workaround of using version 10.0.1.7, like you suggest.

0 Likes
davidgreifer
Adept I

me too

0 Likes
pubdev27
Adept I

I'm having the same issue, but with a RX 5500 XT card from XFX. I came to add some additional details in case it may be helpful for the devs who are trying to fix this. First, related threads on this same issue can be found here:

I've done all the troubleshooting I can:

  • installing different drivers
  • uninstall, reinstall
  • fresh install
  • adjusting sound settings on the computer
  • adjusting sound settings on the TV
  • different machines

I plug the HDMI directly into my TV, and my TV is usually outputs sound via optical to a sound bar. I tried running the sound directly to the TV speakers instead and the same problem persists.

What's more is I can monitor the sound output in the windows panel. It shows a dynamic meter that grows/shrinks when sound signal is output. When the sound cuts out, the meter shows that audio is clearly still being transmitted. It just can't be heard through the speakers.

I've tried the 5500 XT card with the following configurations (all using 32GB memory):

  • Machine 1: Crosshair VI, Ryzen 7 2700x
  • Machine 2: Asus TUF B550M, Ryzen 5 3600x
  • Machine 3: Crosshair VII, Ryzen 7 2700x

I recently bought this card to temporarily replace my Radeon VII. I didn't the exact same issue with that card, but  something similar happened happened sometimes. The Radeon VII, when I watched Youtube videos the sound would OFTEN cut out right at the beginning. I'd have to refresh the page and then it would work fine. But it only happened with online videos that were streaming, mostly with Youtube, but occasionally  with Amazon Video too. Otherwise, the sound did NOT cut out intermittently with that card and for the past year I've just sort of accepted the minor troubles until recently. This was on Machine 3.

With the RX 5500 XT, its chronic. I've tested this on Machines 1 and 2, both on fresh installs of Windows, with fresh hard drives, fresh drivers.

The main pattern is that as long as I'm listening to one audio source (in this case Spotify), it mostly works fine. It cuts out, but its maybe once or twice per song. However, when I'm trying to play specific games, its worse and sometimes impossible. The interruptions are several times a second at its worse on Machines 1 and 2.

The particular game that illustrates this very well in my case is Cities Skylines. I tested this theory on several games, but none were as bad as Cities. It has complex a soundscape. When a city is loaded in the game, the sound immediately starts chopping up. If I zoom into a particular area of the city, it worsens. Now typically, the closer you zoom in on your city, the more different sounds you can hear: buildings, cars, environment, music, etc -- and the sound pans with camera rotation and viewing angles. However, when zoomed out the primary sound sources are just the UI (clicking), game music and the messenger tool. 

On Machine 1, this problem makes the sound useless. I can't get through a game session. And generally, I cannot have sounds coming from 2 sources or else it becomes too choppy to use. For example, playing Spotify while playing a game. Its also totally unusable with software like Virtual DJ -- it just cuts out too much. This is a severe issue.

On Machine 2, its not as bad but still unusable. Some games like Surviving Mars are near normal sound. But Cities is just awful. It's not playable.  Overall, the problem is present on all machines with the 5500 XT and its very disruptive.

I wanted to try the older driver versions mentioned in this and other posts, but as of today the oldest are no longer available from the AMD downloads page.

The issue seems unique to this card series based on what I've learned so far. I've recently been doing a lot of maintenance so I've been able to use 3 different cards (one a low profile Nvidia GTX 710) and the 5500 XT is far and away the worst performing when it comes to sound. I plan to return the card because its really impossible to get anything useful out of it. I hope you find this helpful and since this issue is over a year old I really hope someone from AMD can give the community some answers about this.

Thanks. I'm having very similar issues with my RX 5500.

Interesting enough, the problems slightly changed recently, possibly because of the driver update to Radeon 20.8.3 pack (AMD Audio Driver Version 10.0.1.16).

I used to have the audio on sites like YouTube stop after a couple of seconds. Now it only jumps and then continues after a second. Still very annoying, especially in games like you describe.

A friend helped me debug a little, and we found that when the sound disappeared previously, it went to another audio output. The motherboard has an on-board sound card, and when connecting regular PC speakers, the sound jump to them when the YouTube tab's audio stopped a few seconds after it began.

An easier workaround to refreshing the page, by the way, is to right-click the Chrome Tab and choosing "Mute site", then right-click again and choosing "Unmute site". This kicked the audio back to the TV. Of course, it sometimes bounces back so this might have to be several times. But i found it better than refreshing the page. Muting the Sound Device on Windows taskbar doesn't help, but changing between sounds devices does. Note that you might only see a second sound device after plugging in the speakers (LP connector). 

I tried a lot of things like re-installing Windows, replacing cables and disabling other sound devices. See full list in my post here: https://community.amd.com/message/2992490?messageTarget=all&start=525&mode=comments#comment-2992490 

I'm now trying out an active HDMI splitter to see if it solves the issue, and it might hint about whether the workaround suggested in that thread - using an Active Display-Port to HDMI adapter might solve the issues.

As mentioned, the YouTube problems are much more rare in the past few days. I'll try the in-game audio jumps. By the way, they dont happen in all games. Fall Guys, Fortnight work pretty well. For some reason FIFA 19 is terrible. It wasn;t like that a month ago but it was yesterday, so I suspect the audio drivers.

By the way, I opened a ticket to AMD who say they think it's a hardware issue with my card and that I should contact Sapphire who make the card, but I don't think that is the issue.

I also wonder if the old audio driver mentioned above (10.0.1.07)   will solve it. Will have a look for it later on.

0 Likes

If you are not using the Mother Board Audio then it may help to just disable it in the Bios. Then nothing will be able to be confused by it. 

0 Likes

You could also disable it in device manager if you don't have the hardware option to do so in the bios. 

0 Likes

Yes, I tried disabling the on-board audio device in 3 places: sounds settings, device manager and BIOS. None helped.

Sorry just a thought. I wish I had an answer. I can only tell you that you are far from alone complaining about the issue.

Hard to believe it is defective hardware. Unless it is just defective in design. Or the drivers are just plain flawed. 

corsair
Adept I

I can’t solve this problem with the latest and old drivers
I suspect that the 5000 series, especially the 5700XT, are defective cards at all
Isn't it an exaggeration to have a driving problem for a whole year?
No wonder the market share has been declining
HDMI is a 3C standard specification, this basic thing should not be in a state at all

I have done three tests
My 5700XT is connected to panasonic TV through HDMI
It is normal to transmit to YAMAHA and DENON amplifiers via ARC (Set Bitstream or PCM)

Second test
5700XT HDMI directly connected to the amplifier (PCM encoding)
The sound will be choppy from time to time
Decoder off is constantly displayed on the amplifier, which means the signal is intermittent
I changed to nvdia 1080 and everything is normal

The third test
I put an HDMI repeater between the 5700XT and the amplifier
Sound output is normal

Obviously there is a problem with the PCM encoding of the sound effect setting
This means that 5700XT’s HDMI directly output sound to the machine will cause problems
The signal must be reprocessed through other products (TV, HDMI converter, HDMI repeater)

Now can you tell me whether this is an AMD driver or is there a problem with the hardware or even WINDOWS?
Over the past year, many people in this forum have reported why AMD has not resolved this issue?

If it is not resolved in a day, I will keep telling everyone in various forums and FB communities

Do not touch AMD's graphics card

I bought 2 different 5700XTs and both have this problem

619alejandro
Adept I

I FIXED the sound issues on my PC, it appears its caused by a discrepancy on HDMI-GPU and HDMI-AVR speeds.

i did the following:

1) access radeon software

2) "display" tab

3) Enable "HDMI Link assurance" (This matches HDMI-GPU speed to your HDMI-AVR)

I haven't had an issue ever since.

I tried this approach, but it didn't work

0 Likes
kfir
Adept II

Updates:

- I tried using the borrowed Active HDMI splitter and the problem was not solved.

- I tried downgrading the audio driver version to 10.0.01.07 according to rockmong‌'s instructions above. The issues are still happening but much less! Thanks, it's better than before.

619alejandro‌'s suggestion sounds interesting. I'll try that next.

Thanks

You can try it, install WINDOWS ATMOS sound effect, after I do this, problems rarely occur

0 Likes

It worked for a while, now I'm back where I started, There is no definitive

solution for this problem, I will have to switch to Nvidia 2070 or 3070 as

some others have done here. Sorry AMD, we really tried.

0 Likes

I got the 2060s...flawless

0 Likes

HDMI Link Assurance doesn't really help.

I am now getting more of a different type of problem: the TV shows a "static noise"-like screen, with colors. And usually goes back to normal display and sound after a few seconds. Twice I had to disconnect and reconnect the HDMI cable. (I have the Radeon connected directly to the LG OLED TV.)

Will try the different suggestions in the other thread and report. 

0 Likes
tschi
Adept I

I have definitely solved my issue by selling my card.

I bought it for an HTPC, it was really a pain to use it.

Bye bye AMD.

kingfish
Volunteer Moderator

0 Likes

Indeed under Known Issues on the Sep 16, 2020 version:

  • Audio may experience instability when connected through an Audio Video Receiver via HDMI on Radeon RX 5000 series graphics products.
  • Some games may exhibit stutter intermittently during gameplay on Radeon RX 5000 series graphics products.

At least AMD acknowledges the problems. 

0 Likes

I'll state the same thing here I did in another similar thread:

Great that it's acknowledged but it's been over a year and still not fixed which makes you wonder is this a hardware issue then that can't be fixed. Then will this issue carry over to RDNA2. I would be interested in one of the new cards if performance is on par with the competition but an audio issue would be a deal killer for me. 

0 Likes

I can't believe they won't even comment to the community about the status of this issue. When we pay hundreds of dollars for a card, its not really OK have this broken for over a year.

I also wanted to add that the most recent driver update was far worse. I literally just uninstalled it and rolled back to 20.8. The stutter with 20.9 had a new feature: occasional static noise in the audio output. 

If its hardware causing the issue I'm losing hope they'll ever mention in anywhere because of the new hardware they're releasing. If I get an Nvidia card and this issue goes away (and it sounds like it will), I won't look back. I've been exclusively using AMD for over a decade and this is supremely disappointing.

0 Likes

Best thing you can do is report the issue with the newest driver to AMD support. AMD in their infinite wisdom chooses to have teams working on different forks of the drivers. One team will fix an issue in one driver, then another team fixes another issue in theirs. The release it with the new fix introducing bugs that were already fixed before in another. This has been happening about 3 years now with regularity.

Report it to AMD:  https://www.amd.com/en/support/contact-email-form 

pubdev27
Adept I

Its definitely the driver and/or AMD hardware. I finally just got a sound card (its cheaper than shelling out more cash to replace the card). I like the card as far as its graphical performance. But they've acknowledged that this is still broken and have told us nothing about how they intend to fix it.

Sadly this will have to be my last Radeon card. I paid a LOT of money for these 2 cards and the audio is absolutely unusable and only becomes mildly tolerable if I carefully select an old driver -- thats terrible. Its simply not worth it any more.

But yeah, if any of you are still encountering this, if you can buy a cheap audio card (internal or external) that will at least tide you over until you need a new graphics card. Everyone else: return it if you can, RMA it or use the warranty. This issue isn't going to be fixed.

Agree.

Stuck older Nvidia vidcard I had into same PC was using my AMD card and not once had issue with audio via HDMI so pretty sure it's AMD card issue.

Latest few official drivers have totally  been broken for my RX 560 card how can they even be allowed to release such broken drivers!

"

  • Driver timeouts may be experienced while playing a game & streaming a video simultaneously on some AMD Graphics products such as Radeon™ RX 500 Series Graphics.
0 Likes

I'm having the same problem and it's driving me bonkers. What a shame I'm going to have to figure out another output for audio since this card's audio stuttering makes enjoying music impossible.

 

Any help AMD people? Any genius in the community found a reliable solution?

0 Likes