cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

stellaros
Journeyman III

Radeon RX 5700 XT 75HZ Refresh Rate Causing Issues

Hello! after further usage of my brand new 5700 XT (Refererence Powercolor model), the card seems to be unusable at 75Hz refresh rate (using Acer VG240YU 1440p 75Hz monitor).

Using 75Hz refresh rate, this sort of things would happen consistently:

- Wattman settings on Radeon driver does not show anything, no control, only zero numbers, nothing usable. (MSI Afterburner also does this) But strangely if I use 60Hz mode it will appear okay, I even tried undervolting & adjusting fan curve with no problem.

- Youtube videos will be extremely unplayable and seemingly very unresponsive, GPU usage reading on Task Manager will shown at 100%. Switching to 60Hz fixes the issue.

- In some games, the game will seemingly run fine and well. But the fan never ramps up, at first I thought the GPU usage is low but when I touched the back of the card it was very hot to the touch and I immediately quits the game. After I force Alt+F4 it in panic, the fan suddenly ramps up to maximum power. (Switching to 60Hz also fixes the issue) This issue almost kills my new card.

Other than this, my card also have issues whether its 75hz or not:
- V-Sync in game or via Radeon driver will result in ~30fps. My only saving grace is to enable Enhanced Sync or leave it off for it to run at 60+ fps.

Currently I'm using the most recent 19.8.2 Radeon drivers, previously switched from GTX 1060 6GB. Used DDU before switching the card, spotted this issues. Then I use DDU again, the issue still persist.


System specs:

- Ryzen 5 1600 6 Core Processor (Stock Clocks)
- Teamgroup Elite+ 16GB DDR4 2400 Memory
- PowerColor RX 5700 XT 8GB GDDR6
- MSI B350M Bazooka AM4
- Kingston UV400 120GB SATA SSD
- Seagate Barracuda 1TB 7200RPM
- 500W Be Quiet Pure Power 10 80+ Silver Power Supply

Anyone have any of this issue aswell? I really wish these issues will be fixed soon as I already planning to sell the card

1 Solution
Matt_AMD
Community Manager

This issue has been resolved in driver updates, you can download the latest driver (currently 19.10.1) here. 

https://www.amd.com/en/support/graphics/amd-radeon-5700-series/amd-radeon-rx-5700-series/amd-radeon-...

View solution in original post

118 Replies
vegetagaru
Adept I

same here with 5700XT

0 Likes
spajdr
Adept III

Same issues for me with RX5700 reference from Sapphire

Already reported this to AMD a few days back, I hope we get it resolved soon.

Except that VSYNC enabled does not cripple fps to half, only when having 75Hz set on LCD.

0 Likes
zantsu
Adept III

This problemas happens to everybody.

Every version released after 19.7.1 is causing constant BSOD when the GPU is needed.

0 Likes
needsnurfing
Adept II

same issue but i get bsods above 60hz and half fps vsync too.

0 Likes
philtheagony
Adept I

Same issue here with MSI Radeon 5700 XT. I'd wait a few more updates before returning the card.

crayraven
Elite

Im using the Asrock Challenger 5700 xt. I have similar issues, if the refresh rate is set to 75hz then  the card gets really hot and I start getting flickering. Eventually the card makes the screen blink over and over again. Setting the refresh rate to 60hz or using HDMI cord does not have this problem.

0 Likes

Interesting. Even when on 75hz with the hdmi cable doesnt have the instability issues?

0 Likes

I'm using the LG34UM67.  When HDMI is being used, freesync is disabled and the refresh rate is locked to 60hz. I can't change it to the monitors max refresh rate of 75hz. At  first I thought my display port cord  was going bad. Then I discovered that if  I disable freesync I don't have the instability issues for the most part. Just like the HDMI cord, if freesync is disabled then the refresh rate is automatically locked to 60hz on this monitor. 

My conclusion about this problem is that the 5700 xt has problems with freesync and maybe 75hz refresh too. It doesn't seem to be a driver issue since its present in the bios too. If I boot up using the display port, what happens  is my monitor turns on and off.  I see the  picture of the bios then it turns off, turns back on...repeat infinitely. The only way to stop it is to use the HDMI if I want to a access my bios. 

From what I see is that the only way we will see a fix is if we get a updated bios on all 5700 xt to fix the issue.

mahtab3
Adept II

FX 8350

M5A97 LE RE2.0

RX 5700 XT

AOC Q3279 WG5B

This same problem

only on 60 hz wattman work

V-sync work below 30 fps

freesync dont work

and lot BSOD

0 Likes
zachal84
Adept I

same...

0 Likes
horas12
Journeyman III

I have the same problem with my Sapphire Radeon PULSE RX 5700 XT and AOC 24V2Q 23,8".

0 Likes
Matt_AMD
Community Manager

Thanks for the posts folks.

I have passed the information from this thread onto driver engineering for investigation. 

new drivers dont solvet problems

capt_negev
Adept I

I Have The Same Problem Random Blue screens and system freeze

 

Amd 1800x

ASUS ROG Radeon RX 5700 XT OC

Asus Crosshair vi Newes Bios

lg 21:9 75hz freesynk screen

Adrenalin 2019 Edition 19.8.2

0 Likes
manneking
Adept I

Same problem. HDMI or DP doest matter 75hz is unusable.

0 Likes
hastular
Journeyman III

Same issue with Sapphire Pulse 5700 XT

Monitor: AOC Q3279VWF (Q3279WG5B) 75 Hz

same here, I have a 75hz AOC Q3279VWFD8

0 Likes

None of this works. The problem isn't that simple, it exists outside of windows.

0 Likes

I did that and my games crashed as soon as I opened them, would not recommend. Didn't back up my registry right so I had to end up completely reinstalling windows

0 Likes
nabokow
Adept I

same here. when I use 60hz monitor mode though, after a while under load playing games, I get black screen and PC shuts down everytime.

0 Likes
johnny19734
Adept I

I have the same issue. Can't turn on v-sync in game . Makes games run at 37 fps.  

0 Likes
he3ck
Adept II

I saw this forum a bit ago but thought I'd revisit it to confirm that the problem is still happening. My monitor is 75hz but I'm able to set it to 60. It still sucks I can't use the extra hz. I also get the 30 fps vsync issue and someone told me it had to do with ultrawide. For me that was correct. I set my in-game res to 1920x1080 instead of 2560x1080 and the problem disappeared. Try it for yourself to check too. It really sucks that even in the (at this point) latest driver, 19.9.1, multiple updates later the problem still isn't fixed. The only advice I could give is to make a custom 60hz resolution if you haven't already returned the card. Personally I'm considering just spending the extra $90 on a 2070 and returning this $400 paperweight. 

0 Likes
johnny19734
Adept I

Actually, I was able to hack this. If you create a custom resolution w/ either CRU and or within the AMD driver, it fixes the issue. Just make the same native res and HZ then reboot.  I was able to V-Sync game with-in game. It really works. 5700xt cannot read the Ultrawide monitors correctly. If you don't want to wait go for it.

0 Likes
mahtab3
Adept II

Driver 19.9.1

5700xt

75hz AOC Q3279VWFD8

same !

0 Likes
nozet
Adept II

Acer VG240YU, 75 Hz, 5700 XT
Same problem, driver 19.9.1
By the way, there is such a problem on ubuntu and windows 7

0 Likes
xunter
Journeyman III

same monitor and same problems. 

perhabs the fact is that the displayport cable is defined by gpu as dp1.1 instead of 1.2-1.4 ...  it may cause problems above (in FullHD 60hz everything works fine).Безымянный.jpg

For me the issue is still there no matter it is on HDMI or DP.

aleksh
Adept I

For me what is so far stable is creating a cru LCD Native profile with 72hz. With 75hz, while stable in Warframe, starts to lose signal and crash in Control ( probably because my range limit is 180hz on the pixel clock and making an LCD Native with 75hz pushes it to 185hz ).

0 Likes

My 5700 xt also loses signal repeatedly at the motherboard bios screen. Does anyone else have this issue?

0 Likes

Not under bios no.

Sapphire Pulse 5700 ( non-XT ).

lg24mp59g-p

Asus rog b350-f 

Evga 600bq

Try changing cables ? Maybe ordering a new DP.

0 Likes

I ordered a brand new cable and nothing changed.

0 Likes

Remove gpu , clear dust , reseat. Remove ram , clear dust , reseat. Let me know.

P.S. Although you're probably right and this might take a gpu bios flash update.

0 Likes

Yea I did that when I first got the card. Nothing changed. The most interesting thing is, that the problem is the same for all display ports. So its not a physical issue. It will be hard to convince the vendor to create a bios that fixes the problem, unless AMD does it.

0 Likes
vegetagaru
Adept I

Still Having BSOD all day, i did DDU changed registry etc etc.

ROG CROSSHAIR VII HERO (WI-FI) - Bios 2703

AMD 2700X

Sapphire 5700XT Blower - Driver: 19.9.1 - Using DP - 60Hz (75 fails)

0 Likes

My system reduced BSOD a lot after DDU+Bios change to PCI-E Gen 3
But this is with 19.9.1, 19.8.x keeps BSODing all the time.

PS.: All the BSODs that happened after (Only 1 in 3 days) ocurred when browsing facebook in firefox.

0 Likes

im using GEN3 and also tried with Auto, i already tried different browsers and same thing all over

besides some times it even crash when nothing is open at all ( i already changed the GPU for a new one and same thing happens)

0 Likes

You have hardware acceleration disabled right ?

0 Likes

atm yes

0 Likes