Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Radeon RX 5700 Direct3D Not Available?

My Specs


Processor: AMD Ryzen 5 2600X Six-Core Processor

GPU: Radeon RX 5700

16 GB of RAM

When I run the DirectX Diagnostic Tool it's telling me that Direct3D Acceleration is not available and there is no toggle to turn it on. Also it says Direct3D DDI is unknown. I have tried reinstalling the GPU driver and the C++ redistributables. Also I enabled Legacy Components. I even reinstalled Windows. This is a fresh PC build with a fresh install of Windows 10 so no old drivers to worry about. I'm driving myself crazy because I can't play any of the games I built the computer to play. Any help would be greatly appreciated. Thanks much

1 Solution

If these steps did not work, it is possible that the full driver package was not downloaded from the AMD website, after running DDU in safe mode. Using the AutoDetect installer or the minimal package installer, or updating via Radeon Settings 19.7.1 > 19.7.2 may cause this issue. We will fix that in a future update. 

View solution in original post

30 Replies
Journeyman III

My Specs


Processor: AMD Ryzen 7 3700X 8Core Processor

GPU: Radeon RX 5700XT

32 GB of RAM

Yes, I also met the same problem. I queried it. Most people said that it is a driver problem. Now there is only one driver to choose from, and it can't be played when playing MP4 video. I don't know if there is any way to solve it.


So is this something you think they will fix quickly? I have no earthly idea I have never dealt with something like this?

Edit: Just updated to 19.7.2 and still doesnt work

Journeyman III

Same problem with rx 5700 card

Adept I


MB: ASUS Z77-V Pro 

CPU: Intel Xeon 1230v2 Quad Core 

GPU: Radeon RX 5700 XT 50th Anniversary 

Memory: 16GB DDR3-1333

Same here. Not every application using D3D will crash, kind like those slightly older application will report cannot obtain D3D and crash after it. MPC-HC will crash, even dxdiag. 

Already tried DDU in safe mode, since there are more issue if simply switch to 5700XT from GTX1070 without DDU. But DDU do not help this issue in my case.

Adept I

Experiencing same issue

My Specs


Processor: AMD Ryzen 5 3600X 

GPU: Radeon RX 5700

16 GB of RAM

Yes, I also met the same problem. I queried it. Most people said that it is a driver problem. Now there is only one driver to choose from, and it can't be played when playing MP4 video. I don't know if there is any way to solve it.

Journeyman III

I ran into the same problem, but only after updating to the latest drivers (19.7.2 which were released a few hours ago). DXDiag reported that Direct3D is unavailable and I was unable to start a game of League of Legends due to "an unknown DirectX error". Reverting the driver to 19.7.1 seems to have fixed the problem, although I do have issues with occasional crashes on game start/freezing.

This is on a pretty fresh installation of Windows 10 (<week) and reproducible by upgrading to 19.7.2 or using DDU to uninstall 19.7.2 and reinstalling 19.7.1

My specs:

Operating System: Windows 10 Education 64-bit (10.0, Build 18362)
Mobo: Asus ROG Strix B450-I (BIOS Version 2406)
Processor: AMD Ryzen 5 3600X 6-Core Processor
Memory: 16384MB RAM

GPU: Sapphire Radeon RX 5700XT

PSU: Seasonic FOCUS Plus Series SSR-650FX 650W

Storage: Sabrent 1TB Rocket NVMe PCIe M.2 2280

Full DXDiag attached (after reversion to 19.7.1)

Journeyman III

PC Specs

Mobo: MSI Z370 GAMING M5

Processor: i7-8700K

GPU: Radeon RX 5700 XT

RAM: 32GB DDR4-3200 (4x8GB configuration)

OS: Windows 10 Pro Version 1903 (OS Build 18362.239)

I have the same issue as others have stated after upgrading from 19.7.1 to 19.7.2 this morning. I noticed that MPC-HC (media player) was throwing a D3DERR_NOTAVAILABLE error on every video I attempted to watch. VLC still worked fine. DXDIAG hangs on Direct3D component analysis and crashes without any notification.

  1. Upgraded from 19.7.1 to 19.7.2 this morning. Ran into the issue.
  2. Used DDU in safe mode and reinstalled 19.7.2 drivers -- same issue.
  3. Used DDU in safe mode and reinstalled 19.7.1 drivers -- issue rectified.
Adept III

I've found that the new drivers 19.7.2 have fixed all my issues.

Wattman shows proper statistics all the time. Also works with Afterburner (I am using the newest beta).

I can overclock the RX 5700 XT no problem, its stable and fast.

Only thing is if it's enabled is to ensure Freesync is off as well as VSR.

Also if you have 19.7.1 installed, remove it using DDU then install 19.7.2 clean.

Community Manager

Please can you try running DDU in safe mode, going to DDU > Options and select Prevent downloads as in the screenshot below. 


Select AMD then click Cleand Restart. Now try to install 19.7.2. 

I just followed these steps and can confirm that the DXDIAG tool shows the following. 



Thank you! I just repeated this procedure again .. and surprisingly, it worked! I'm now running the 19.7.2 drivers without any visible issues. I didn't have to select 'Prevent downloads' as I already had it selected since before I installed the 19.7.1 drivers. These were my existing settings in DDU :


Again, I have no idea why it worked this time because I merely repeated what I did when I used DDU to remove the 19.7.2 drivers and reinstall them. Heck, I even used the same install file which was sitting in my Downloads folder (win10-64bit-radeon-software-adrenalin-2019-edition-19.7.2-july16.exe). I've attached my DxDiag.txt's after running DDU in safe mode and after installing the driver again for your reference.

I know at this point there probably isn't anything you can do, but I'm letting you know I did exactly that and it still didn't work. Not sure what to do at this point beyond that. Thanks for the help anyways. I suppose I'll just have to wait for the next update. 



Sadly didn't work on my end. And I tried multiple times, even going back and installing 19.7.1. I'm pretty much SOL until AMD fixes it in a new driver. 


This worked for me, I just installed 19.7.2 after following these DDU instructions and it sorted my issue out. Starcraft 2 now loads


If these steps did not work, it is possible that the full driver package was not downloaded from the AMD website, after running DDU in safe mode. Using the AutoDetect installer or the minimal package installer, or updating via Radeon Settings 19.7.1 > 19.7.2 may cause this issue. We will fix that in a future update. 

My Starcraft II loads, however after the game being unable to detect optimal graphics i went ahead and cranked it up on extreme settings jumped on to play and realized the game has a very low textures...I have spent all night and part of today trying to figure this out and im tired...i should have remain with my Undervolted Vega 64....Will simply turn this thing off until new driver comes out..


Yes this fixed it amdmatt!! Thank you so much

Adept I

I tried the DDU and reinstall of 19.7.2............................ and it worked. 

Thanks much.

Adept III

Below worked after extra restart.

Download from AMD website the full install: approx 430mb



Extract to download folder then open and run the program

Select the GPU setting from GPU/Audio button.

Select Prevent windows from downloading drivers checkbox in options

Select Clean and restart

Install from your download.

Restart the computer wait for a few minutes then restart it again.

Type "Screen Saver" into Cortana and check if bubbles is working, if so D3D is working.

Now check if D3D now appears enabled in DXDiag with the run command. (type run into Cortana)

above worked for me.

AMD should buy the DDU program and include that as their "Clean Uninstall"

Thank you Wagnardsoft !!!

Adept I


Mobo Gigabyte AORUS X570 PRO

CPU-Ryzen 3600X


RAM 32 GB 2400 MHZ CL12

I had the same problem. I used DDU, now in dxdiag Direct3d in enabled, but I still cannot play Fate of Atlantis, Starcraft2 and even in World of Tanks, there are pale colours. I am so nervous about this stituation. AMD Radeon Drivers are so bad, so bad, so so bad!! Is there anybody from AMD who is reading this?? What are u doing to improve your drivers?

Adept I

I used DDU in safe mode and then installed 19.7.2 successfully with Direct 3D working. It caused all my monitors to go green till I restarted though.

You can also try right clicking on desktop > go display settings and that will fix that bug without having to restart the system. Microsoft is listing it as a known issue to be fixed in build 1903. 

Adept I

I gave up on Rx5700 today and went and replaced it for an ASUS RTX 2060. Works right out of the box. Scored 5X times on the Unigen Heaven benchmark test. No issues with playing youtube videos. The system seems to be at ease and seems to be working much better now. I guess a stable/mature video card with established drivers is the way to go. I couldn't wait for AMD to get the drivers right - lost my patience after 2 weeks of playing install/uninstall drivers.

Don't blame you there my friend. I was very tempted to return mine too but I'm holding out a bit longer for now as I also have a waterblock ordered for my RX 5700 XT which arrives next week. I think they will get these issues sorted it's just going to take a bit for it to happen.

Journeyman III

I'm encountering much the same problem, but none of the solutions in this or other threads I've found so far have worked. I have run DDU, ensured the "Prevent downloads" flag was set, and run the full driver install from win10-64bit-radeon-software-adrenalin-2019-edition-19.7.2-july16.exe. Motherboard BIOS has been verified to be the latest; I have run the AMD x570 chipset driver installer from AMD's site.


OS: Windows 10 Home, 64 bit (version 10.0.15063 Build 15063)
Motherboard: MSI MPG x570 Gaming Plus (bios 7C37vA2)
Processor: AMD Ryzen 5 3600X
Memory: 32GB

GPU: XFX Radeon RX 5700 XT

PSU: Corsair RMX Series RM650x


Update: After further investigation, determined that Windows had not applied all updates. Ran all updates, dxdiag failed abruptly without erroring. DDU'd graphics drivers, reinstalled; success, directx appears to be working now.

GLad you were able to get it working,but please note we only validate our drivers againat the latest Win 10 build which is currently 1903. 


The potential issue here is your Windows 10 build is severly outdated. 

Adept I

Sooooooo, i have istalled 19.7.3 - still cannot play Fate of Atlantis. When my character reaces Atlantis the game crushes!!!!!! Go for Nvidia!

Journeyman III

i just recent bought the MSI rx5700 followed theyre instructions and downloaded the drivers from theyre website im running 19.8.1 adrenalin 2019

amd radeon rx 5700

windows 10

8gm ram

intel i3-8100 @3.6ghz

Direct3D® Version

someone please help im not a computer guy i work on cars all day long i just wanna relax n play some csgo XD


i have ran dxdiag with no fails no problems nothing im able to play most games but cant seem to get csgo to work as i get the d3d problem popping up every time i try to run it