Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Radeon R9 390 8G prevents system boot

So I have bought this card back in november 2015 and for some reason, it has been troubling my system for the past week or so. Whenever I have the card connected, my computer will "turn on" but won't actually boot. Fans are running, the power supply is making noise, all the normal things are there. Nothing shows up on the monitor however. I have tried reinstalling all the AMD software, I have tried reconnecting every thing in my system, I have tried a different power supply, I have tried a different monitor and nothing works. Whenever I have the R9 390 connected to my system it won't properly boot anymore. Normally when windows is running, I have to hold down the power button +- 3 seconds for my computer to power off, however, when the problem presents itself like I discribed, the computer instantly turns off when I touch the power button (that's why I don't think windows is booting at all). I have plugged my monitor into my motherboard and I am using my graphics chip at this moment, because my GPU does not work. I still have exactly 1 month left on the warranty and am considering returning it for reparation/replacement. Has anyone had this problem and know how to fix it?

1 Reply

Without any INFORMATION REQUIRED WHEN POSTING A QUESTION​ , can only suggest trying different cable/port to monitor/card.

And checking mobo error code/s when booting ?

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..