Showing results for 
Search instead for 
Did you mean: 

Drivers & Software


Radeon Overlay doesn't work, how do you fix it?

Hey guys, I've had this problem for quite sometime. My overlay no longer works. So I can't use the performance overlay nor relive overlay. Nothing shows, but using the hotkeys to start lets say recording pops up. What is the problem? I read that gpuup.exe is related to overlay. But I'm not sure if that is true or not. But when I checked my amd folder where it should be, there was nothing there.

Any help would be appreciated!

13 Replies
Adept I

My guess is in the upgrade hot key got confused. Try this:

- Go to Radeon Settings / Home Page (Via desktray icon or right-click desktop 'AMD Radeon Settings)

- Click Preferences (@ Bottom)

- Change the 'Toggle Radeon Overlay Hotkey' key. Click in the box than select a new combinaison. (I like CTRL+SHIFT-Z but use one not already used elsewhere.

- Try it. Let us know if that worked or not for you.


Adept III

Same problem. Overlay not work.
AMD FX 8350
Sapphire RX 480 8GB

Clean install 18.12.2

Edit: I change language to another language and Overlay again work.

Edit 2: Not working performance metrics. This is "nice" driver.

Edit 3 (temporary fix):

1. AMD Clean Uninstall Utility

2. Download and install driver

3. Change to another language you know

4. Done.


Report driver issues to AMD


Hello, first: report issues online when i click on that, there is "Redirecting to page" loop, i waited about 30 min and nothing happend, second what is amd reference and how can i obtain that in the problem report wizzard?

Best regards and thanks in advance!Capture.PNG


Adept I

I had a similar problem. The overlay showed up for me but the performance metrics did not. I applied the fix that marekbujko​ said above.

My PC:





Changed the language of Radeon Settings to a different one. Tried the performance metrics and now it is showing.

Switched back to english language, and it is still working. I haven't restarted my computer, so I don't know if the fix is permanent.

Journeyman III

I finally got the overlay to work....

I had a similar problem, it would seem the overlay would work on the desktop but not in the games, it would freeze my cursor but nothing would come up.  I reinstalled drivers and changed settings followed others posts but nothing worked.

I did finally manage to get it to work with fortnite (only game i'm playing right now) I did the following:

disabled the windows 10 game mode and other capture settings in windows control panel

found the game executable and 1.)  disabled fullscreen optimizations 2.) ran in windows 8 compatibility mode

I really think it was modifying the executable that made the difference, once i restarted the game the overlay popped up with both alt+z and alt+r as well as messages regarding recording screen clips.  

I hope that helps somebody else

- RT

i have the exact same problem as you. trying what you suggested did not work. Did you ever find a different fix?

If you have Wallpaper Engine installed, try disabling it for that. You can do that through removing Wallpaper Engine from the list of games in the 'gaming' tab.

This fixed the problem for me when I could only bring it up on the desktop, and when I tried in game it would freeze the cursor and the overlay would be invisible.

Hope this helps.

overlay not working. first time using radeon card after 9600 ati. kinda regret moving to 6900 xt mgpu. 

I had to create an account just to thank you. I just got my first Radeon GPU and this issue has been bugging me for days now. I had the exact same problem you were having, the overlay would work in the desktop but not when opening the game and also froze my cursor. But the moment I configured Overwatch.exe to make wallpaper engine stop I could see it in game! Thank you so much!!!

Journeyman III

Also, if you have copyright protected content openned in your browser or something like that (In my case it was spotify on google chrome) the ingame overlay won´t appear and if you use the hotkeys to recoord there will be a pop out noifying that there are protected content being played.

Journeyman III

Something that worked for me:

Toggle every possible setting off and on.

And then it worked again.