cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

cyber_punk667
Journeyman III

Radeon HDMI audio fine 1.4b Horrible over HDMI 2.0+

This is really beginning to bother me.  This is ongoing since GCN as I first experience this issue with the 7870 and continues on to the 5700XT. 

HDMI audio transmits fine over Hdmi 1.4b (my older 1080p LG tv) has perfect working STEREO audio out of EITHER card!

If I take either card and plug it into (I have tried like 5 brands) a TV that is HDMI 2.0 or above (2.1 or whatever) the audio drops out completely for seconds at a time and/or crackles horribly.  This is on just the STEREO output of the tv.

I have tried many different cables.

I have found out that the newer cables are not backward compatible with the video card and the tv. I have to use the proper version.  (Not really sure why I added that bit but meh 20 hdmi cables have been tested amongst various older and newer tvs)

If I need to make a video I suppose I can.  But you just updated something in the driver for surround it made a (slight) difference as it seems to play sound a tad longer before the bitrate mismatches. (How do you guys screw up sending PCM data over a wire?!?!)  Also seems many others report these sound issues however, not seen anyone mention how it works fine over the older hdmi standard.  

 

Hopefully someone finds the **bleep** typo already and can give us proper HDMI audio over the whole range of hdmi standards  

Tags (2)
0 Likes