Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Radeon graphics driver still broken - No clue what to do.

Describe your system:

  • Radeon R9 270x Gaming 2G (MSI)  (Previous post I got my specs wrong, this one is right)
  • Windows 7 Home Premium SP1 Desktop
  • I have tried various radeon driver versions, ranging from:
    Multiple versions of AMD Radeon Catalyst (One from 2013 and one from 2015)
    Multiple versions of Adrenalin (Latest as of writing and earlier release)
  • AMD FX-8350 Eight-Core Processor 4.00 GHz
  • ATX-AP800W
  • 16GB DDR3


Describe your issue:

For reference:

My problem is this:  Each time I attempt to clean install any version of Radeon drivers, on restart my computer gives me a black screen before it even gets to login.  However, I can get to the recovery screen and enter the various safe modes if I restart and use F8 during the boot up sequence.  I have made sure that windows needs no updates, even checking the website just to make sure.  I have performed various tests including attempting to install Windows 10 (Long story short, upon restart it didn't even let me fully set up the OS and reverted me back to windows 7 saying there was an error during install.)  I have made sure to perform complete clean uninstallations of the software each and every time using DDU, and the uninstaller provided by most radeon driver programs, and all while making sure I am in safe mode.  I have also made use of the DISM and SFC commands (Both showed no results)
I made usage of the hard drive cleaning tool which scans the HD for possible insecurities and anything broken, and even that was no help.  I used the boot logging setting which can be found from the Recovery Screen and received a massive amount of these:
Did not load driver @cpu.inf,%amdppm.devicedesc%;AMD Processor
Did not load driver @oem13.inf,%amd6810.1%;AMD Radeon R9 200 Series

(ntbtlog.txt can be found attached)

TL;DR I am running out of solutions, and any supposed fail-safes are..  Well, failing.  Please, I need help.

15 Replies
Adept I

Crud I forgot to add the ntbtlog.txt, here is a download for it:



Here is the latest AMD Driver for Windows 7 x64 for your R9-270X: AMD Radeon™ R9 270X Drivers & Support | AMD  and the Release Notes: Radeon™ Software Adrenalin 2019 Edition 19.4.1 Release Notes | AMD 

What is the Make & Model of your Motherboard and do you have the latest BIOS version and CHIP Set installed?

Does your R9-270X does the same thing on a different compatible computer?

When installing the AMD Driver, what Error message pops up or any error messages when it starts to boot into Windows with no video?

Are there any Motherboard TROUBLE L.E.D.s or TROUBLE DIGITAL CODES or more than one BEEP when booting up with a black screen?

NOTE: Try downloading the latest Windows 10 version using the Windows Creator's tool and install it on a USB Flash drive or burn it to a DVD Disc. Then input your Windows 7 Serial Number during the beginning of the Windows 10 installation. That way your Windows 10 is free and gets activated at the same time.

If the Windows 7 Serial Number doesn't work, then after installing Windows 10, go to Windows Settings Activation and click on "Change Product Key" and input your Windows 7 Key. It should then automatically activate your Windows 10 permanently as long as the Windows 7 Key is legitimate and not illegal.

Adept II

If you can boot in safe mode, I would try running CCleaner. It seems there's something wrong with Windows itself, maybe not even directly linked to the driver. If it's an old installation of Windows 7, it also might be time for a clean install (and yes, I hate saying that!). Sometime, it's just easier to start over with a new OS installation than trying to find some old/unusual bug incrusted in an old installation...

Big Boss

sounds like a modified gpu-bios for me
run Windows SafeMode!
if you have video there you can download and run: atikmdag-patcher.exe and it will work than in normal windows

you get into safemode if you interrupt boot 2-3x with a poweroff

PC: R7 2700X @PBO + RX 580 4G (1500MHz/2000MHz CL16) + 32G DDR4-3200CL14 + 144hz 1ms FS P + 75hz 1ms FS
Laptop: R5 2500U @30W + RX 560X (1400MHz/1500MHz) + 16G DDR4-2400CL16 + 120Hz 3ms FS

Out of curiosity, what makes you think it could be a modified BIOS ?


if you get no video in win but at boot than driver doesnt like the bios of your card

PC: R7 2700X @PBO + RX 580 4G (1500MHz/2000MHz CL16) + 32G DDR4-3200CL14 + 144hz 1ms FS P + 75hz 1ms FS
Laptop: R5 2500U @30W + RX 560X (1400MHz/1500MHz) + 16G DDR4-2400CL16 + 120Hz 3ms FS
Adept I

Sounds familiar to me.....  Black Screen on Laptop 

Is it a Laptop?

Try to connect an HDMI device.


Okay I know you have had a lot of other good advice here. I have an R9 380x that was having these same problems and still would be but I found out how to get it to stop, if the card is not dammaged from this happening.

Not trying to scare you but there have be a ton of threads on this issue.

To get the driver to load you have to ( and I know you have done many of these things but you have to do them all) do the things I am going to list.

Disable Fast Startup/Hibernation

Disable Windows Update from Updating Drivers. Win Aero Tweaker from winaero_com can make this registry change for you on Windows Home or Pro easily, it's a free app.

Make Sure Windows is fully Up-To-Date


Have current driver downloaded and ready to load locally.

Run DDU from from Safe Mode with Internet Disabled

Leave Internet Disabled Reboot

Install Driver, Choose Clean Install, if not available that's good DDU did it's full job! Internet Disabled, this is a must!

Restart and Pray for the best.

If it is still not starting your card may already be fried at this point. This black hang issue in my opinion for many killed their cards. Many kept trying over and over to get Windows to go each time damaging the cards. I was lucky and noticed that not only was it black screening but realized the chip was overheating and shut my machine off. Then eventually figured out why it wasn't loading in the first place was Windows Update was corrupting the install.

I hope your card is okay and this helps.

Thus far everyone of these I have seen reported to AMD they don't acknowledge an issue they blame the hardware. To me it is obvious it is an issue with the installer. This seemed to affect a ton of R7 and R9 owners but AMD has never acknowledged why the driver install only corrupts on these cards. I do know however whatever it is Windows update is also stepping in and messing it up.

That would explain some threads here at AMD Forums in the past where R9 and some R7 would stop working after the computer crashed due to video or after a Driver update and the computer restarted with no signal and a defective GPU card.

In some of the threads I did mention to the Users that there were other Users where their R9 or R7 failed to work after the computer crashed or the AMD Driver was updated.


yes and this has been brought up many times in other threads. when this happens the chips almost immediately overheat and they black screen. people keep rebooting their machines over and over not understanding they just keep doing the same bad thing. had I not had it happen to me the first time on a machine I had on my test bench that was open, I would not have caught what was going on. you can return to older drivers and it works. you can load the new drivers if you do it how I said, but you have to disable windows update. then you have to hope your card didn't get toasted in the process. hundreds of cards didn't just suddenly go bad between late 2018 and current drivers. this is wide spread issue talked about in many threads here and in other forums as well. just like the hd 7970 issue they didn't acknowledge but finally do. this one is an even bigger issue but it results in so many dead cards it is being written off as just hardware failure. I was able to reproduce this issue 100 percent of the time over and over on 2 cards and 3 systems in my testing, I just made sure I pulled the plug immediately.. 

I've tried doing old driver loads and it does the same thing, I've even tried it on older windows builds. still nothing


Hey, me again. I don't understand what is right and what is wrong anymore, but I feel like I should mention it here. Just in case.

I eventualy made it to work. Several times. And I don't know how. I also hope AMD is not going to "fix" it.

  • The Win7 version doesn't seems to be the matter. I did several clean installs of an old (around 2010) Win 7 build and managed to get my hands on a pretty good Win7 SP1. I had another SP1 which failed though so I'm not sure what are the differences in all of them. All my installs were clean on fully formated drive.
  • I downloaded drivers from - tech support advised me on that one so I guess it's trustworthy. No viruses yet. Theese drivers are basically the same install packs from official website.
  • I certainly did clean install of drivers, where AMD software failed to install (installing the driver beforehand thankfully). I did "restore factory settings" every time even if it disn't make sense. The thing is that on current Win7 SP1 install didn't fail and I had to uninstall everything (without DDU) and use next thing. It did not matter.
  • The very last time I used manual windows driver search and install. I unpacked AMD instalation pack. Then through a device manager I installed only graphic drivers straight from the unpacked folder. Still shows me some AMD log utility driver that is missing. Did work though.
  • I never installed MSI Afterburner before drivers. That's for sure. In some cases I didn't even have MS .NET framework or any Visual C++ installed. Not sure if that matters.

Again sorry for updating old thread. Maybe someday it'll help someone. I asked my father who is way better with computers than I'm he's confused too. He also said that if graphics card still outputs immage it might be fine - fried cards don't show anything  and he's got some Nvidia's he tried to restore to back up that claim.

What is also funny here and scared me to death is that I somehow managed to recreate this black-screen\turned-off-monitor without my AMD card whatssoever. I used motherboard's integrated graphics card (and god only knows what build and setup)  in that case. Didn't even touched BIOS\UEFI here. So at this point I'm considering psychiatist.

I hope your graphics card will work and that I didn's annoy you as much.


Not sure why someone felt this isn't helpful. This is the exact same advice that helped this work in MANY OTHER THREADS WITH THIS ISSUE. The OP is always allowed to follow whatever advice they choose. 


Hey I know I'm acting kinda like a wierdo and all but right now I'm in utter desperation. Please don't be mad and at least hear me out.

I've had an issue like the one in discussion but even worse. I have AMD RX 580 graphics card and I've stumbled upon the same problem of my display working fine without drivers or in safe mode but totally turning off with normal "driver" startup. I think I had to do about 10 fresh installs of windows to figure that out. My win 7 was not really updated since 2011 (It's not fully "official" to put it gently). I haven't had any updates at all, i think. Last big thing I installed was steam version of Garry's mod.

So if you're not very busy or angry at a newbie ressurecting old tread please advise me at least a little bit in what to do now. I don't really understand how DDU should help and I'm lind of scared to even try another driver startup. My windows 7 now is different and is currently "up to date". At least it doesn't have any "importaunt" updates for me to offer.

Should I check for something else on my system?

Is that a working method now? I mean, things might have changed and all.

My AMD card is working well without drivers on updated windows and normal startup. This looks to me like a working card but are there any other ways to verify that, or at least confirm that my Graphics card is dead?

Have people found out which update actually breaks it?

I know I'm asking a lot but I'm currently out of any ideas even where to look at. Google is not being very helpfull either so I will be very greatfull if you'll find a time to help me. I haven't found a better way to contact you rather than this.


P.S. My english is a bit clunky - sorry for that too.


I looked through your boot log, there is quite a lot of other things not loading, but i don't know how to interpret what should/not load during boot.

You may do better also posting on where someone will most likely have more knowledge of possible causes.

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 7000s 2tb, Nitro+RX6900XT, RM850, Win.10 Pro..