Showing results for 
Search instead for 
Did you mean: 

Drivers & Software


Radeon driver crashes system, won't install

Earlier this week, I turned on my PC in the morning to discover it had crashed. After trying to reboot, the system would hang up before loading Windows.

After a few hours, I figured out that the Radeon driver (20.7.1) was causing the issues. Uninstalling this driver allowed my system to boot - although now, of course, I couldn't use my GPU, or my second monitor. I tried reverting back to 20.4.1, but that crashed the system, too.

Later that day, 20.4.2 and 20.8.1 became available to me. When I installed 20.4.2, my system started working again. I was able to launch the Radeon software, my second monitor was connected, I was able to get my displays configured to maximum Hz, etc. I thought the problem was fixed.

The next day, when I turned on my computer, it had crashed again. Same issue: it would freeze before loading Windows. I tried the same fixes I'd tried the day before, but none worked. Either the system freezes and crashes when I try to install a driver (usually at around 40%), or it successfully installs, then crashes the system and the system fails to boot again, where I have to do a system restore.

I've tried every troubleshooting fix I can find online. All the default drivers are up to date. I've tried using the DDU utility. I did a clean install. I've tried temporarily turning off antivirus protection. I've tried installing in safe mode. I've tried using both the auto-detection installer and the direct download installer. Nothing works.

This system is two weeks old. I literally just put it together.

- GPU: ASRock Phantom Gaming D Radeon RX 5500 XT

- CPU: Intel Core i5-9400 Coffee Lake


- OS: Windows 10 Home

Please let me know if you need more info. At this point I feel like my only option is to convert to GeForce, because this GPU is literally unusable.

UPDATE: I just decided to convert to a GeForce, which works out of the box and is just better. Leaving this up for others who might have this issue. Good luck folks.

0 Replies