Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Radeon Adrenalin 23.9.2 FIX!!! (UPDATE)

Im running into a problem with Radeon Adrenalin 23.9.2, after the update/install, if i open up any webbrowser, "Google Chrome, Firefox, Microsoft Edge" all webbrosers will after short time freezes for a few seconds.
i have tried all thinks, deleted %tempt% files, i have run scn /scannow"
i have tried windows clean installation, and all chipset drivers fresh install everything.

i tired hardware acceleration on all webbrowsers, nothing seems to work.


AMD RX 6950XT Nitro+

Ryzen 5 7600X

16GB ddr5 6000mhz cl32

Asrock B650E pg riptide wifi.

seasonic prime GX 1000W




i ddu the driver and all other drivers to my pc, even mouse and keyboard driver, then i boot to normal windows (whitout) drivers to anything.

i redownlaoded the driver but from after i bootet back to safe mode with "wifi" installed the driver and boom! it is working with the new drivers now!

hope i can help some of you guys aswell, i have spend all night almost 12 hours to figure it out now i can sleep!! THIS IS FOR RX Radeon™ RX 7900/7800/7700/7600 Radeon™ RX 6900/6800/6700/6600/6500/6400  Radeon™ RX 5700/5600/5500/5300 THIS IS FOR THE OLDER Polaris and vega GPU Radeon™ VII Radeon™ RX Vega Series GraphicsAMD Radeon™ Pro Duo Radeon™ RX 500 / Radeon 500X Series Graphics Radeon™ RX 400 Series Graphics







41 Replies

Unfortunately I am also in the same situation, with all the drivers since version 23.9.1, I just have problems. Problems in browsers, problems in office, sometimes rgb ram configuration problems. Unfortunately I don't have an nvidia card to try but I only have my 6900xt.

Journeyman III

Im having similar issues except i cant get in web browser or any shortcut when i click it does nothing but keep blue circle thinking. When i right click the screen it says loading where it would say Adrenaline or pro. I updated the driver and had several windows updates its a 2 day old computer ..when i bring up the windows box Task manager App manager Eexcedra i cant click on any of them . Only thing that seems to work is Windows +R commands. Any help would be appreciated