Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Radeon 7800 stops working after driver update

I built my first PC in august 2020 and everything is new but the GPU as I wanted to wait for the newly announced RTX or AMD cards to come out. Yes I know, the card is very old, and there is a very bad bottleneck.
2x16 Corsair Vengeance RBG Pro 16384 MB (DDR4-2137)
AMD Radeon HD 7800
Samsung SSD 970 EVO Plus 1TB
2TB Seagate BarraCuda 120 SSD
EVGA SuperNOVA 650 Ga, 80 Plus Gold 650W, Fully Modular
It has been fine with no hiccups whatsoever for around 3 months. But I recently started getting very very bad crashes and blue screens. Looked on forums and decided to update all my drivers (all were up to date but the GPU and one other thing) Checked the date for the driver and its driver was from 2018. I first, just right clicked and updated it (brought it to May 2019). It worked, but I was still getting crashes and blue screens, so I assumed there was an even later driver. Headed onto AMD driver support to look up my GPU, and saw that after entering the Radeon section, then going into the 7000 series, there is only a driver for a 7850 and there is no mention for a 7800. I downloaded both the auto-detect and installed. I will now Paste the steps I did.
Installed adrenaline 2020 auto-detect.
Installed the experimental version 20.11.2, got a black screen after the driver unplug and replug.
Restarted into safe mode.
Deleted everything AMD to reset. (Used DDU)
Repeated step 1.
Installed Recommended version 20.9.1, got a black screen after the driver unplug and replug .
repeated steps 3-4.
installed adrenaline 2020 version 20.4.2 for the Radeon 7850. got a black screen after the driver unplug and replug.
repeated steps 3-4.
When in safe mode, and open device manager, I can see the card, and after deleting everything it's back to Microsoft Basic Display Adapter, and ill provide pics. I realize I lowkey messed up not noting down the version of the original driver I had before everything.
I am currently with no drivers installed and can't really play anything as integrated graphics is a no-go lol. I'm at a point where I think I should just tough it out, and wait for a card to go into stock and get lucky. Any help is appreciated!
Validation from CPUID CPU-Z (Any specs I missed)
PhotosDriver support site not showing my cardDriver support site not showing my cardDDU with driver installed (In safe mode)DDU with driver installed (In safe mode)DDU with no drivers (Not in safe mode)DDU with no drivers (Not in safe mode)
4 Replies

Have you tried installing and  updating your Intel Integrated Graphics for your motherboard from Asus Support:

You Intel Drivers must all be the latest version especially the Intel Integrated Graphics and CHIPSET drivers. Also see if you have the latest BIOS version installed which might make it more compatible with your AMD driver.

Your Desktop with a HD78xx GPU card installed then you need to post the exact errors you are getting either in Device Manager or Windows Event Viewer under "Errors" or from the AMD installation program itself.

NOTE: In the image you are downloading a AMD Laptop driver and not a Desktop driver for your HD78xx GPU card. I would run GPU-Z to find out exactly which GPU card you have installed.

Okay, so my Bios is already up to date, but the others were out of date. I had to install "MEI" to install that integrated graphics and chipset driver. After successful installations and retrying to install the new GPU driver, I still end up with a black screen after the unplug/re-plug sound.

I see you say I was using the wrong driver, so I did what you said and got GPU-Z. I am confused, though, as before I had working drivers, it still said 7800 and no other number, so I searched up to see if there was maybe a site still selling it, and found a link for it on amazon. (dropping a screenshot of GPU-Z and the amazon link to my GPU)

As for the errors, I am not getting any. I did get a 192 for one of my driver installs, but I fixed that immediately after running DDU. When I install the driver for the 7800, everything goes smoothly until the drivers get switched. I get a black screen and then go into safe mode and delete the driver with DDU. 

GPU-Z no drivers installedGPU-Z no drivers installedCapture1.PNG

According to GPU-Z that you uploaded you have a Sapphire HD7870XT GPU Card.

Screenshot 2020-11-19 153139.png

Also GPU-Z is showing that you don't have your AMD Driver installed since it is using the basic MS Graphic Adapter driver.

Try installing the full AMD Driver set from AMD Download page.

Run DDU with the internet disconnected and delete the AMD previous installation folder at C:\AMD from the Root Directory.

After DDU reboots into the desktop with the internet still disconnected, install the full AMD Driver set. Once the AMD Driver install successfully, reconnect the Internet and again delete the newly created C:\AMD Folder to gain HDD/SSD space and to prevent future conflicts when installing a new AMD Driver.

Adept I

same issue. windows 10?