Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

Radeon 5600G Integrated Driver Issue

Hi there,

Just done a server build with a Gigabyte Mobo with Ryzen 5 integrated graphics (5600G), and all is well until the Adrenaline drivers go on. I need OpenGL 2.2 for the software I am running.

The Microsoft basic driver that Win10 has popped on works absolutely fine at 1920x1080, however as soon as the AMD driver goes on the graphics get limited down to 800x600, which is below the minimum for the software. 

Any ideas? I've tried older drivers and been through various forums talking about advanced settings and listing modes, but in the modes it still has 800x600 as the maximum and in display settings the resolution is locked at 800x600.



20 Replies

The IGPU supports OpenGL 4.6 which is enabled by the AMD Driver.

Can you post your PC information (CPU, GPU, Motherboard, etc) and Windows, BIOS, & AMD Driver versions you currently have installed?

after you install the AMD driver and your are using Windows run GPU-Z and upload an image. It will show if the driver is installed correctly and all APIs at the bottom are correctly check marked for a AMD GPU card.

also check Device Manager for any errors.

By any chance are you using a Windows LTSC version?

Adept II

Hello, apologies for extended time to reply, I've been off sick with Norovirus

So, Spec is as follows!

Ryzen 5 with Integrated Radeon 5600G


Gigabyte B550M DS3H Motherboard.

Windows 10 Pro

AMD Driver is the Adrenalin version or the Windows auto detect version from Windows Update. Both lock screen to 800x600. 



So I've just reinstalled the graphics drivers as you can see in the image, and straight away it's 800x600 locked again. So for now I'll have to uninstall the drivers so the system is usable, and go from there!

How is your monitor connected to your motherboard's video output?

You can't change the Resolution through Windows Settings - Graphics:

Screenshot 2023-01-18 214124.png

NOTE: You AMD VGA Driver seems to be installed correctly and all the API's at the bottom applicable to AMD GPUs are correctly check marked.

The problem is either your Monitor, Cable to Monitor, or Windows or Radeon Configuration.

EDIT: Notice that you posted your PC information while I was posting.

Try installing Gigabyte own OEM AMD Driver for your APU Processor. See if it makes any difference:

Screenshot 2023-01-18 214124.png

Seems like Gigabyte combined the OEM AMD VGA Driver with the AMD Chip Set driver into one package. That might solve your issue.

When you install the AMD OEM Driver delete the created AMD Driver Installation folder at C\AMD and then use DDU (Display Driver Uninstaller) with the internet disconnected BEFORE install any AMD driver.

Once it installs successfully, upload a image of Device Manager -Display and GPU-Z again.

Truthfully your issue might be a configuration issue either in Radeon Settings or Windows Settings. Let see if by installing Gigabyte's own Graphics and Chip set package helps  your issue.

Also if you have BIOS version F13 installed try updating to a newer version that help in compatibility issues with hardware.

Adept II

Hello. So there is one thing I forgot to mention. 
Between the monitor and the PC is an HDMI over Cat6 Extender. Now, this works fine with the laptop that was there temporarily (which also has a Radeon 5600G in it). However you are correct that the resolution in windows is locked. 
I did wonder if the EDID data was corrupted or something like that, however when I tested it with the laptop instead it just worked perfectly. 
I’m going to be there most of the day so I can do loads of tests and try different things. 

Thanks so much so far 


I bet the problem is the Cat6 Extender. It is possible it isn't completely compatible with Windows.

What happens if you connect the monitor directly to the Motherboard's video output bypassing the Cat6 Extender? Does work correctly now?

NOTE: What are the specs for your Cat6 Extender as far as connecting a HD Monitor or Monitors?

That would eliminate the Cat6 Extender as the problem or not.

Well, this is what I was trying with the laptop. The monitor is fixed in the location where it’s extended to, so it can’t move. The laptop has Win10 Pro with the same card and everything, onboard HDMI out etc, but just works fine with the extender. It does display as it’s own monitor, FHDExtender, however I use them all over and haven’t had the problem. Even with the same card at another location.

Adept II

Also, if the extender was at fault, I don’t get why the windows generic drivers work but the AMD drivers have such an issue. If anything you’d expect it to be the other way round. 

Good points maybe the AMD driver is having issues with the Cat6 Extender or it is a Radeon Setting causing the issue.

In the past User enabling or disabling certain Radeon Settings have been able to fix Resolution issues.

Try installing Gigabyte's own OEM AMD VGA driver just to see if it makes any difference.

I’ve just arrived back after lunch so I’ll give it a go now! 

Also in Radeon Settings try to disable everything possible one at time and see if the Resolution goes to normal each time.

The Cat6 Extender is connected to the PC via HDMI cable correct?

NOTE: If you are wondering I am trying to eliminate the Cat6 Extender as the reason for your problem.

Also if it works fine with your laptop try to compare your Laptop Windows, Radeon, and BIOS settings to your PC Windows, Radeon, and BIOS settings.

Those settings that deals with the Monitor generally.

Plus when connected to the PC check the Monitor's Settings. Maybe something changes automatically when you connect the laptop and the PC to the monitor.

EDIT: I might be completely off but I don't believe the issue is with the AMD driver since it seems to be installed correctly and there are no errors in Device Manager that you have mentioned.

Adept II

Yeah so for some reason the driver install is having the same result. Microsoft drivers = full resolution, no issues, but AMD drivers and Gigabyte drivers immediately lock to 800x600 and that's your lot.

Adept II


So I've uninstalled the driver again because otherwise I can't reply. The image is so massive that half the forum doesn't display!

So GPU-Z page is with the Gigabyte installed and the Advanced one is with microsoft to show the HDMI Extender working with the MS Drivers.....


I noticed with the MS Basic display adapter the hz is one (1.000)

When you have the AMD driver install at 800x600 does  it show the same Hz amount of 1.000hz?

No way of connecting another Monitor to your PC just to make sure that is shows the correct Resolution with the AMD Driver installed?

With both the extender and without it.

Adept II

When it's 800x600 refresh rate is showing at 75 Hz. 

Isn't that unusual for that low resolution having a frequency of 75Hz?

Can you change the Hz in Windows Settings to a lower one like 60hz to see if that fixes the problem?

For some reason it seems like MS Basic Display Adapter is seeing the Extender as being connected but the AMD Driver is not seeing it since it has since it has a higher frequency.

What does Device Manager- Monitor show when the AMD driver is connected?

The same as the MS Basic Display adapter?

Adept II

Device Manager says for display either Microsoft Standard VGA or AMD Radeon Graphics. Either way for a monitor it says FHDExtender. There’s something that’s not keen between the extender and the AMD Drivers so I’ve pulled it for now and ordered another one, which at least supports EDID, rather than appearing as it’s own device. That way it should at least see the monitor at the other end. If not I can recable etc. it’s just annoying that the laptops and everything are happy with it but the £2000 server for all the media isn’t! 



I really don't know what to say since I am not familiar with Cat6 Extender hardware.

I find it strange that it also works with everything else except AMD GPU or it driver.

Maybe you should open a AMD SUPPORT Ticket before you spend so much money on a different solution from here:

Also I didn't realize this was connected to a Server. Try posting your thread at AMD SERVER GURU which deals with everything to do with Servers. Maybe someone there can help better from here:


Apologies, it’s connected to a media server, which is basically a fairly high powered gaming system running media server software. 
I need a solution quickly now as the venue is kicking off about it still not working correctly so I’ve just had to throw money at it and hope for now. Appreciate all your help though and I’ll definitely report back with findings

Please do. Thanks for the update.