Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

R9 380 Black Screens, Windows 10 1709

GPU: Sapphire Nitro 4GB
AMD Driver: Adrenaline 18.3.4
CPU: i7-3770
MOBO: DZ75ML-45K Bios: 0017(Latest)
Windows 10 64bit 1709-16299.371

Black Screens at the drop of a hat since Spectre/Meltdown was rolled out for the CPU at end of March. Can be doing anything, from browsing to gaming, and sometimes simply reaching the login screen.
This machine did not ever have the R9 380 Black Screen issue from before (Circa 2016 drivers) and worked fine with 1709 until end of March when Spectre/Meltdown rolled out for my specific CPU.

-Windows Specific: It does not crash like this in Linux (R9 driver for Ubuntu 16.04 LTS, not the official AMD RadeonPro drivers for Linux), and can browse the specific web sites and/or play games in steam that black screen in Windows 10.
-The R9 iteself is Fine: The 39 380 can run through a GPU memory test, and as mentioned is fine in Linux.
-Borrowed an R7 265 to test the system, and that works without black screen. Though you can tell there is something off with the power management in Windows 10, as the card constantly throttles fan/voltage while gaming / browsing when it shouldn't. eg: The fan will be going full blast after a few minutes of gaming (because the GPU is working) and then there will be a 1/2 second pause of the fan and drop in frames whenever there is a transition in the game. (eg: a dialog window opens, such as a diplomatic screen in Beyond Earth) and then the fan goes full blast again.
-Monitored the Voltages of the power supply (sensors only, not directly). All good, the black screen was not triggered because one of the voltages was above or below the failsafe thresholds.
-Monitored heat, card is nowhere near max temp when it black screens.

What doesn't work.
Reinstall / Reset of Windows 10

Clean driver install (uninstall using DDU safe mode)
Motherboard Bios Reset (both resetting defaults, and reflashing the current Bios), so it is not bad settings, failing CMOS or corrupted BIOS]
Wattman +20 Power in Radeon drivers
Disable ASPM (Bios Disable ASPM or Windows Power Settings-> Link State Power Management Off)
MSI Afterburner + Radeon Drivers only +100% Fan and +20 Power
Disable fast start in Power Options

Windows 10 WHQL R9 380 Drivers dated 2017-09-22

Enable Integrated GPU in BIOS and Install Latest Intel 4000 Drivers in hopes of better system behavior.
Disable all power saving features in BIOS

Any other suggestions would be appreciated.

edit: Clarity for "What doesn't work"

Message was edited by: Orion Styles

12 Replies

Third party controllers like AB conflict with AMD/Wattman settings. Delete it entirely from your computer, then clean install the driver of your choice.


I didn't originally do a clean install using DDU to remove the auto-detected drivers after the Windows 10 reset so I went back and did that. It did not make a difference though.

Does Afterburner / Wattman not get along even if you do not enable Wattman?

Regardless, I did a drivers only install with Afterburner, still no luck.


If I remember correctly...the R9 300 series has a different set of options than other cards....maybe goodplay​ could offer some advice.


With wattman  'not enabled', msi-ab(4.4.0) is good on my 390 (4.4.2 can't hold/crashes my oc).

locodicegr​ may have some input on a 380.

I'm not aware of a March spectre cpu update for Ivy. Do you have InSpectre (No.8).

Probably not recommended, but I have spectre/meltdown disabled.


Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..

IvyBridge Spectre/Meltdown was put in production for Windows Update on March 13th and 23rd? My issues began around that time. (of course it could be completely unreleated as I don't have the technical ability to solve). The DZ75 motherboard, however, is on the "will not receive spectre/meltdown bios update" list from Intel.

I did try to follow some other advice on disabling found here​​​ underneath the "Switch / Registry Settings", but I don't really understand enough of what is happening there to know if I did it right or not. Still got a black screen, so re-enabled.

I'll look into the reliability report etc... but I need to take a break from this for a bit before I get back on that.

Thanks for the post.


"Disable PEG (Bios Disable PEG or Windows Power Settings Disable PEG, or both at the same time)" are you indicating that BIOS changed the settings automatically from using the dGPU as the preferred Graphics card to using the iGPU instead?

Never realized that Intel made motherboards in the past.

Intel Support says these cards are compatible with your motherboard: Support for Intel® Desktop Board DZ75ML-45K . This information is probably quite outdated.

Graphics cards
ATIATI HD7950 PCIe 3.0 GraphicHD7950
GigabyteAMD Radeon HD 6570 DP (1GB) PCIe* x16 Card (Dorado) - ECOHD 6570 DP
MSIMSI N560-M2D1GD5 GeForce GTX560 GDDR5N560-M2D1GD5

According to this website the R9-380 is the same as a HD-7950 with a boost. Radeon R7 360, R7 370, & R9 380 - AMD Launches Retail Radeon 300 Series: A Prelude To Fury


They made good ones DX58SO is still cranking


" are you indicating that BIOS changed the settings automatically from using the dGPU as the preferred Graphics card to using the iGPU instead?"

Sorry, that is just me being frazzled. Edited for clarity.

For ASPM, the Intel bios can do Enabled, Disabled, or PEG Only.


Run intel as disabled. Any form of link states from bios power savings to OS power saving disable all go up a set of newer drivers from a mate who had the exact same card said. All he did was load up intergrated card, he just clean installed the 17.12.1 drivers from the integrated card . If device manager on the Integrated picks up the card load your drivers from that bump the power settings just enabling everything & clean out anything that will cause havoc no 3rd party programs & a registry clean. In bios settings just disable  integrated intel crap Enable pcie only should post.


Thanks for the suggestion. The Intel GPU was originally disabled and all power states were already at maxium.

I enabled and Installed the Intel 4000 drivers just incase there were more power management drivers in them.

There was no change.

Eventually there was a black screen again.

Adept I

A fresh install of the new Windows 1803, with a clean install of 18.4.1 seems to have resolved this problem.

Activities that would normally cause a black screen have not occurred in 24 hours.

For certain the memory clocking and phase changes seem more sane.

The rapid fluctuating of memory and core clocks every few seconds that were seen previously are gone, and phase changes occur slower. Now it's more like proper smooth shifting of an experienced driver in a manual car, and not the gear grinding you see in new people just learning stick.

Journeyman III