Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

R5 GPU Unrecognized After Driver Update

So, I've had this prebuilt machine for about 6 weeks.

Dell gaming. A10 processor, 4GB Radeon R5 with RX 560. SSD drive on C and TB of HDD on D.

I have problems with sound drivers being hosed by each Windows 10 update, and tbh at this point I don't know if it is AMD or Windows to blame for the GPU driver issues at this point. 

Blizzard decided to force the update of the driver with the disaster of their Wow prepatch. I had the 18.1.1 driver from Jan. The game didn't like that and would give a blank screen but I could hear sound. The advice at the moment was that the driver needed to updated on the GPU. Okay, no sweat.

At first I did it in the Device Manager. It updated to 18.5.1 from May, but threw a Microsoft error 43 once updated, the message being that there was a known problem and that the machine disabled the device.

I rolled back the driver to 18.1.1. GPU worked for all else, but still blank screen during new game cinematic that wouldn't leave after the video.

So, I downloaded the optional 18.7.1 installer manually, figuring, "why not?"

Well, same,,, Windows 43 error. Of course, using the AMD installer means that I no longer was about to roll back.

Complete uninstall, tried manual download of May 18.5.1, thinking maybe the device manager might have hosed something. Same outcome. Blocked my GPU and driver software.

So, in an act of desperation, did a clean download and install of 18.1.1.

NOW even device manager doesn't see the R5. Only the Microsoft Basic Display adapter and the RX 560.

FFS. Any ideas?

0 Replies