Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III


Hello i hope you can help me here....


I try to activate SAM (R-BAR) on my Pc but its not working.

The BIOS is telling me that its activated but the device manager and GPU-Z telling me its not activated.

I deactivated CSM on the Bios like i supposed to do and activate the R-BAR settings and its not working... Why??


I have a RX 6900XT (GPU) and a 5950X (CPU).


Would be really nice if you have some tipps


8 Replies

Did you also enable encoding above 4g when you enabled sam?



Download GPU-Z and go to the advanced tab, select PCIe Resizable BAR from the dropdown menu and look there what is the problem. It should look like this, if something is set to No there is your problem.

Hey i looked at the GPU Z software like you said and it said that R-Bar and Above 4G is deactivated. 


But when i go to the Bios, the bios said its activated. What can i do? Sorry for my english. I will attach some pictures to show my problem.


GPU Z.jpg

Bios 1.jpg

Bios 2.jpg

  Like you see the GPU Z software says its off but the bios says its on. I hope you can help me with that

Kind regards,



Sorry, I have no idea what is wrong.

In the Radeon drivers under performance- tuning can you enable SAM ?

Also you should check that you are running the latest chipset drivers for your motherboard from AMD website, the latest BIOS version from gigabyte and the latest windows version.




In the AMD Radeon Software is SAM not Available i will check the Bios and so on.




Does this not appear for you ?
Screenshot 2021-08-13 174618.png

First you should install the latest chipset drivers for your motherboad and the latest radeon drivers (21.8.1) from here:


Select chipsets...am4...and x570/b550 for your specific motherboard
for radeon select graphics....6000 series and your specific GPU.
If none of this works you should update BIOS from gigabyte if you don't have the latest version.


Check you have following:-

BIOS> Settings> IO Ports> Above 4G Decoding>  "Enabled"

BIOS> Settings> IO Ports> Resize Bar Support>  "Auto"        [Before BIOS 33f: 'Enabled', After 'Auto']

BIOS> Settings> Miscellaneous> PCIe Slot Config> "Gen 4"

BIOS> Boot> CSM Support>  "Disabled"

I have a Gigabyte Aorus Elite MoBo, 5950X and RX6800XT ... so a similar setup.


Did you ever get this solved? I am now having the same issue after running SAM for months. 

CPU - 5600X

GPU - 6900xt

Mobo - X570 Gigabyte Aorus Elite


All of the sudden SAM is now greyed out in the Radeon control panel. Have double checked the bios to ensure that 4G/BAR supports/CSM Disabled are all taken care of.  Have checked GPUZ and it shows that the 4G and BAR support are not enabled. 


Steps taken to correct

1. DDU and reinstalled latest GPU drivers

2. Uninstalled/reinstalled Chipset drivers

3. Did a "load optimized defaults" in bios and re-did the settings within


None have worked thus far




I have now fixed the issue. I just reflashed the same exact bios I was currently running, I can now enable SAM in the control panel.