cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

sircaco
Journeyman III

"Pixel Format settings may not retain after system restart"?

"Pixel Format settings may not retain after system restart" used to be listed under "Known Issues" up until Adrenalin 2019 19.2.1. It is no longer there in 19.2.2, but it's also not under "Fixed Issues". So has this been fixed or is it just kinda being swept under the rug? Cause I have an office computer here with a Ryzen 3 2200G connected to a VGA monitor (I know VGA support has been dead for a while, but this is what I had, and the motherboard does feature VGA. We'll get into that though). It works in Adrenalin 18.5.1, though the system thinks it's really DisplayPort, and so the pixel format defaults to YCbCR 4:4:4, which doesn't work for me because then the screen is all pink. That's fixed when I change it back to RGB 4:4:4. Now, if that setting was actually retained after restarting the computer, all would be fine and I wouldn't be here typing this right now. But it doesn't retain it, and release notes no longer mention the issue. Now, last time I actually let Radeon Settings update itself to the latest version, I didn't get any signal anymore on my monitor. So you can see why I'd be reluctant to update to any newer version without knowing whether it'll work. The main thing here is I'm not trying to shell out the money for a new monitor, obviously. This stuff ain't cheap and I shouldn't have to spend money on hardware to circumvent something that should be fixed through software. All I'm saying is that compatible motherboards feature VGA, so the drivers should be there for it. Doesn't make sense otherwise, I mean if you're gonna terminate all support, then terminate all production. I imagine that if this somehow isn't ignored, someone will say "well get in contact with the motherboard vendor about it". See the thing is, AMD should've done that. AMD knows who's making motherboards that support their APUs, so they should've contacted Gigabyte, ASUS, ASRock and whoever else and they should've told them "Listen, our APUs are not gonna work properly with VGA, so don't bother implementing it in your Ryzen motherboards", but as you can see, they didn't do that, and if I go to the mobo vendors talking about this, they'll be like "That's an AMD problem", if they answer at all, and I'm not trying to get ping-ponged around here. I just want to know if I'm stuck with this hassle or if there's anything that can be done. Thank you.

0 Likes
3 Replies
jdrobinson314
Challenger

Good grief.

I understand.

It's a rare thing that this might fix your issue, but check you monitor picture setting and set it to a  custom mode or rec709 or similar. Some monitors can accidentally "request" a color space via their edid signal.

As for the VGA stuff, you might be able to fix that with a dp to VGA or hdmi to VGA adapter, see if your issue is revolving arou d that VGA port emulation going on on the motherboard.

0 Likes

Thanks for replying Robinson. I've tried an HDMI to VGA adapter, but unfortunately the screen kept going black for a bit every 2 seconds. So unfortunately, that doesn't work. I did also attempt DVI-D, because that's the only other output the monitor supported (I forgot to mention that), but that also didn't work. Just no signal at all. And then finally I tried a DVI-D to VGA adapter, which did pretty much what the HDMI to VGA adapter did, except instead of a black screen, it was something like TV static. Which was quite strange. I'll see about the monitor picture settings you mentioned first thing tomorrow. Thanks again.

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro..