Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

Question About AMD Smartshift


I have an Asus Rog Strix G713QY-K4005T, and I'm experiencing reboots during gaming, under 5 minutes after I launch a game the laptop's display goes black and it reboots. This only happens when it's plugged in, when it's running on battery the gaming sessions go smooth and without issues for as long as the battery lasts. The only way I can play a game without issues while plugged in is by going to Device Manager and disabling the RX6800M to force the laptop to use only the integrated GPU.

Through AMD Software Software Adrenalin Edition's overlay readings, I noticed that when gaming on battery Smartshift Max percentage usually varies between 70% and 100%, and the CPU/GPU bar has a red part towards the GPU side as soon as the game starts. When the laptop is plugged in Smartshift Max percentage is always 0% and the CPU/GPU bar is always gray not showing any red parts during the couple of minutes the game runs until the laptop reboots, it's like Smartshift is not working/disabled when the laptop is plugged in.

So is this working as intended? Or could this be the cause for the game crashes when the laptop is plugged in?

16 Replies

Do you have the latest BIOS version install on your Asus Laptop from here:

Also try installing Asus own AMD Graphics and CHIPSET drivers and see if that helps if upgrading your BIOS didn't work:

Found this Tech Review on AMD Smartshift:

It mentions if you have a new version called AMD SMARTSHIFT "ECO" and does this when plugged in:

AMD SmartShift Eco is another new offshoot designed to make your battery run longer while gaming. SmartShift Eco can automatically move the majority of the performance load to the Ryzen CPU's integrated graphics when on battery power, intelligently moving it back to the discrete GPU when the laptop is running on AC power. AMD expects this to significantly boost battery life while gaming, though with the expected fidelity loss when moving from discrete to integrated graphics.

There are 3 different types of AMD SmartShift according to the article.

NOTE: I saw that you opened a thread at ROG ASUS Forum but no one answered as of yet.

EDIT: Not really familiar with this new laptop feature but reading about it and you mentioning that your laptop doesn't crash with SmartShift enabled while on battery but crashes while plugged in and SmartShift seems to be disabled seems to indicate a power issue with your laptop which when SmartShift is enabled it able to control but when disabled it is not able to properly control the power to your laptop using the GPU card installed.

Could it possibly be a bad laptop power supply cord?

I downloaded your Laptop manual and it doesn't mention anything about SmartShift feature. Possibly you have the latest version which is the SmartShift ECO since it is disabled when plugged in.

Thank you for your reply.

I have the latest BIOS,  version 318, I also tried the ASUS drivers, both the chipset and the graphics one, and didn't work. I also installed a VBIOS Hotfix available on that page you provided that also didn't fix the issue.

I saw that article as well and my Smartshift is Smartshift MAX, at least that's what shows up on the AMD Software Adrenalin metrics, Smartshift ECO isn't out yet from what I gathered from other internet articles.

Yes unfortunately no one answered as of yet on ROG forums, I also opened a thread at AMD Help Reddit with no answers as well so far.

Yes, it looks like a power management failure when plugged in. I bought the laptop in November and in February it had to go to RMA, it didn't recover from sleep mode and died, where they replaced the mainboard. Before the RMA the laptop was stable and didn't have this issue, this only happened when it came back from RMA. Could be something faulty on the mainboard preventing Smartshift from working when plugged in?


I would RMA the laptop again. Let them know the reasons why.  Unfortunately, when a Manufacturer repairs a hardware it comes back with more issue than before unless they replaced the entire hardware with a new one.

Sounds like a hardware issue again.


Well, the thing is they say they replaced the entire mainboard as well as the display so it's almost a new laptop. They also say they ran stress tests on it and it ran without issues. Another problem is that since this laptop was never released in my country the technical knowledge in repairs centers here about specific features like Smartshift is practically non-existant. They won't be running any gaming sessions to reproduce the issue and they will only run stress tests again and return it has is if no issues appear running those stress tests. Unless this could actually be software-related and someone knows any fix for it I think I'm pretty much stuck with a half-functional gaming laptop.


can't you take the laptop to the repair center or vendor and physically show them what is happening.

If they see the laptop crashing while plugged in but not on battery they should be able to find out what is going on again.


I sent videos of both Smartshift working on battery and not working plugged in and the laptop rebooting a couple of minutes after launching a game. They say they don't have any idea how Smartshift works at all because it's something new that they never handled before. They do find it unlikely to be hardware since it works on battery and in case of being hardware related it wouldn't work on battery or plugged in. They're leaned to believe it could be software-related but have no idea whatsoever of what it might be other than some problem with AMD Software Adrenalin Editon or the AMD Chipset drivers. But I've tested with clean installs of both the ASUS chipset and graphics drivers and I even tried with the last stable WHQL AMD driver from January that I had before sending the laptop for RMA with no success. I gather that this requires more specialized knowledge about how Advantage Edition laptops' hardware and software work.


Then I suggest you open a Asus Support ticket and see if you can RMA the laptop to Asus directly rather than the Vendor.

Maybe they can suggest some Troubleshooting tips to find out how to fix your laptop.

If you want you can also open a AMD Support ticket and ask them if they feel it is hardware or software related from here:



I'm gonna try both ASUS and AMD. Thank you very much for your help. If I'll get it fixed or get any idea what it might be I'll let you know.

Yes please update this thread if you find out what fixed your problem.  Thanks.


According to AMD Support, I have only one thing left to try and help figure out if it's a software or hardware problem. Clean Windows install and wipe the OS drive, install all the windows updates, then install the latest AMD chipset and graphic drivers, and install the games without any additional software installed, if the reboots continue then it's a hardware problem for sure because there's no reason for any software conflicts. I will only try this next weekend and let you know how it went.

So that problem ended up becoming a dead laptop that didn't turn on at all. I sent it to RMA, they replaced the motherboard again and I'm going to test it and see if the issue has disappeared.


delete and disable all powerschemes in registry and in powershell and only use the amd provided ryzen balanced.

in bios even for laptops many pciexpress low power or lower bandwidth modes set to auto will default to the weakest mobile phone quality or laptop ones so it doesnt drain battery or blow up your phone as they all have the same pci express standard just the phones use like 1/2 the bit depth and fraction the bandwidth and bus speed and far far cheaper nastier lower quality $10 stuff instead of say $50 stuff? u get me? 

disable the ryzen master and ryzen master SDK many criminal **bleep**s hack in and set its boost clocks base clocks in hidden scripting so it looks normal and shows normal readings but youre gaming on like 200mhz instead of 2200mhz then when you plug in power it goes to switch to higher boost or base clocks and they've locked them in at turds and then the script detects tampering with their tampering so it crashes your PC so you never discover it.


The laptop reached a point where it didn't even turn on. I sent it to RMA and they replaced the mainboard again. I got it back this week and I'm gonna test it in gaming to see if the reboot issue is gone.


So i've tested it and so far it went through over 3 hours of continuous gaming without any issues.

I'm suspecting the cause of all my problems is a 4Tb M2 SSD I have, that ended up freezing the boot on my laptop. As soon as I removed it the laptop booted again normally without problems. I was having issues with permissions to access it and it ended up with the SSD disappearing from the File Explorer, Disk Management and BIOS.

Either the motherboard doesn't support SSD over 1or 2Tb or the SSD itself is already faulty and dying. The SSD is 7 months old by the way.


With laptops you can't just buy any type of hardware and expect it to fit or be compatible.

You need to find out from the Laptop Support exactly what hardware will fit and be compatible with the Laptop Motherboard.


The SSD is an ADATA Spectrix S40G with RGB lights and according to many users, it has lots of issues because it quickly runs hotter than it should due to the RGB lights and apparently a poor thermal design. The SSD had occasional, about one out of five times, quick 1 second or so freezes when opening a folder or file right from the start, but still worked for the first 3 months. After that first RMA, it worked until the day before the laptop died again, and after this second RMA, it only worked on the first day ending up not being recognized in either the File Explorer, BIOS, or Disk Management.