cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

roxor
Adept I

Purple-ish desktop screen after clean-installing the newest 19.5.2 drivers

Hello there. It has happened to me around 3 times now and sometimes it doesn´t even happen, maybe its not a big deal but I just want to make sure. I tried searching for information in regards to this but I was unable to find anything.

I have installed with a clean installation (using DDU in windows safe mode) the latest AMD GPU drivers (switching back and forth from 19.4.3, 19.5.1 and 19.5.2) and sometimes I get the desktop completely "painted" in blue right after the installation has been performed, the screen blinks as the installation is being done, as usual, the screens turns to a blue-ish tone (see attached images), switches back to a normal mode, then back to blue-ish and stays like that UNTIL I RESTART THE PC, then color comes back to normal.

Has that happened to anyone? Could that be considered normal or definitely something is up? It has never happened to me prior to 19.5.1 and it occurs regardless if I choose express or customized installation options. I don´t see any major issues in performance or problems while launching games, but that happening to me definitely made me a bit concern.

Thanks in advance for any insight provided.

144 Replies

Roxor, I had the same issue with these drivers (pink screen specially via HDMi) but now I install only via Windows Update from Windows 10 and the new drivers are perfect !

0 Likes
alleyviper
Elite

I get the same with a DVI monitor (plugged to either DVI or HDMI on the graphics card) and latest drivers under 1903, at least since 19.4.1 on a RX480. Either purple/blue, red/black or green/yellow screen.

If you do anything to restart your monitor, like re-plugging or changing resolution it should go back to normal before a reboot.

You'll also see crazy colors just for an instant over the welcome screen right at log in.

Same Problem here

0 Likes

I see the same color flicker at login as well. Sometimes after waking from sleep the screen will be tinted white, only after going to the desktop, it's fine on initial sign in screen.  It can be fixed be power cycling monitor, clicking on display settings or resetting driver with Shift+CTRL+Win+B

0 Likes
edmondvonersung
Adept III

I had the exact same problem with the new drivers.

teslap100
Adept I

Just wan't to say that I experience this purple/pink screen as well. First time I saw it was reinstalling 19.5.2 drivers for my Radeon VII and after that when waking up my screen. However for me it's usually fixed by turning both monitors on and off again.

Well that's one more problem we'll have live with i guess.

0 Likes

Awesome, issue also in a RAdeon VII ! Amd like very much Purple/pink color !!! Try install driver via Windows Update from Windows 10 (for me the issue disappeared)

this issue is ooold : https://community.amd.com/thread/238454 

0 Likes

If you see it again you can also try just right clicking the desktop and going into display settings, or key combination Shift+Ctrl+Win+B which will reset the driver. 

0 Likes
joecrow
Elite

Same here (yellow/green) on Win 10 (1903) and RX 570 after DDU clean install. OK after reboot but 2nd problem of no audio, looks like 19.5.2 failed to detect my Denon AVR on the HDMI, hard failure no AMD audio driver installed. Went back to previous version all OK and did an AMD clean install of 19.5.2, no desktop colour or audio problem this time and so far all looking good.

0 Likes
nhar4702
Journeyman III

I had same problem here. When i was installing 19.5.2 on my rx570, my screen swiched to pink or green. And when i enter the login screen, it flashes pink or green. I came back with older driver, it didn't happen again.

 

crkmanho
Adept I

Same issue here, seemingly not random at all.

0 Likes
kingfish
Volunteer Moderator

Report issues to AMD Online Service Request | AMD 

0 Likes
tingo
Adept II

My first guess with everyone's post here was, our motherboards and CPU are getting to old.
Because I was having issues with 18.xxx drivers I turned off, Intel VT - Virtualization Technology, in my Bios.
Turning this back on fixed the green/pink screen, and blue screen I was getting on restarts of my PC,
it also fixed all of the WMI and a host of other errors in my Event Viewer.
If your Bios/CPU does not support  VT of some sorts, then you may need to upgrade.
I found that after driver 18.10.2, I started having problems.
I'm having No issues with 19.6.1 after turning VT back on in my Bios.
I'm no expert so if anyone has found a fix besides this let us know, Thanks.

Turning VT back on fixed it for me thanks

0 Likes
ghostx
Adept I

I have the same problem, also comes white screen when waking up from sleep.

I think the problem is related to the 1903 version of windows

Same exact issue, you can try combination Shift+Ctrl+Win+B and this will reset the driver and clear white screen, or just right click the desktop and go into display settings. 

0 Likes
joecrow
Elite

With respect to those who commented that turning VT on fixed the problem I would like to point out that VT is an Intel thing and as far as I am aware neither AMD CPUs or Mobos supporting AMD CPUs have this option. Mine certainly does not.

jefff73
Adept II

I had the previous version of drivers installed and I backed up my system to upgrade to windows 10 1903 then I seen this issue (Pink an Purple Screen) prior to updating AMD Drivers to 19.5.2. I then seen it the first time I logged back in with 19.5.2 installed. I then got scared that Windows 10 1903 update broke my cpu or gpu so my last step I then did a fresh install after using DDU to Uninstall then updated to 19.6.1 (New Optional) and the problem went away. I am running on a 6 month old Ryzen system. So this tells me that it has nothing to do with older systems.

0 Likes
joecrow
Elite

As per others here no problems with 19.6.1! I reckon it was some peculiarity with 19.5.2, hey AMD rarely provide full details of the fixes in the new release notes, so no surprise.

0 Likes

Don't speak too soon, I did a fresh install of 1903 and 19.6.1 drivers yesterday and still have this issue. It didn't happen for the first day but came back today.

The only real fix is rolling back to 1809. Not viable though when the new xbox game pass requires 1903.

Have you reported this to AMD yet? : Online Service Request | AMD 

0 Likes

I can confirm about it not being fixed with 19.6.1. After the clean install is done my screen stays purple/green, it goes back to normal after a restart, and i havent noticed it happening in normal use. Some times at startup a couple seconds after the log in screen appears my screen flashes purple/green for a frame or two.  And i also agree with derkiederk that this is most likely a 1903 problem, i had no problem installing 19.5.2 when i was using 1809. I got an RX580

Running 19.6.1 on W10 1903 and i get rand green/pale screens and the way I get rid of it is to log off and log back in. Haven't had to reboot the system to fix it thus far.

0 Likes
jefff73
Adept II

As my previous posted comment I can confirm that the problem has not totally went away. It still flashes Purple/green screen every so often using 19.6.1 on a Ryzen system with Rx580

0 Likes
jefff73
Adept II

BTW I am not using wattman. I am only using the drivers for default configuration along side MSI Afterburner. I will be doing more testing and changing settings to see if I can pin point a setting that maybe causing it and Etc.

0 Likes
qwixt
Forerunner

I have seen Red and another time Purple-ish. I always immediately restart then it's back to normal. I don't consider it an issue since it only happens immediately after installing and a restart corrects it.

jefff73
Adept II

Not sure if this may help some of you but so far I have uninstalled using DDU in safe mode restarted, Reinstalled 19.6.1, Noticed each object on my screen was it's own color this time around. Without logging in I restarted from the login screen. It didn't show any odd colors this time so I logged in. AMD Radeon Drivers detected my monitor could use "Virtual Super Resolution" so I turned that option on under "Display". Restarted and shut down many times as well as played a few games to see if that would bring it back for hours now and have not seen the odd colors again. (Radeon Settings set to Default other than turning on "Virtual Super Resolution".

jefff73
Adept II

Also forgot another option I changed directly from my monitor settings. If you have a monitor connected to HDMI cable try to see if you can turn "HDMI Compatibility Mode" I changed that to On due to the faded colors and it restored colors back to the way I like them.

0 Likes
jefff73
Adept II

Well I have done some more testing with both Driver versions 19.5.2 and 19.6.1 The results seem the same and I have found to work the best but aren't perfect. I hope help someone.

Steps below that seem to minimize this issue

#1 In safe mode uninstall AMD Drivers using DDU and let it restart in normal mode

#2 Log into windows and Create a System Restore Point and run CCleaner Registry cleaner. Fix Selected Issues (I did this more than 3 times to make sure I had gotten all Fixed to make sure all remnant of AMD Drivers were uninstalled/removed from the system)

#3 Install your chosen version of AMD Drivers (Restart when required)

#4 When logged in go into AMD Radeon Settings to Preferences and Restore Factory Defaults (I have noticed some settings changed even after a fresh install)

#5 Go to Display settings and then go to Color Change Color Temperature to Automatic

(Strange enough even removing the AMD Radeon Icon from the tray reproduces the issue)

0 Likes

beware of "color temperature" setting as with some gpu/monitor/system config you'll get limited range colors even though full rgb is set. a fix for this is to set it to 6500k.

0 Likes
fujiyama-95
Challenger

RX 590 "Fatboy", Same exact issue as you!

0 Likes
jefff73
Adept II

The last option I tried that worked was to uninstall AMD Drivers with DDU and then let Microsoft install their version of AMD Drivers that completely eliminated this issue and I was still able to play my games.

0 Likes

How do you get Microsoft to install their version? 

I've used Control Panel to uninstall AMD Software

Used DDU to uninstall the driver

Ran CCleaner three times and rebooted

I cannot get Windows to install their AMD driver at all.

0 Likes

Microsoft should automatically detect the drivers in need on your system just after you log into your desktop. It should automatically install any missing drivers. If it doesn't then you can go to Start Menu and there will be a Gear looking Icon. Click that brings you to System Settings Window pops up. At the bottom of System Settings is Update & Security click that then click on Check for Updates will check for updates and should automatically install any drivers needed

0 Likes
lefteris
Adept II

i have the same problem with driver 19.6.1 purple screen/and radeon settings not opened

0 Likes
codexllll
Adept II

Hi, for what it's worth I'm also getting this (or at least I think it's the same issue) with 19.6.1 except for me it is red, not purple. I wanted to post this because for me, CTRL-ALT-Shift-B fixes the issue without rebooting, try it out maybe it avoids a reboot.

CTRL-ALT-Shift-B is a windows keyboard shortcut that resets the graphics driver stack. It's useful sometimes.

0 Likes
gabriel02v
Adept I

I also confirm that the purple screen is present on RX 460 on Windows 10 1903 and windows 7 SP1 with 19.5.2 and 19.6.1 drivers.  I got all the colors: purple, blue, yellow and redish tinted screen on DVI and HDMI connections.

On windows 10, the only way to make it revert to normal is to install the drivers from windows update, which have the version 17.1.1, basically more than 2 years old, which it is not okay...

I tested also on Ubuntu 18.04 LTS and were no purple tinted screen problems.

Make sure you are all reporting this to AMD, the more complaints they get the more they realize it is a widespread problem and look into their drivers. Report it here: Support Ticket Process | AMD