Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Problems with Radeon 530 drivers and Boot loop

Hi, I have some problems with the video card, but I can't figure out what exactly is wrong.
I have an IdeaPad s145-15ast laptop.
CPU: AMD A6 9225
GPU1: radeon R4
GPU2: Radeon 530

I recently reinstalled Windows and it did not install the drivers for the video card automatically.
Then I ran into this problem: The driver from AMD's official website installs Radeon 440m, but the driver from Lenovo's website installs Radeon 530.
(lenovo website: )
I decided to stop at the driver from the Lenovo website, since it at least coincides with the characteristics of the laptop.

I tried using a Blender and it also worked incorrectly.
Blender didn't work with Radeon 440m drivers at all.
With drivers for Radeon 530, the Discrete graphics card worked worse than radeon R4!
Default scene renderer in Cycles:
CPU: 2:06 (radeon R4)
GPU: 6:59 (Radeon 530)

But I could still put up with this and continued to use my laptop normally until yesterday evening.
I was playing with a friend in Deep rock galactic, he was the host, went to the menu and I was disconnected from the lobby. At that moment, my laptop completely froze.
I turned it off by holding down the power button. And during the turn-on, he fell into a Boot loop. the logo of Lenovo appears, it loads for a while, then a black screen and all over again.
I tried to restore Windows, but it didn't help. So I decided to reinstall it. After reinstalling, Windows could not find the video card driver. I decided to install them manually from the Lenovo website.
During their installation, my laptop restarts and after restarting the drivers are not installed. The same is true with drivers from AMD's website.
I want to clarify that the laptop is rebooting, it seems, at the wrong time: when AMD is about 20% setup, and Lenovo at the end of "extracting files ..."
And I also want to clarify that I have such a confusion with Radeon 530/Radeon 440m drivers since I bought the laptop.

My questions:
What could be wrong with my video card?
Which drivers are better to use and how to install them?

2 Replies

Since no one has answered your post I decided to answer.

First, generally when you install a AMD Laptop Mobile Basic video driver the GPU card in the laptop won't be the exact GPU model you have installed. Instead if will either show the Series or Family type model.. So if it is showing your GPU card was being a 440m that is common. But the Mobile driver will still be compatible and should work except maybe some Lenovo specific features may not.

Second, when you install your Laptop's OEM AMD Video driver it will show the correct model of GPU card you have installed in your laptop since it is 100% compatible and made for that laptop.

So I would install Lenovo's AMD driver first and make sure everything works normal before updating it from AMD website.

When you download the AMD Basic Mobile video driver you must download your AMD APU Processor's Integrated Driver which will also automatically install the GPU card driver at the same time:

NOTE: AMD doesn't have a A6-9225 APU video driver but the closest one I found was a A6-9220 which might or might not work until your try it.

When you reinstalled Windows you may have deleted some of Lenovo's OEM apps that might make the laptop run normally.

Also Windows must be fully updated via Windows Update plus I would also update the Laptop's BIOS to the latest and it AMD CHIPSET to the latest.

You can alway run GPU-Z and see what Make & Model GPU card you have installed. Also when after installing the AMD driver go to Device Manager - Display Adapter and see what Hardware ID is showing for your GPU card.

EDIT: Your A6-9225 is not supported with AMD driver updates anymore since 06/2021.  The problems with Blender could be due to out dated video drivers. Just guessing.

Thank you for responding! Thank you for explaining which driver is better to install.

But the problem here is not whether my Windows is updated. Before this, I had already reinstalled the system several times and everything worked. The problem arose after I forcibly turned off the laptop while it was frozen. I made a new discussion where I described the Bootloop problem in more detail. ( Link: )
Please, let's continue the discussion in it