cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

dominik523
Journeyman III

Problems with my drivers

Hey everyone! I need your help please. So this is my story.

I had few weeks ago AMD HD 4650 graphics card and recently I've got Sapphire HD 6850.

I haven't uninstalled my old drivers and I installed new. Device manager was showing "Standard VGA Graphics Adapter". I uninstalled everything and installed AMD Catalyst Suite which was for automatic detection of drivers. After the installation, I was still getting that Standard VGA Adapter. I went to Update Driver button and I specified the folder where I installed AMD Catalyst and my graphics card was recognized. Everything was alright for 2-3 weeks.

Yesterday my screen started to get black, with stripes on it and many other things. Most of the people wrote it's a case of a bad driver. I went to the safe mode and uninstalled my driver. I also ran Driver Sweeper which removed all the remains. I went to full version of my windows 7 64-bit. I downloaded Catalyst Suite from Sapphire's website and I'm still getting Standard VGA Adapter under Device Manager. Can someone please tell me what to do?

Thank you very much in advance.

-Kindly regards, Dominik

This is one of the thing that happens:

YouTube

0 Likes
3 Replies
Hardwood
Paragon

Re: Problems with my drivers

Your vid is private.

0 Likes
dominik523
Journeyman III

Re: Problems with my drivers

Sorry about that. It should be on public settings now:

VIDEO0033 - YouTube

0 Likes
dominik523
Journeyman III

Re: Problems with my drivers

I managed to deal with this issue. I've used program called Drive The Life to update my drivers to the latest version and now everything works good.

0 Likes