cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

killroy2963
Adept I
Adept I

Presets and Soundblaster

Hello I just switched to a AMD 6900 XT after years of Nvidia, and I have a couple questions about these optional drivers, specifically version 21.2.2 and the set before. 

 

1. The global presets do not stay enabled like rage, quiet and balanced do not stick, whichever one it always goes back to manual.

2. Installing the latest 21.2.2 drivers using factory reset hosed my Soundblaster AE5 driver. To get it to work again I had to uninstall it from device manager and then reinstall it, this just isn't cool.    

So as of right now those are my main concerns, if anyone has some advice please share. Thanks!

0 Kudos
5 Replies
elstaci
Esteemed Contributor III

Re: Presets and Soundblaster

The AMD Driver shouldn't affect the separate Sound-blaster driver.

Do you have any audio devices connected to your GPU Card? Like a Monitor or TV Set etc.?

Mostly likely what happened was when you installed the AMD Driver package it set whatever Audio is connected to your GPU card as "Default" thus disabling any audio devices connected to your Sound-blaster PCIe card.

Next time it happens open up Windows Sound Control Panel and see if your Default Audio device was changed from Sound-Blaster connected Audio device to GPU Card connected Audio device.

killroy2963
Adept I
Adept I

Re: Presets and Soundblaster

Thanks for responding, I have a monitor that is connected to the GPU that has built in sound, which I never use. I believe my soundblaster was disabled as you have said, and my monitors sound made to be the default. I'll keep a eye on this next time I update the drivers.

 

Do you have any suggestions regarding the presets not sticking??

elstaci
Esteemed Contributor III

Re: Presets and Soundblaster

Not familiar with that specific issue. 

Someone else will need to help you with that.

killroy2963
Adept I
Adept I

Re: Presets and Soundblaster

I found out the problem I was having, I was running fan curve in MSI Afterburner and that was causing the Radeon preset not to stick. Once I disabled fan curve the presets worked just fine.

elstaci
Esteemed Contributor III

Re: Presets and Soundblaster

Thanks for the update.

In the past, the The knowledgeable Users here at AMD Forums have always suggested to uninstall 3rd party software like MSI Afterburner since they tend to interfere with AMD Driver and it related software functions. Especially AMD Wattman for GPUs.

But as MSI and other similar software got updated they seem to cause less issues with AMD driver than in the past and it isn't mentioned as much.

Good troubleshooting.

0 Kudos