cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

sandbo
Adept II

Possible bug with AMD GPU Pro Driver installation on ubuntu 18.04 LTS with Secure Boot ON

Hi,

My system has the following spec:

CPU: Threadripper 1950x

MB: Asrock X399 Taichi (fireware 2.0)

GPU: R9 Fury

OS: ubuntu 18.04 LTS

The issue was that if I turned on secure boot, the installation would fail at a point where it tried to generate the private key. I already *reinstalled* ubuntu 4 times in a day due to broken boot (flicker screen and so) after installing the driver and failing. Sorry that I haven't kept the message/screenshot, so the below is a description of the problem and solution for now.

After much search, it turns out I was stuck at a prompt for the generation of private key during the AMD GPU Pro driver installation, when secure boot is on.

The problem is, throughout the installation process, at some point in the terminal it should pop up a prompt asking for a password for the generation of the private key.

However, it fails to show up so the system keeps waiting for user's input that user can never give.

(This seemingly also affect Nvidia's driver installation (some users managed to solve it by blindly typing in a password)

Update: found it, this is exactly the bug I am seeing where it got stuck: (https://devtalk.nvidia.com/default/topic/1036167/stuck-trying-to-intall-nvidia-390-ubuntu-18-04-lt...

  1. Generating a new Secure Boot signing key:
  2. Generating a 2048 bit RSA private key
  3. ................................................................................................................................+++
  4. ..+++
  5. writing new private key to '/var/lib/shim-signed/mok/MOK.priv'
  6. -----

Forcing close this process and rebooting it often ends up with breaking the boot.

To solve this, I simply disabled secure boot in BIOS and everything works just well and I am now a happy user of OpenCL (again).

However, it would still be good if this can be solved without turning off secure boot.

Tags (2)
0 Likes
4 Replies
elstaci
MVP

Re: Possible bug with AMD GPU Pro Driver installation on ubuntu 18.04 RTS with Secure Boot ON

You may want to post this question at AMD Opencl Forum here : Devgurus .

They may be able to give you an answer about Secure boot and linux.

0 Likes
sandbo
Adept II

Re: Possible bug with AMD GPU Pro Driver installation on ubuntu 18.04 RTS with Secure Boot ON

Thanks for the suggestion, it was originally posted in the NewComers section as I was only able to do it there.

It seems it has since been moved to the Drivers & Software section.

Would it be appropriate if I just repost in the Devgurus? Or I should contact a mod to move the thread again?

0 Likes
elstaci
MVP

Re: Possible bug with AMD GPU Pro Driver installation on ubuntu 18.04 RTS with Secure Boot ON

Good question, I guess since it was moved to this section, it would be best to let the AMD Moderators decide if it is a driver or Opencl issue.

This is the latest Ubuntu 18.30 for the R9 Fury from AMD Support: Radeon™ Software for Linux® 18.20 Release Notes . If your linux driver is older try updating and see if the latest Linux driver the issue is resolved.

Otherwise open a AMD EMAIL SUPPORT TICKET and let them know what is happening and see what they suggest here : Email Form

0 Likes
sandbo
Adept II

Re: Possible bug with AMD GPU Pro Driver installation on ubuntu 18.04 LTS with Secure Boot ON

Thanks for the form, I will give it a shot.

I did it two days ago, as the page was last updated on June 15 I think I was using the latest installation package (18.20).

0 Likes