Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Poor performance with Vega in No man's sky and A Hat in time. Specific issue that effects only these two games.

Hi all,

As title states, in both these games I (and a lot of other people) are experiencing terrible performance but this seems to be tied to some weird issue effecting only Vega cards. At certain points in game play, the cards power draw drops significantly from say between 160-200 watts (I have an undervolt on mine) to between 50-80 watts and getting massive stuttering and low gpu usage, along with low fps.

This is even on the lowest possible settings in game, with V Sync off etc

This is with a wide range of processors from both AMD and Intel, so this does look to be a Vega issue. I have tried many other games uncapped and benchmark suites to ensure that this doesn't happen and it doesn't. I can peg the gpu at 99% usage all the time with the correct power draw and no issues whatsoever.

Anyone else have these issues or suggest what to try? The evidence looks to point towards Vega being the culprit though.

My Specs :

Ryzen 1700X

Vega 56 flashed to 64    

16GB ram at 3066 mhrz

X370 Taichi

Corsair AX 860i PSU

11 Replies
Journeyman III

Has anyone found the issue? This still seems to be a problem. I just helped my friend upgrade from a RX480 to Vega 64. It ran fine on the 480, but now suffers lots of stuttering.

Journeyman III

I have just bought an RX Vega 56 OC 1520MHz(1622MHz out the box, which I promptly clocked down. Currently trying 1475MHz.) It gives approximately 60% more FPS in No Man's Sky, than my R9290 OC 1030MHz. Unfortunately, compared to Vega, my R9290 is buttery smooth. In a new area in NMS when turning 360 degrees, Vega almost literally chokes itself to death. The screen freezes for 100s of milliseconds in certain spots. I am assuming it is trying to load new textures. The only problem is that when it is most needed, the core clock drops to the low 100s MHz range, matching the stuttering. GPU utilization falls as low as 0% in some cases. That is not what you do when there is work to be done (Pro tip to driver team). I have made sure that the card is running below 70 degrees by upping the fan speed so that overheating can not be blamed when it should be spiking in GPU usage. I have tried every trick I can find on the Internet. Nothing works. It appears to be a Vega issue, which also implies an AMD only issue.

I specifically bought this card so that I can enjoy No Man's Sky more, but instead have been left with regret. Worst of all, this is not even listed as a known issue in the release notes.


i7-6700K OC 4.5GHz (ASROCK Z170 OC)

32 GB Ram 3200Mhz

1.5 TB Disk via (M.2 Evo 950 Pro 500GB) x 3 in Raid 0 (System and Game Drive)


Windows 10 x64 release 1803


I know it is not something you want to hear, but I would log some reports of the power usage with OCCT and see what is going on under load. It sounds like that Vega may not be getting enough juice. Those things are power hungry and I am not sure the minimum requirements they put on them are enough. I see people all the time with normally really good PS brands make the same complaints and they go to a 1000 watt or better PS and it is better. I am only passing along what I have collectively read on Vega experiences. I don't have one myself.


Since my OP, I've upgraded my friend's PC from a Corsair CS550M (550 watt) to a EVGA G3 (850 watt) and that appeared to reduce stuttering by quite a bit, but didn't solve it entirely. It also helped a lot when I downclocked the GPU and Memory and turned up the fan profiles. For anyone else having this problem, here's a summary:

1. Remove all overclocks.

2. Always keep GPU and Memory voltages lower than stock. I'd recommend finding the lowest stable voltage, then adding 50 or 100 mv.

3. Keep temps below 75C. Around 70C is ideal.

The end settings on my friend's Reference Sapphire Vega 64 are in this range:

GPU Clocks: ~1300 Mhz P6, ~1400 Mhz P7

Memory Clocks: ~950 Mhz

GPU and Memory Voltage: 1000 mV

Fan Profile: Up to 3000 RPM, max temps 75C

My friend's card max overclock is:

GPU Clocks: ~1450 Mhz P6, ~1550 Mhz P7

Memory Clocks: ~1150 Mhz

GPU and Memory Voltage: 1050 mV

Fan Profile: Up to 4400 RPM, max temps 85C

So keep in mind the end settings that work for NMS are approximately a ~150 Mhz downclock from max OC on the GPU, ~200 Mhz downclock from max OC on the Memory, and 50 mV lower than max OC. I provide these numbers so you can get an idea of how your silicon should fare whether it's better or worse.

This probably made 80-90% of the stuttering go away on medium settings, 1440p. Definitely far from a great experience, but it at least matches or exceeds a RX480 and is tolerable.

Really wish that AMD would address this issue in-software rather than send NMS players on a witch hunt for the best settings! To be fair though, a lot of it has to do with NMS as other games run completely fine.


Yah, this information doesn't want to make me go to a Vega, I was really considering it to get to the higher side of my free sync range. I am on a RX 580 and even it took a good bit of tinkering to get it stable but once there everything is buttery smooth and I wouldn't consider these issues worth the trade. I think I will be waiting for the real next generation of cards before changing again.


I have upgraded my PSU from 850W to EVGA 1200W. It does not make any difference to the stuttering. That being said, I experienced an anomaly with the Vega 56. During one test run it worked flawlessly. No stutter. I then shut down No Man's Sky and reloaded the saved game. The stutter was back. This is feeling like a driver issue to me.



Notice the long white screen after loading with Vega. Thereafter the stutter happens as I pan around slowly. Panning fast gives you even less control. You end up looking at some random place in the sky since you could not make micro adjustments to the scrolling as the screen is not updating. Going for a walk leads to further stuttering of maybe 500 ms when entering new areas. The R9290 is smooth as butter throughout. Just with lower average frame rate. This is not workable.

I would re-flash that card with the proper bios. See if that doesn't fix things. If not, I don't doubt it being a driver issue. I don't have one of these cards but I do see this complaint on these cards a lot. All I can offer is that you need to keep filling support tickets for every driver release that still doesn't fix the issue. These are expensive cards, but even a cheap new card should work as advertised. Thanks for sharing the videos.

Journeyman III

Hey guys. Thanks for the reply. It seems isolated to these two games and I believe I know why. A hat in time uses UE3 which runs only on two threads so it love IPC, which while the 1700x is not bad at all at, it still a bit behind comparable intel one's. Having said that, I managed to play the game mostly locked at 60FPS right through. I did overclcok my 1700x to 3.9 GHZ which seems to have helped a bit ( I use a Noctua DH-15 so still have great temps).

No man's sky is similar in which it uses Nvidia OpenGL solutions and hello games have ignored supporting AMD in this, which they have even openly lied to me and said they were working with AMD to improve this. Whilst AMD doesn't particularly fair well in opengl, it shouldn't be this bad with some competent developers, not to the point with massive frametime spikes and a stuttering. Other than these two titles, Vega has been excellent for me. The Undervolt I've managed keeps it going at 1600 mhz with 1100 on the hbm and load of no more than 200-210 watts.

TLDR - Shitty UE3 for a hat in time. Nvidia solutions for No Man's Sky.

Thanks for the feedback and explaining exactly what you figured out. The end results fixes or realizations it wont get better, really help others asking the same questions. You should mark your answer as correct if you are satisfied this thread has help you the OP as much as it can.


I have this problem as well.  2700x/vega 64.  The game ran better with the rx580 the vega replaced.  I have low gpu usage when the frame rate tanks.  Has made NMS unplayable.  

Journeyman III

Hi guys, check that : Vulkan Update - No Man's Sky