Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

Please Help! Dobly Atmos, Windows 11, 7900XTX, LG S75QR soundbar

THE SOLUTION IS TO USE OPTICAL CABLE INSTEAD OF HDMI ARC!!!! Today I switched over and now IT IS PERFECT. Netflix works perfect, games work perfect and pandora/youtube all work perfect now. All speakers play . Dolby Atmos for Home Theater is selected on Sound Format and Spatial audio. Disable enhancements is unchecked, all enhancements are unchecked, Allow aplications to control this device is UNCHECKED so I can play videos and games at same time. Otherwise it would only play one source at a time.  Works PERFECT NOW. So excited, I HIGHLY recommend the TCL Q7 tv when it is on sale for 500 and HIGHLY recommend the LG S75QR   Dolby atmos 5.1.2 Soundbar! This is best picture and sound quality I have ever seen and I didn't even know existed! Atmos is so immersive. It's freaky. GG got to go play Avatar:Frontiers of pandora! The forest is incredibly relaxing and sounds great with Atmos support. 

Original post : I have read and tested for hours. 
I have a 7900xtx video card going to a TCL Q7 Dolby atmos tv HDMI , then HDMI arc going to LG s75qr soundbar. 
Everything right off the bat works PERFECT. All sound is incredible 5.1. All channels play correctly and sounds great. 



The issues arise when trying to set the correct settings to have Dolby Atmos enabled. I go into Dolby Access. Click setup , continue, and then "experience Atmos". It then changes the Sound format from 48khz 24 bit  to Dolby Access for home theater, and Changes the Spacial audio from off to Dolby Access for home theater.   
Then I can play some of the clips at the home screen of Dolby Access. Works great. But then netflix doesn't sound as good, and I lose rear speakers when playing music with Pandora and youtube. IT kills surround sound speakers for non atmos content. 

So Am I supposed to set the sound format to 48khz 24 bit and leave spacial audio off?   Am I supposed to wait for new drivers from AMD who knows about the Dolby atmos issues and has posted on this forum in september about it under another post?

Am I supposed to enable Dolby Atmos in Dolby access or setting sound format and spatial audio to Dolby Atmos for home theater in both areas? Is the amd driver causing the rear speakers not to play? 

If I just set it to 48hkz 24 bit sound format and spatial audio off, All speakers work good and sound great but seems I am not getting Dolby audio/Atmos, but instead it says "PCM" when I check the playing stream through ... button on the LG remote. 

Also, If I click configure speakers, It only shows Stereo or Dolby atmos or DTS:X. No 5.1 surround option.



Also, if I set it to 48khz and 24 bit , then go to dolby access, play a sound clip it shows I don't have it enabled, BUT, As soon as I play the video, the soundbar lights up and shows "Dolby Atmos".   



I don't know how to get Dolby Atmos support on netflix on pc, but I can just use the TCL Q7 TV remote, go to netflix and do that instead. Setting it to 48h/24bit and going to netflix app still shows dolby atmos though. It seems dolby atmos works and enables for access atmos content videos, It seems netflix can see I have atmos, but I have spacial audio set to off and 48htz/24 bit selected instead of selecting atmos for home theater for both. 


So am I doing it right. Leave sound format to 48htz/24 bit , spatial audio to off, and just let it sometimes turn on? Is this an issue with the AMD driver and sound driver the 7900xtx uses? In the future will an update come out that I can turn on Dolby Atmos in sound format and spatial audio settings and the rear speakers will work correctly, and the possibility of 5.1 surround be enabled instead of just Stereo,atmos,dtx:x? Please help me 



Also , when set to 48h/24bit I don't get accurate playback through each channel. This test file found on Does not play correctly unless atmos is selected in sound format and spatial sound, atmos enabled through access. But then I lose rear speakers again. 
4 Replies
Adept II

IMPORTANT UPDATE:  You must have Disable enhancement off or it will kill your rear speakers even with atmos content played by dobly access app.  DO NOT do the windows speaker configurator. It messes it up, If you did, go back in, Select stereo, unclick full range speakers and click done or go to enhancements tab and click DISABLE! 

I have atmos working, in everything except rear speakers during pandora or youtube. It works great on all atmos content, games, etc. I just need it to doe the correct channel /multichanne  support . Both options are on in Dobly atmos Channel upscale and LG phone app Multistream enabled. But doesn't work. 



do NOT do configure speakers or it just causes more problems. 




Adept II


this is turned on on my phone 
and channel upmixer is turned on.  

Could it be 7900xtx and amd driver is just not sending it? 



Adept II

anyone know anything? AMD can you help with information? Is this being worked on still. 


I don't think AMD will be fixing atmos any time soon