Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Please can someone help, even if its just a guess at what's going on.

When I install a driver for my 5500 xt windows refuses to boot, giving the error message BAD_SYSTEM_CONFIG_INFO. If I boot using safe mode and remove the driver windows boots fine again...The day before yesterday I replaced my secondary drive seemingly successfully, used the computer for several hours and restarted it several times in that period. I am aware that a Windows 10 update coincides with this issue emerging but other than that I have no idea what's going on or how to fix it... So far I have tried rolling back to before the update, using an older driver, reinstalling everything from bios up, formatting the boot drive and resetting uefi settings to default. Physically everything is seated correctly, powered and showing no signs of overheating. I've also used the AMD cleanup tool or DDU for removals between attempts, nothing has made any difference - if theres a driver on there for the gpu the shutdown failure is identical post install. This is destroying me, please help lol  (no really, its a lifeline I desperately need right now).

My system specs are:
Asrock B450 itx/ac
Ryzen 3600
16gb 3200mhz RAM
Corsair Force MP510 480gb (M.2 nvme Boot)
Kingston A400 960gb
550w PSU

Thank you massively in advance for even trying to help if you choose to, have a better day than I am.

9 Replies


Thank you, but this unfortunately didn't work.


Try a in-place upgrade?

Thank you for the suggestions!
Do you think this is likely to give a different result to repairing, resetting, restoring or reinstalling the OS?


An in-place upgrade is basically reinstalling windows over windows (you won't lose any programs or settings or data). It should correct this issue. I did an in-place upgrade when my catalog became corrupt. It fixed the issue right away. Sorry you're having issues. good luck to you!


You are not alone in this issue. I have seen several threads similar to your results and seen a lot of blame at everything but AMD. With so many having this same problem on different b450 boards and r5 3600, something is surely going on. Have you contacted AMD support? 

If you have another gpu around use it for the moment. Then just let it run the standard windows driver. And if it boots do the following. 

Makes sure you have the latest bios update for your board. Contact you motherboard support department and see if they have a bios that is beta newer than what is listed as AMD just introduced a micro code update last week that is just now trickling down into firmware. 

Make sure you are using the latest chipset driver.

Make sure you have the latest Windows updates installed as well.

I would disable fast startup as it often caches old driver data that can conflict. 

If at this point you still have an issue try booting with one stick of ram at a time and make sure you don't have bad memory. Also make sure you are using the right timings for that ram. If you are unsure contact the manufacturer. 

If everything is fine then run ddu from safe mode again and re-install your GPU and load the latest driver. 

I would try all this before reloading my OS.

Thank you, that is very helpful, I'll work my way through the points I've not tried and get back to you.


No joy, issue still the same now up to making an Ubuntu usb in the hope that a linux installaton will somehow reset whatever windows is persistently dropping the ball on.

A long shot I know, but I'm out of ideas again sadly. This is crushing.


I am so sorry for your issue. I hope you find a resolution.