cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

bobotu
Journeyman III

Pixel Format for DP Alt mode 2 lanes configuration

I have a ThinkPad USB-C dock (USB 3.1 Gen2), which use 2 lanes for DP Alt mode. My laptop is ThinkPad T495 with Ryzen 3500U. When I connect to an external monitor through this dock, I can only select 6bit RGB 4:4:4 or 8bit YCbCr 4:2:2. I also tried this with my MacBook Pro 2018 with 560X GPU, the supported pixel format and color encoding are the same.


The Radeon Software shows the link speed is 8.1Gbps x 2. As mentioned in VESA's documentation, DP 1.4a Alt mode can support 4k@60fps FULL 4:4:4 color encoding WITHOUT DSC in 2 lanes configuration. So I connect this dock to my RTX2080's USB-C port and connect my monitor through the dock, the result is 8bit FULL RGB 4:4:4.


So is this a hardware limitation on 560X and 3500U or just a driver limitation that can be addressed in a later release?

0 Likes
1 Reply
joevt
Adept I

Re: Pixel Format for DP Alt mode 2 lanes configuration

Is the timing using something like CVT-RB (533.25 MHz) or HDMI (594 MHz)? Look at G.Pixel Clock (kHz) in the Radeon Software. HDMI timing exceeds the theoretical max of 540 MHz allowed by 2 lanes of HBR3 without DSC for 8bpc RGB. If a display has both timings, Radeon Software or Windows might not expose both options. Or maybe one of them could be wrong.

My EDID has a 533.25 MHz detailed timing and some HDMI items (Use CRU to see the EDID). Radeon Software doesn't have a refresh rate option so I have to go to Desktop -> Display Settings -> Advanced display settings -> Display adapter properties for Display 1 -> List All Modes. It shows two options: 59Hz and 60Hz. The 59Hz option shows as 593.4 MHz in Radeon Software. The 60Hz option shows as 594 MHz (as expected for HDMI). I don't know where the 593.4 MHz number comes from or why the 533.25 MHz option does not seem to be present.

Does the dock have an internal MST Hub? When I connect my display to an MST Hub, the 59Hz and 60Hz options appear as I stated above and items I add using CRU are not shown. If I directly connect my display to the GPU, then options that I added using CRU are shown. I can delete the HDMI items in CRU to remove the bogus 594 MHz and 593.4 MHz items. I'm not sure how to get CRU to work with a display connected to an MST Hub.

0 Likes