Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

Overclocking not working on Radeon VII via Wattman


Just installed Catalyst 19.12.1 on my system with Radeon VII.

Since version 19.6.x users on forums were reporting that overclocking via Radeon Settings do not work for Radeon VII and its necessary to use 3rd party tools.

I tested that yesterday and can confirm the issue. Regardless Wattman settings every tool reported stock frequencies during either 

Last version where everything works as expected is Radeon 19.5.2.

16 Replies

radeon vii + 19.11.3 here , no oc problems : running at 2183 mhz + 1200 vram ... the only thing you can't do is to get beyond 20% powerlimit unless you use morepowervii ... but oc works for a long time

will test 19.12.1 , but i don't see any reason it would be different


Can I ask you for a screenshot where GPU-Z or Wattman reports GPU actually hit that frequency during 3d render?


here you are , and i just updated to 19.12.1 :

oc@2184 hitting 2121mhz and memory @ 1200 ... in the last "star wars"


Ok lets compare the systems more in detail.
Threadripper 1900x, AsRock Taichi X399M, Gskill XFlare 3200Mhz, Seasonic Prime Titanium 850W.
Windows 10, latest patches...

Did us used DDU, or Clean install?
Also did OC worked for you without problem in previous versions?


nothing unusual here , all up to date too, 3900X + radeon VII + x570-f gaming + 32Go gskill 3600mhz , 1000W psu... and before I had a 4930k+p9x79+16Go ddr3 gskill with the same radeon VII and had no problem with overclock either

I always use clean install , I use DDU sometimes when I test other graphics card in my system ,

maybe one time an oc didn't work with one version , but as I installed next version it was fixed, don't remember what version it was , but it was just one time (effect was that when i tried to oc , card was downclocking to 1500mhz as I remember, but like I said next drivers installed : back to normal)...

just explain what you do to oc , and what you think don't work with your oc

Adept II

Raise FAN to 100% and OC will work again (was my issue)

I had partial success when using Radeon Overlay.  When i changed the frequency, i got artifacts and/or game crash.

To me it appears that specific game profile was not used, and global profile was used instead and/or settings were taken "at random" either from global profile, specifc profile or from overlay settings.


what is the frequency you tried to oc to , what are your parameters ... disable overlay and every other option that is not useful to test oc, and start oc from scratch , little by little or you won't have the real stable values ...

and you have to test in games with vsync of (vsync on : limits fps to 60 so card isn't used at 100% , so oc test not reliable)


that's not a cause of a oc problem, that could eventually be a reason of a bad oc hability , but I don't think it's the problem

or maybe overclocking isn't done properly , there are some rules ... just check tutorials for that maybe


My card runs at 2150Mhz @ 1,218V just fine. After locking fan speed to default, the card did not clock higher than stock again. After setting it to 100%, the clock goes all the way up.

Journeyman III

I cant OC my RVII after driver version 19.7.5 ... The AMD support for a card we spent 700$ is damn terrible.  Never again will I buy an AMD GPU.  Fix this damn OCing issue please!

maybe you guys should start from scratch , disable all options , no hdr , no freesync and i don't know what you could have activated... you are clearly doing or using something that prevents your oc, ... but from here I really don't see any difficulties ... maybe you should find some tutorial , amd driver have nothing to do with your problems , as i told , i never had problems with oc , so i don't see any reason you would ... just explain a little bit more what you done and what you see on screen and what makes you think it's not working... if you want to be helped


Its quite simple. You set 2000Mhz in Wattman, either in global profile or specific profile.

Then you run 3D application you are testing it with (lets say Witcher 3 on 4k), and measured frequency does not get above 1750, or 1800MHz. Same applies for memory OC, power management and other settings.

It appears that guys who are affected with the bug all have Watercooled Radeon VIIs and therefore they have no reason to change fan RPM, while there was recommended to set fan to MAX to resolve it. I have to test it myself.

Previously i already encountered bugs with fanspeed on Radeon VII. It either ran on 100% all the time, or was running when PC was powered down (flashing MB bios to latest solved that).

This also might be specific to different GPU bioses. I have original one from Sapphire. AsRock for example offered an update with UEFI. Plus OFC there are modded ones.

Also... my Radeon VII seems to be not that good, (even when i did not tried proper OC yet), as i have stable OC up to 1950MHz.


mmh mine is watercooled, no problem like that ... but you say it yourself : bios related , so not a driver issue ...and that seem more of a possible thing regarding your problem

on air mine goes up to 2030 like a lot of radeon VII seen on forums

on watercooling : 2182

Adept II

 Yesterday i did a proper clean reinstallation of 19.5.2 and set a bunch of profiles. Everything appeared to work fine.

Today i started first game in list Deus Ex: Human Revolution and enabled Enhanced sync in Radeon Overlay. Then i clicked "back" and opened the Enhanced sync tab again to verify it shows "on". Then i opened Radeon settings, and i saw that Vertical Sync was showing "Enhanced sync".

Then i started Mortal Kombat 9: Komplete edition. Enabled Enhanced sync as in previous case... But it never showed in Radeon Settings. Vertical Sync was still "On, Unless application specifies". Because both Radeon Overlay and Radeon Settings works essentially with Windows registers, i rebooted the system, checked the Radeon Settings and this showed up:

Most profiles (except for Nier: Automata, Witcher 2 and Witcher 3) cloned themselves. So again i set each profile Vertical sync to "on, unless application specifies" and repeated the experiment. As a result i identified which profile is really active - and in every case it was the new one.  Witcher 2 profile cloned bit later - when i tried the experiment with Radeon Overlay, while Radeon Settings was opened in the background.

New profiles (which always work) always took the name from the executable they are associated with. Nier profile already had its name same as the executable, and Witcher 3 profile was created manually.

So if this or similar bug is present in newer versions of the AMD Radeon Settings, it would explain why overclock is not applied - there might be a profile which is essentialy a dud - while the real profile is either not visible in Radeon Settings or not existing yet.

amdmatt‌ Does this ring any bell? I may test it for 19.12.1 as well, but i at least have answer why the OC may not get applied.

Not applicable


Seems we have an issue with the Radeon VII, the core MHz fluctuates from 800mhz to 2020mhz its all over the place, it results in weird phantom stuttering on 3D applications.

Its the exact same issue with the AMD Fury X back in 2015, I had to flash a custom BIOS to fix the issue but I cannot find any custom BIOS for the Radeon VII.

I already have +99% Powerlimit and the core still tanks to even 500mhz in 4K, 1440p which ever resolution.

I have flashed the Radeon VII with the 1.06 BIOS update, no luck in fixing the powerplay issue.

Temps are 75c with 100% fan for testing, I would like to see some solid FPS before I go ahead and watercool.

Right now my old Fury X does a better job.

AMD chill is disabled also, could it be the drivers are bugged and the chill parameters are actually active?

I'm not sure but please help.