cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

alainbrest29200
Adept II

openCL linux debian bullseye / sid

hello to all.

i'm on debian bullseye testing / sid

I'm looking to install openCL since amdgpu-pro 20.45.

I know debian works with ubuntu (which I also have) but I much prefer debian.

Do you have any leads, ideas ? solutions ?

(amd rx 6800 under sid)

friendly.

Alain.

ps: even if it's negative, you can answer me.

45 Replies

AMD, we still waiting for official Debian support!!!

2.5 months later, any news AMD????????

0 Likes

AMD has launched the ROCm (openCL) project.
ARCH has successfully developed it.
Fedora and Debian are currently working on it.
The porting and development of the ROCm project is currently in progress.
let's support developers and geeks .
friendly,
respectfully ,
alain .

 

 

Running into the exact same issue on PopOS 21.10 with an RX580.

I see people with more recent cards having better support like here

It would nice from AMD to confirm whether they are going to end support on the polaris cards as it seems that it might be the signal being sent here.

From my experience, I can get the 21.40.1 installer working only if I have done the installation of the drivers using the 21.20 non-apt-based installer (old method compared to that new one). 

I cannot find the version of the amdgpu driver I have on my system as 'modinfo amdgpu | grep -i version' does not report anything other than srcversion: and vermagic:

If I try to use the installer on an Ubuntu derivative system with no previously installed amdgpu driver, the new installer fails due to missing packages that only previously installer seems to have installed with proper dependencies.

After a bit more investigation for my use case in connection with Blender, I found the following documentation for ROCm installation instructions pointing at a more recent amdgpu-install version from the 6th of December 2021.

https://rocmdocs.amd.com/en/latest/Installation_Guide/Installation_new.html#ubuntu-20-04

I installed both and the installation completed however I have yet to get OpenCL working in Blender.

Following discussions on this Blender devtalk thread for updates:

https://devtalk.blender.org/t/cycles-amd-hip-device-feedback/21400/54

0 Likes

there is still no functional solution for debian .

even the sources.deb in 20.04.2 does not bring any serious answer.

AMD would brocard Debian ?

the persistence to make drivers only for 3 or 4 linux distributions and not for deb and rpm package managers, much more generic and standard, borders on software aggression and bad faith.

Why do you want to **bleep** open source in the bud?

I repeat: AMD doesn't provide any support for Debian, even though it's the mother distribution from which ubuntu comes.
This is discouraging.

AMD would like to force us to use Windows instead of Linux, but it would not do it otherwise.

friendly,
respectfully.

 

Translated with www.DeepL.com/Translator (free version)

0 Likes

Alain,

Indeed, AMD support for debian is trash, but your script to install opencl worked for me.  Thank You!! Happy New Year!

0 Likes