Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

OpenCl is not working Ubuntu 18 or 20

  • AMD Graphics Card eight RX 580
  • Crypto RIG
  • Operating System Ubuntu 18 and Ubuntu 20
  • Driver latest driver available for each system
  • Display Devices LG 22MP58VQ
  • Motherboard Asus B250 mining expert
  • CPU/APU Celeron
  • Power Supply Unit  Coursair AX1400 AX 1500

------------ after update the driver, it seems that the OpenCl is not available. as example, claymore miner does not detect the GPUs and my bash file could not access to overclock the GPUs using the mask 0xfffffff in GRUB

--- what I did

 format the SSD and I did a fresh installation of all again, Ubuntu, amdgpu driver and claymore. I use ./amdgpu -y --pro --opencl=pal,legacy . 

I tried under ubuntu 18 and 20, but same negative results. during the driver installation, just after the part of creating the MOK, it said "forcing installation"


*If I use Clinfo, the terminal said that it is not installed. but if I opened the terminal into the current directory where is Clinfo. i can use it.

*the secure boot is enable. but I also tried under unable state, same negative results.

*I read that the issue is about render group. This group is not  on my list of my groups. on the other hand, "video" is listed on the list of groups

*In GRUB, I set amdgpu.dc=0 as the screen begin to flickering after the amdgpu driver is installed.

*my display manager is gmd3 using wayland. as wayland let me use all eight GPUs

I wonder if you could please help to fix the installation of the amdgpu opencl driver and use it with claymore.


thanks in advance for your help

0 Replies