cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

shady1824
Journeyman III
Journeyman III

Only 1 of 6 Rx 570's not showing up in device manager?

Looking for some help here.

Currently running windows 10.  Have  5 of my 6 amd rx 570's up and running with no issue.

The 6th, well, it doesn't want to show up. I've tried multiple ways and more recently removing all other cards to try and just focus on this issue

The card lights up and shows power upon windows loading. No fans spin. When windows is loaded it doesn't appear in device manager.  When i removed the other cards, I put this in a spot that has all working connections.

What do we think the fix could be here as all the other same cards are working and recognized by windows without issue.

Edit: Running on Asus Prime z270-a.  and am attempting to get this card to show when no other cards are plugged in.

Asus prime z270-a

Asus prime z270-a

Tags (1)
0 Kudos
4 Replies
elstaci
Esteemed Contributor III

Re: Only 1 of 6 Rx 570's not showing up in device manager?

When the computer boots up with just that one card installed does it beep more than once?  Do you have integrated Graphics on your Motherboard?

Sounds like a defective card since all the rest are recognized and not that one in particular. If you install it in another computer and the exact same thing happens that pretty well shows that the card is probably defective.

Generally the GPU fan (s) starts up while loading Windows and then shuts down. If the GPU Fan never turns on, it is possible your GPU got damaged from Overheating when the fan stopped working while in use. Just taking a guess not making a fact. Most modern GPU cards, the fans won't turn on until it reaches a certain temperature. on my Asus GPU card the fans are stopped until it reaches 60 degree centigrade, then it turns on automatically. I believe the Rx 5xx have something similar.

0 Kudos
shady1824
Journeyman III
Journeyman III

Re: Only 1 of 6 Rx 570's not showing up in device manager?

I believe there is no beeping and it boots up as normal.  Sadly, I don't have another computer to test it out on.  I'm still holding out hope and found a few random posts online to troubleshoot.  Was holding out hope for a possible solution here though

0 Kudos
shady1824
Journeyman III
Journeyman III

Re: Only 1 of 6 Rx 570's not showing up in device manager?

In regards of the fans not turning on, I'm assuming it would still appear in device manager prior to this?

My option might be to take it to a repair place to see if they can install it on another CPU

0 Kudos
elstaci
Esteemed Contributor III

Re: Only 1 of 6 Rx 570's not showing up in device manager?

If the GPU fans never turn on, then you probably have a damaged or defective GPU card. If it overheated and damaged the GPU chip or some other vital component in the GPU card than it won't show up in Device Manager.

If you turned off your computer and restarted it, Your GPU fan should start working until Windows loads or at least start up and then shut down. If it never starts, then you have something wrong with the GPU card and needs to be RMA if under warranty.

0 Kudos