Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Oculus Quest Software not working, says graphics card not compatible (RX 580)



After trying lots of things with Oculus Support to get Oculus Link working on the Quest 2, rolling back the drivers to 20.10.1 worked for a short while. 

Yesterday, I got an error message from the AMD software saying something about OpenGL2.0 and my display flickered, and the PC was not detected by the headset. I reinstalled the latest drivers and the PC is still working as normal but the Oculus software says Graphics Card not Compatible (when it is) and won't let me connect to Link.


I've read that this could be down to AMD not supporting Quest 2 on all it's supported chipsets, and was wondering if anyone could help me fix this problem.

Thanks in advance.

7 Replies
Journeyman III

This same exact thing happened to me, I played one of the games that are already installed on there, and it worked just fine (even though I have a gtx 1050 mobile) and then I tried something else and an error about directx11 popped up and now I'm stuck on a screen that says "Graphics Card Not Compatible," even though I literally played a game 5 minutes earlier. Does anybody have a solution?

Journeyman III

Still going through support with Oculus, no luck yet. Anyone?


Not sure if it is related to your specific issue but in the latest AMD Driver Release Notes under "Known Issues" it does mention about Oculus Link problem:

Oculus Link users may experience intermittent crashes on Polaris and Vega series graphics products.

So it seems to be something with both AMD Driver and Oculus Link software not being fully compatible.

Try installing a previous AMD driver and see if it starts working again just as a test. If it does then it is a problem with AMD Driver or until Oculus  comes up with a patch to make work with AMD Drivers.


Oculus says that AMD's last 3 drivers will not work and that AMD does know about it!

According to Brett(Oculus guy I've talked to), AMD has known about this prior to release 3 drivers ago...about August'ish I think...AMD has been very difficult to work with and refuse to correct their code! Sounds like some inner drama is affecting us costumers. I would get on the horn and contact AMD, tell your friends as well, cuase if that's true, this is bull! But tbh AMD has had driver errors for years, although they've said it's obviously isn't! As their drivers used to work fine last March, and before then! It says on the box of our AMD cards that it's VR Ready, and Oculus is pictured so that's false advertisement!

If interested, here is AMD Previous Drivers (from 03/2020 to current) if you want to install a previous working AMD driver again:

If you need a earlier AMD driver than 03/2020 than you can go to and download all AMD drivers from several years ago up to the current AMD Driver.

Journeyman III

I've been troubleshooting the issue of Oculus Link software not installing and compiled a list of effective solutions:

  • Clean Reinstall of Oculus Software:
    • Uninstall Oculus software, delete all Oculus-related folders, restart PC, and reinstall.
  • Check Setup Logs for Errors:
    • Access the Oculus setup log file to identify specific errors or issues during installation.
  • Unplug Headset During Installation:
    • Disconnect the headset from the PC before running the Oculus setup.
  • Disable Firewall and Antivirus Temporarily:
    • These programs can sometimes interfere with Oculus software installation.
  • Run Oculus Setup as Administrator:
    • Right-click the setup file and select "Run as administrator" for proper privileges.
  • Use a Local Admin User Account for Setup:
    • Domain user accounts might lack necessary privileges for installation.
  • Install on a Different Partition:
    • Try installing the software on a different drive if space or conflicts are an issue.
  • Disable VPN:
    • Temporarily turn off any active VPN connections and retry installation.
  • Update Windows and GPU Drivers:
    • Ensure all system and graphics drivers are up to date.
  • Unplug Unnecessary USB Devices:
  • Disconnect non-essential USB devices during the installation process.
  • Contact Oculus Support:
  • If all else fails, provide detailed information and logs to Oculus Support for further assistance.

These steps should help in resolving the installation issues with the Oculus Link software. Feel free to check out my post for more details on any of these solutions!

Numerous reports have surfaced regarding compatibility issues between AMD graphics units and Oculus Link. While a portion of these difficulties can be attributed to Oculus not updating their graphics card compatibility list to include recent AMD models, a significant aspect of the problem also lies with AMD. The company's marketing promises have not been consistently met, raising concerns about their ability to deliver as advertised. It's crucial for AMD to address these ongoing issues promptly. Failure to do so not only undermines consumer trust but also potentially exposes the company to legal risks, including a class action lawsuit for false advertising and neglecting a known issue.