Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

New Ryzen 3700x - Games now crashing?

Hi all first time posting here hopefully in the right section,

So I've recently upgraded my CPU to a Ryzen 3700x from an i5 6600k

(Note: RAM and GPU worked perfectly fine in the Intel system)

and have followed the common procedures of doing a fresh install of windows and updated the bios, i even recently tried to make my ram timings better as i feel the RAM may be where the issue lies. As i tried playing borderlands 2 and threw me an error regarding not enough memory and i doubt its VRAM when i have a 1080ti.

My current system now is:

CPU: Ryzen 7 3700x - stock speeds and volts

Cooler - Included Wraith prism

Motherboard: Asrock x570 Taichi

RAM - Corsair Vengeance LPX 16gb (2x8gb - CMK16GX4M2B3200C16)

GPU: Gigabyte Aorus Extreme 11gb 1080ti

SSD: WD Blue 250gb

HDD: Seagate Barracuda 2tb 7200rpm 

PSU: EVGA SuperNOVA G2 Gold 750watts

Case: Fractal Design Define R6

Some games dont crash but most of them do..

Tom Clancy's Breakpoint, Risk of rain 2 and Senua's Sacrafice (didnt play too much of it) didnt crash however Darksiders 3, Borderlands 2, Risk of rain 2 (on a rare occasion would crash) and HITMAN.

Max temps were 73c on CPU

Max temps were 75c on GPU

Sorry if that above is a mess but i am really annoyed with what been happening and want to solve it cause i dont want to regret this upgrade I have loved being able to see this CPU render things in cinebench fine (as a test to see if computer would crash but did not so doubting its CPU as my work is rendering 3d models and gaming on the side). The reason i keep mentioning RAM is that on the ASrock site my older DDR4 is not one of the supported QVL memory which is where I am making this connection as i cant see anything else being the issue. 

Thanks if anyone could help!!!

0 Replies