Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

New build freezes or partial-freezes when letting Windows turn screen back on (6650 XT)

Just built a new machine, specs below; There's a couple small things that aren't working right, and one is definitely video card driver-related.


Gigabyte Z690 UD DD4

Intel i5-13600K Raptor Lake 3.5 Ghz

Corsair Vengeance RGB Pro SL 32GB (2 x 16GB) DDR4-3200 PC4-25600

ASRock Challenger Radeon RX 6650 XT 8GB

Samsung 990 PRO M.2 2280 1TB SSD - OS/boot drive

2x Samsung 990 PRO M.2 2280 2TB SSD - running mobo-supported RAID1, storage only

Asus PCE-AX58BT Wifi Card

Cooler Master N400 case

Corsair RMx Series RM850x PSU

Win10 Pro 64-bit


(FYI the other "minor" issues I'm trying to resolve are that the SATA DVD drive is only recognized sometimes & that the Intel Optane SW setup the storage drives in RAID successfully, and recognizes them as such, but won't let me create an actual Optane pairing with them.  Doubt they're related but listing just in case.)


Been trying to research on my own, and found alot of similar issues to me, but seemingly little for what exactly I'm experiencing.  So here's a summary of what seems to be unique & what I've tried to troubleshoot so far on my own.

- My machine either freezes, or only partially returns from, anytime the screen is off, but not fully powered off, and is turned back on by me triggering Windows to do so.  I worded it like this because it's NOT only waking up from sleep, as many other similar issues have.  I have the screen set to turn off after 15 min, and if that happens (without ever going to sleep), it even freezes when I try to turn the screen back on via mouse or keyboard

- Sometimes it only turns back on to a blank black screen.  Sometimes it freezes on the Windows startup/login background blue-background-color screen (but not lock screen wallpaper).  Sometimes it displays the lock screen (time & date shown).  Sometimes it displays the lock screen wallpaper, but no time/date/PIN field shown BUT the mouse still moves (so, not frozen).  Sometimes it even lets me type my PIN in but then freezes trying to log in. 

- I tried turning off the lock screen altogther, and it still would freeze during loading my desktop.

- If I enable "basic video" in msconfig, the issue does NOT exist.  Turning back on from sleep works fine then.  So it's definitely pointing toward drivers. (if I uninstall all AMD-specific video card drivers, the default Win10 driver doesn't allow sleep, so I haven't tested the issue under that driver - but I should try the screen-off scenario.  I'll do that and reply to my message here shortly)

- This first occurred by the default driver Win10 came with/pulled from MS, which is dated 4/28/22.  I've tried the latest from AMD, 23.3.1 Adrenalin, no change.  I saw 22.11.2 Adrenalin seemed to be more stable for sleep issues, so I tried that, no change.

- Confirmed I have the latest BIOS and other mobo drivers (first thing I did after turning this thing on for the first time)

- Fast Startup & hybrid sleep turned off (but those shouldn't affect the times when I'm just trying to turn the screen back on)

- Tried turning off ULPS, no change


I'm at a bit of a loss now, not sure what direction to head next, so hoping I've given enough info, and hoping someone has some idea what's going on with my machine.


Thanks in advance!  If you need more info, just let me know.

6 Replies
Adept I

- Edit: default Win10 drivers were 4/28 not 6/28

- Update: As promised, I installed the default Win10 graphics driver again (the one w/ no sleep support) and just let the screen turn off after its 15min timeout, and then turned it back on via mouse/keyboard after letting it sit.  No issue - it comes back to life without issue.

Adept I

Hi, bumping my thread!

Adept I

Some updates (no fix yet though) on new behavior/troubleshooting:
- The other day, I got my first BSOD. I had the screen to time out (but sleep still disabled). When I woke the screen up, it let me log in/type in my PIN, then it hung at the spinning cursor. Then, BSOD. It was very quick, but I caught a photo with my phone: INTERNAL_POWER_ERROR. So started going down that troubleshooting rabbit hole.
- note: hibernate is, and has always been, disabled on this machine. So size of hibernation file cannot be it(?)
- made sure all Windows updates were installed
- Since I first started all this, AMD posted new drivers 23.3.2, so I tried those using Adrenalin exe. No change
- I tried letting Windows just install the 23.3.2 drivers. Uninstalled drivers via Device Manager (going thru Add/Remove programs deletes them from my machine). Let Windows self reinstall upon restart. no change.
- I tried a more meticulous version of above. Start 23.3.2 Adrenalin exe just so the files are unzipped. Then cancelled the setup. Deleted all other driver versions in the C:\AMD folder except for that ones I just extracted. Restarted in safe mode (all following steps/reboots are in safe mode), uninstalled all AMD drivers until MS Basic Adapter installed, ran AMD Cleanup app, restarted in safe mode again, let Windows install the 23.3.2 drivers, restart in normal mode. For the FIRST time, I put the machine to sleep, and when it awoke, it was working perfectly. Let me log in, was stable, and I could use it like normal. However, every sleep attempt since goes back to original behavior. HOWEVER it does seem to be a more stable crash now (if there is such a thing) - it seems to always stick at the login screen now, with wallpaper+date/time shown+mouse moves, but hangs there indefinitely still.
- ran DISM & SFC. Latter found some corrupt files but did not change sleep behavior
Not sure if any of this helps?
Adept I

Good day! I bought this gpu from Asus 4 days ago, and till now I have same problems as you. When I installed new gpu I had old version of windows on my PC. So, when I tried to install Radeon software I got a black screen. After few attempts installed new windows. Tried to install old drivers, deleted using DDUon safe mode, turned off MPO and fast boot and nothing helped.

Once cod warzone, stalker gamma successfully opened and I had 30 min game session, in other cases games doesn't want to open and black screen and artifacts while loading .

Have you found a solution?



Hi, sorry for the long delay.

Unfortunately, no, no change, no fix found. I've just been living with it, shutting down every night.

I just update to the latest Oct AMD drivers 23.11.1, in some blind hope it'd fix it finally, but no change.

Have you?


Hello, I just refund this GPU and got 3060ti

No problems at all