Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Neither VSYNC nor limiting FPS work.

Hey there,


using an RX 580 and latest Windows 11 here, any driver side option to affect FPS is not working for me.

In games it's usually working, in Horizon Zero Dawn it's not, which is how I noticed it's not working driver side either.

I've tried fullscreen, windowed, borderless windowed nothing works.

The only thing a little special on my setup is a DVI->VGA-Adapter, could that be the reason?


I'm completely clueless and any help would be greatly appreciated!

1 Reply
Journeyman III

I am having the same issue but on Windows 10. Tried the latest recommended as well as 21.10.1, which is the latest driver for the card in this system I'm testing on (RX 570).

Both the global FRTC option and the game-specific Chill option fail to limit frames. On menus, screen transitions, and loading screens my FPS in certain games can exceed 2000+ and creates unnecessary heat, power draw, fan spin/noise, and just straight up annoys me.

Have tried removing drivers and reinstalling clean both with AMD's factory reset option and DDU in safe mode. No change.

By comparison, the FPS limiter on Nvidia software works flawlessly. This is the first AMD card I've used in a while. Seems like an AMD software/driver issue preventing this from working. Just for fun I installed a spare Nvidia card in the same system and FPS limiter in Nvidia's software works fine, locks at whatever I set it at 60fps generally). So this seems to be an AMD specific issue, not something else affecting it in this system.

Anyone else having this same issue and come up with a solution?