Showing results for 
Search instead for 
Did you mean: 

Drivers & Software


My 720p TV monitor stopped working after enabling GPU scaling - GPU scaling stuck

Hey AMD community,

A couple of days ago I encountered a severe problem with my TV monitor that I haven't been able to resolve myself yet. It involves the AMD GPU scaling function which I applied to my second monitor; a 720p JVC television-monitor.

My set-up:
Radeon RX 5700 XT in combination with a BenQ XL2411Z 1920x1080 monitor connected via an HDMI cable to the HDMI port of the card. As a second monitor, I used my old HD ready JVC LT32G80BU 1280x720 monitor which I connected with a display port to HDMI cable to the display port of my video card.  

The problem:
It worked fine except for a little overscan on my JVC monitor so one day I decided to try and fix that. While doing so I enabled GPU scaling in the monitor settings in the Radeon Software. When I did this, my JVC monitor immediately lost signal, so I quickly disabled GPU scaling again. This is when the problem started: Disabling GPU scaling did not turn my JVC monitor back on.

I have tried nearly anything I could think of; used the AMD uninstallation tool in safe mode, removed AMD Radeon software and installed it cleanly after. No results. Using purely my HDMI cable with the JVC monitor and my BenQ disconnected also didn't help. Even applying a custom resolution did not work.

What I think is the issue:
When I open Windows Display Settings for my JVC monitor I see a Display Resolution of 1280 x 720; the correct resolution. However, when I press Advanced Display Settings it shows a Desktop and Active Signal resolution of 1920 x 1080; which is out of reach for the 1280 x 720 monitor.

Extra info:
*When I make a screenshot with both monitors connected I can see my main (BenQ) screen resolution fits correctly, but my second JVC screen resolutions seems like a 1920 x 1080 screen with a 1280 x 720 screen inside it. Around the 1280 x 720 screen, there is a black letterbox.

*When I enable AMD Eyefinity my JVC monitor comes back to live (but it is useless because it doesn't scale/work properly with 2 vastly different screen resolutions).

*When I start my PC my JVC monitor will work while in the BIOS menu and post BIOS screen. Only when Windows boots up and the AMD Radeon Software takes over the JVC monitor immediately loses signal.

*When the problem first occurred, my PC ran AMD Radeon 20.5.1, rolling back to latest stable release 20.4.2 did not resolve the issue.

I have already sent Radeon Software feedback, most of the text above and below comes from that. I'm curious to see if anyone else has encountered a similar issue. I'll try to keep this thread updated if I somehow someday manage to fix this without having to reinstall Windows 10.

PC Build info:

CPU: AMD Ryzen 5 3600 - 6 core, 12 threads - 3892 MHz

Display / Display connection info:
BenQ XL2411Z 1920x1080 monitor connected via an HDMI cable to the HDMI port of the card.
On the HDMI cable, the following is printed: " High speed with ethernet E205663 AWM STYLE 20276 80C 30V VW-1 ". A little over 1 meter it is connected via the HDMI out from the display to the only available HDMI port on the 5700 XT.

JVC LT32G80BU 1280x720 TV monitor connected via HDMI to Display Port cable connected to the Display port of the card (various positions). I have also tried connecting the monitor with the HDMI cable.
On the HDMI to Display Port cable, there is no text printed, but I do know its specifications form the vendor:

Type: 1.1 - 1920 x 1080,
Connection 1: DisplayPort Male,
Connection 2: HDMI Male,
Connections: DP 20 pin,
Signal: Digital,
Diameter: 5.0 mm,
Version: DP 1.1,
Ader: CU (copper),
Kable length: 1.5 meters.

Motherboard info:
Model: ROG STRIX X570-F GAMING rev X.0X
BIOS ver: American Megatrends Inc. 1405, 19/11/2019

RAM: 2x Corsair Dominator Platinum RGB CMT16GX4M2C3600C18 (2x 8GB DDR 4)

Windows 10 build 1903

Power supply: 700 Watts

1 Reply

Update: I have found a thread from a couple of years ago from someone experiencing a similar issue: GPU scaling cannot be turned off 

In this case the issue seemed to be resolved by manually removing Windows Registry entry HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0001].

In my case it's HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0000 but manually removing this registry and rebooting did not help.

Also I tried uninstalling the driver with DDU in safe mode to see if that would help but also not.