cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

sampler
Adept I

Multiple Driver Errors on ASUS RX5700-8G

Jump to solution

Recently built a rig with a Ryzen 3600, 16GB Corsair Vengence and an ASUS Prime A320i-k. I'm using a NVME 1TB SSD for the OS and have a Corsair 750W SFF PSU which I've used in another set-up and believe to be providing enough stable power.

I use the computer for work (work from home) so is on about ten hours a day and I'm getting 5-6 BSOD's a day with errors such as:

VIDEO_TDR_FAILURE (atikmpag.sys)

VIDEO_SCHEDULAR_INTERNAL_ERROR

(should've written the others down, but these are two from this morning, it's been on forty minutes)

I've tried the latest drivers direct from AMD: 19.12.3, then cleaned with DDU and tried 19.12.2  downloaded via ASUS's site, then jumped way back to 19.10.1 which has been the most stable (the aforementioned 5-6 crashes a day) after a complete operating system wipe and re-install (Win10 x64 Pro). On the fresh install I held off installing any drivers for a couple of days (which only allowed me to use the HDMI port) and the system was stable and fine hooked up to a 4k@60Hz.

I'm running three displays - 2x4k@60Hz (one on Display port, the other HDMI) and a 1080P@144Hz on Display port (currently running at 60Hz as I've read that can contribute to the first error above). These displays were no problem for my old Sapphire Radeon R9 280 Dual-X 3GB OC (admittedly the 1080p@60Hz on HDMI and the HDMI 4k@30Hz) in my previous build with an A8 6600k.

Workload is nothing strenuous, bunch of chrome tabs and excel - yesterdays average cpu utilisation was 2.1%, peak 79%, which brings me to my next issue, only occasionally with the GPU show up in AIDA64 and even if the system doesn't crash I got odd glitches and slow downs (changing chrome tabs will lock chrome up and I hold my breath as to whether it'll crash or I'll just get a windows notification that Chrome isn't allowed to access the GPU any more. Some times the screen will blink and the 4k monitor on the Display Port will lose the 150% scaling on the taskbar or start menu (or both, but, only them), when the systems resumes from screensaver all the windows have moved to the primary screen and resized, sometimes clicking a minimised window on the taskbar makes it maximise on the wrong screen. All very, weird, odd problems I've not seen before.

When the GPU does show up in AIDA64 the temps all seem ok, peak 49 GPU, 50 Hotspot, 52 Memory and 40 VRM (Celsius) and GPU powers all look fine. More confusing is I can run 3DMark without a crash, done about seven run throughs, score is about what you'd expect (7854 on the last).

Am I expecting too much? It doesn't seem to be taxed so load doesn't seem to be an issue, have I just been too unlucky with drivers? Or do people feel I've got a faulty card? With the couple of days without drivers and without an issue, it would seem more likely it's the software right?

I used to be an IT engineer for about two decades and I've never had something so flakey in my experience, long time AMD user and mostly an ATI user before they were subsumed but never known anything like it (in fact, a C2D2600 and a GT6600 are my only strays away).

0 Likes
1 Solution

Accepted Solutions
sampler
Adept I

Re: Multiple Driver Errors on ASUS RX5700-8G

Jump to solution

So, after more tinkering, this fault could be attributed to using a PCI-e riser cable.

One thing I hadn't mentioned, I was using a Dan A4 which is a sandwich style case, uses a PCI-e riser to connect the GPU in the other side of the case.

I've since sold it and have the machine just on the bench out of a case, card connected directly and it's working perfectly fine now.

So, if you came across this searching similar symptoms, try re-seating your card if it's directly connected or replacing your riser cable if not.

View solution in original post

2 Replies
sampler
Adept I

Re: Multiple Driver Errors on ASUS RX5700-8G

Jump to solution

The irony, posted this, another VIDEO_TDR_FAILURE BSOD = \

Noticed that there were new drivers out yesterday, 20.1.1 - booted to safe mode, removed the old with DDU, rebooted to normal, installed, rebooted to complete the install and crashed, not even managed to give a BSOD, just black screens all round  = (

[Edit]

Went all the way back to 19.7.5 and been stable for the rest of the day, least in terms of BSOD's - showing back up in AIDA64 too but glitches are still abound (just come back to from making a coffee to find all browsers on the primary screen rather than split, start menu was tiny, now back to normal without restarting explorer.exe).

I'm very confused, I'd like to be able to use the latest drivers, I do occasionally play the odd game (have Resident Evil 2 remake sat waiting on steam), hence getting the 5700 to start with.

[Edit2, as I await mod approval]

Been running six hours flat, have attached a screengrab of the performance/heat numbers, barely using the card as you can see. Odd problems all arvo, two "Application has been blocked from accessing Graphics hardware" for chrome.exe as I tried to open this tab.

0 Likes
sampler
Adept I

Re: Multiple Driver Errors on ASUS RX5700-8G

Jump to solution

So, after more tinkering, this fault could be attributed to using a PCI-e riser cable.

One thing I hadn't mentioned, I was using a Dan A4 which is a sandwich style case, uses a PCI-e riser to connect the GPU in the other side of the case.

I've since sold it and have the machine just on the bench out of a case, card connected directly and it's working perfectly fine now.

So, if you came across this searching similar symptoms, try re-seating your card if it's directly connected or replacing your riser cable if not.