Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

MSI B550 Tomahawk latest bios

Anybody having issues with latest bios Agesa 12.0.7 trapped in Dianosing PC boot loop issue Windows 10.

Bios version 7C91vAA1

Mobo: MSI B550 Tomahawk

CPU: AMD 5800x

Gpu: Asus TUF 6700XT

Memory: Patriot Viper Steel 32GB (2x16GB) DDR4 PC4-28800C18 3600MHz
Dual Channel Kit (PVS432G360C8K)

Tried resetting CMOS. Everything is on default settings in BIOS. No over clocking.

11 Replies
Adept II

Also tried the following repairs but everything was 100% good.

sfc /scannow 

Dism /Online /Cleanup-Image /CheckHealth
Dism /Online /Cleanup-Image /ScanHealth
Dism /Online /Cleanup-Image /RestoreHealth


In BIOS or in Windows disable automatic reboot so that way it should stop the booting cycle and you have a chance to see any errors that might be showing after crashing.

You have installed  a BETA BIOS version which might be buggy. I would first downgrade to the latest Non-BETA version 7C91vA9 and see if the reboots cycle continues or not.

If it does continue does it crash during POST or when BIOS is enable to be entered or when Windows starts loading after POST?

Did you have BIOS originally set in CSM Mode or strictly UEFI Mode with Secure Boot enabled? 

Reason why I ask is because the BETA BIOS changes the default setting of Secure Boot:

- Update to AGESA ComboAm4v2PI
- Change the default setting of Secure Boot.

If the PC reboots after POST and while Windows starts to load indicates a driver that is causing your issue that is either incompatible or corrupted with some hardware you have connected.

If it happens during POST then it is either some defective hardware or incompatible hardware you have connected to your motherboard after downgrading your BETA BIOS to a Non-BETA BIOS version.


My PC boot perfect with Previous bios based on agesa 12.0.6c. Guess that's the answer for now, but never had this issue before. 

It's always booted using UEFI. Not sure about secure boot, never changed any settings to this, always been on default. 

Using TPM module and not cpu ftpm. But tried booting both ways.


See if you are able to downgrade your BETA BIOS to the latest Non-BETA BIOS to stop the reboots.

If it does fix the problem since you mentioned it started after updating to the BETA BIOS I would notify MSI Support about the problem you were having so that they can take a close look at the BETA BIOS they have for downloading.


Using the latest chipset drivers

AMD Driver 22.5.1

Tried booting in safe mode and same issue.


This happened with the Non-BETA BIOS installed?

No. Just this one beta bios version


Only hardware which maybe driver related is the TPM msi card, or startech 2 port esata card.

More testing I think. Will remove items and try again.

Yes, to tell you the truth, it sounds like the BETA BIOS may not be compatible with a connected hardware now that was compatible with the Non-BETA BIOS version.

What you are doing is the one way to find the problematic hardware that is causing the rebooting with the new BIOS.


Hi. I updated drivers for Asmedia 106x SATA controller card using windows update, down loaded the bios file again and flashed. No more issues booting into Windows 10.

Noticed the flash time was longer than previous efforts, so may have been either driver or bad flash ?



I'll report to MSI. I just wondered if anybody else was having same issues. 


Thanks for your help.